symbol lookup error: /usr/lib/torcs/modules/graphic/ssggraph.so

Bug #43660 reported by Cristian Aravena Romero on 2006-05-08
10
Affects Status Importance Assigned to Milestone
torcs (Ubuntu)
Medium
Reinhard Tartler

Bug Description

Binary package hint: torcs

Not play game. I use Dapper Beta.

caravena@hefesto:/etc/X11$ torcs
Visual Properties Report
------------------------
Compatibility mode, properties unknown.
freeglut (/usr/lib/torcs/torcs-bin): Unable to create direct context rendering for window '/usr/lib/torcs/torcs-bin'
This may hurt performance.
Xlib: extension "XFree86-DRI" missing on display ":0.0".
WARNING: ssgLoadTexture: Cannot determine file type for './(null)'
GfParmCheckHandle: parameter "Rear Right Suspension/packers" out of bounds: min:0 max:0.01 val:0.02 in ("Tanhoj" - "drivers/tanhoj/tracksdata/car_g-track-3.xml")
GfParmCheckHandle: parameter "Rear Left Suspension/packers" out of bounds: min:0 max:0.01 val:0.02 in ("Tanhoj" - "drivers/tanhoj/tracksdata/car_g-track-3.xml")
open /dev/[sound/]dsp: Device or resource busy
terminate called after throwing an instance of 'char const*'
/usr/games/torcs: line 52: 7885 Abortado $LIBDIR/torcs-bin -l $LOCAL_CONF -L $LIBDIR -D $DATADIR $*
caravena@hefesto:/etc/X11$ torcs
Visual Properties Report
------------------------
Compatibility mode, properties unknown.
freeglut (/usr/lib/torcs/torcs-bin): Unable to create direct context rendering for window '/usr/lib/torcs/torcs-bin'
This may hurt performance.
Xlib: extension "XFree86-DRI" missing on display ":0.0".
WARNING: ssgLoadTexture: Cannot determine file type for './(null)'
GfParmCheckHandle: parameter "Rear Right Suspension/packers" out of bounds: min:0 max:0.01 val:0.02 in ("Tanhoj" - "drivers/tanhoj/tracksdata/car_g-track-3.xml")
GfParmCheckHandle: parameter "Rear Left Suspension/packers" out of bounds: min:0 max:0.01 val:0.02 in ("Tanhoj" - "drivers/tanhoj/tracksdata/car_g-track-3.xml")
OpenAL backend info:
  Vendor: OpenAL Community
  Renderer: Software
  Version: 1.1
  Available sources: 1024 or more
  Available buffers: 1024 or more
/usr/lib/torcs/torcs-bin: symbol lookup error: /usr/lib/torcs/modules/graphic/ssggraph.so: undefined symbol: alutLoadWAVFile

Emmet Hikory (persia) on 2006-05-09
Changed in torcs:
status: Unconfirmed → Confirmed
Dennis Kaarsemaker (dennis) wrote :

Reinhard, this looks like a bad openal migration :)

Changed in torcs:
assignee: nobody → siretart
Reinhard Tartler (siretart) wrote :

yeah, it looks for a symbol which used to be in openal, but has moved now to freealut. Need to investigate what went wrong during compilation.

Emmet Hikory (persia) wrote :

A temporary workaround for those hit with this bug is to use the plib sound system (Select Options, Sound from the main menu).

The attached debdiff applies a patches to config.h.in, configure.in, and the offending Makefile to really link against libalut (which makes it work :)).

Reinhard Tartler (siretart) wrote :

Thank you for your patch, Emmet. I uploaded the package for you.

Changed in torcs:
status: Confirmed → Fix Committed
Emmet Hikory (persia) wrote :

Built on all architectures. Thanks for uploading.

Changed in torcs:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers