Torbutton say it is using Tor but it isn't

Bug #273027 reported by clovepower on 2008-09-22
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Torbutton
New
Undecided
Unassigned
torbutton (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by James
Nominated for Lucid by James

Bug Description

Ubuntu 8.04.1 AMD64
Linux set 2.6.24-19-generic #1 SMP Wed Aug 20 17:53:40 UTC 2008 x86_64 GNU/Linux

I've installed:

torbutton-extension 1.0.4-2ubuntu1
privoxy 3.0.8-1
tor 0.1.2.19-2

from synaptic.

Tor button does not show up in Firefox 3.0.1.

Then, I removed torbutton from synaptic and installed Tor Button from Firefox extension site. Now Tor button appears in status bar, but it's not working (it switches from enabled/disabled but the traffic is never relied to the proxy it seems).

Can provide more debug if required.
Tnx

clovepower (mzattera) wrote :

Note that this is a potential security threat since it gives user the illusion that TOR is enabled, while it's not...

Setting confirmed since I have had those issues as well.

The reason that it does not show up in Firefox 3 is that the version of Torbutton in Ubuntu is old and not made for Firefox 3. Bug 247867 already covers that.

When it comes to the other issue you mention: Does it still pretend to be using Tor without actually using it when Tor and Privoxy is installed? You can check by going to http://check.torproject.net/ (If it does it will make it easier to find out where this bug is)

Changed in torbutton:
status: New → Confirmed

One more thing: Could you please check that it is in fact Torbutton 1.2.0 and not a Release Candidate you have? You can check by right clicking on the Torbutton and choose About Torbutton. (RC6 was on addons.mozilla.org) I wasn't able to reproduce the "green but not connected" error with 1.2.0, even if I have seen it before.

clovepower (mzattera) wrote :

OK, here is how to reproduce second part of the issue:

1. Open Synaptic and install torbutton-extension, privoxy and tor

2. Open Firefox 3, torbutton is not showing (as already noticed)

3. Close Firefox

4. Open Synaptic, choose torbutton-extension and choose "Mark for Complete Removal" and uninstall it

5. Open Firefox, go to Tools > Add Ons, search for torbutton extension and install it. Restart Firefox as requested.

6. hen Firefox opens again, Torbutton will show on status bar, click on it so "Torbutton Enabled" appears in green

7. Hit http://check.torproject.net/, you will see that torbutton is not enabled

Try to navigate to other sites, you should be able to go everywhere and you will see Tor is obviously not used, even if "Tor Enabled" appears. Sometimes you can experience hangs during navigation.

I checked and I've Torbutton 1.2.0 installed.

clovepower (mzattera) wrote :

Here is a screenshot to confirm the behavior.

Note then when I say I've torbutton 1.2.0 I mean this is the version downloaded form the plugins page. As you noted, the version in Synaptic is older.

clovepower (mzattera) wrote :

...also, try to reproduce the steps above as close as possible, as I said, sometimes navigation just hangs instead. That appears to be the case if you open a new tab and try to use that for navigation when torbutton is enabled.

clovepower (mzattera) wrote :

OK, this ones has less private data :-)

I was still not able to reproduce it, but since I have seen it myself before i filed it upstream as http://bugs.noreply.org/flyspray/index.php?do=details&id=832

Just a few comments:
* Even if I was not able to reproduce the bug by following the steps above letter by letter, I remember the thing about navigation hanging so I am quite sure that this is the same bug I used to see.
* I'm using the Hardy packages firefox 3.0~b5+nobinonly-0ubuntu3, privoxy 3.0.8-1 and tor 0.1.2.19-2 on an amd64 system
* The reason I haven't added a remote bugwatch is that launchpad isn't able to import it. See 28738

Could you create a new Ubuntu account (or you don't have permission to do that: create an extra Firefox profile) and see if you can reproduce the problem there too?

clovepower (mzattera) wrote :

1. Create a new desktop user using System > Administration > Users and Groups

2. Switch to the newly created user

3. Open Firefox and install torbutton add on

Same behavior as above (green TOR button but TOR disabled).

Note I did not touched TOR and Privoxy installs for this test.

clovepower (mzattera) wrote :

OK, Just to throw some insights into this.

I've removed torbutton add-on and manually instructed Firefox to use privoxy (as you can see in the included screen shot).

Still, it appears I'm not using TOR while browsing.

If I'll have some time today, I'll try to check TOR and Privoxy configuration (I'm new to Ubuntu so this might take some time :-))

clovepower (mzattera) wrote :

OK, one issue was that Privoxy when installed is NOT configured to use TOR.

After I followed install instructions for Privoxy as explained here:

http://www.torproject.org/docs/tor-doc-unix.html.en

I can use TOR but ONLY if I enable Privoxy manually by configuring Firefox proxy settings (as shown in the previous screen shot).

I'm not sure what is the best course of action with this, if this is intentional Privoxy behavior and should be left as it is, if I should enter a bug or what. Please advise on this. IMHO when installing torbutton form synaptic, it should also install tor and privoxy properly configured, but I can be wrong.

Still, if I click on torbutton and enable it, I am now hanging on each page I try to visit and I get a blanc tab as shown in included screen shot.

Giorgio Wicklein (giowck) wrote :

I confirm this. It is not a bug or something like that, simply Privoxy is not configured to use Tor. Synaptic should configure it (IMHO).

To use Tor and torbutton through Privoxy:

1. Install tor and privoxy from your package manager.
2. Edit privoxy's configuration file: /etc/privoxy/config and replace all content with this default settings:

# Generally, this file goes in /etc/privoxy/config
#
# Tor listens as a SOCKS4a proxy here:
forward-socks4a / 127.0.0.1:9050 .
confdir /etc/privoxy
logdir /var/log/privoxy
actionsfile standard # Internal purpose, recommended
actionsfile default # Main actions file
actionsfile user # User customizations
filterfile default.filter

# Don't log interesting things, only startup messages, warnings and errors
#logfile logfile
#jarfile jarfile
#debug 0 # show each GET/POST/CONNECT request
debug 4096 # Startup banner and warnings
debug 8192 # Errors - *we highly recommended enabling this*

user-manual /usr/share/doc/privoxy/user-manual
listen-address 127.0.0.1:8118
toggle 1
enable-remote-toggle 0
enable-edit-actions 0
enable-remote-http-toggle 0
buffer-limit 4096

3. Restart privoxy to apply the changes: "sudo /etc/init.d/privoxy restart"
4. Install torbutton from the firefox's add on site, because the torbutton package in synaptic is obsolete...

On ubuntu 8.10 (intrepid) this "issue" is not "fixed".

I hope this can help!

clovepower (mzattera) wrote :

Thanks Giorgio, that basically reflects the changes I made to get privoxy to work, still enabling torbutton gives me a blank tab.

I'm thinking about entering a bug/change request to turn torbutton into a meta-package that installs all the 3 components together and configure them properly.

Giorgio Wicklein (giowck) wrote :

The biggest problem is that if someone installs the torbutton package from the official repository it will not work since firefox 3 is now the default browser.

After the procedure, explained in my other comment, i had no problem like the white tab...

clovepower wrote:
"I'm thinking about entering a bug/change request to turn torbutton into a meta-package that installs all the 3 components together and configure them properly."

Yes that would be nice!

Keep us informed, thanks!

ciao

cally03 (calyps007) wrote :

I've had the same problem, but I found a solution.

On installation, Ubuntu just puts in the default config file for privoxy without setting it up. Go to http://www.torproject.org/docs/tor-doc-unix.html.en and go to the instructions for Step Two to set up the privoxy config file. After testing it in the browser, it works like a charm.

clovepower (mzattera) wrote :

To Giorgio and cally:

This is NOT a Privoxy issue, I edited the files manually already and Firefox works like a charm if I instruct it to use Privoxy for all the traffic.

The issue is Tor or TorButton related....I'll take some time to dig into TOR config eventually.

Maxi

@ Giorgio Wicklein
I tried Your configuration (I just changed actions file names to end with .actions, as this is how actually those files are named in Ubuntu) - no difference. Still everybody sees my IP very clearly...

I use last TorButton from Mozilla addons site. What can I do to repair it?

Upstream just marked my previous mentioned bugreport as a dupe of http://bugs.noreply.org/flyspray/index.php?do=details&id=564 Since Launchpad still can't track upsream's bugtracker (Flyspray, see bug #28738 for status on this) I'm posting the new URL here.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers