[UNMETDEPS] torbutton: auto-synced, depends on iceweasel

Bug #137513 reported by Philipp Kern
8
Affects Status Importance Assigned to Milestone
torbutton (Ubuntu)
Medium
Unassigned
Gutsy
Medium
Unassigned
Hardy
Medium
Unassigned

Bug Description

torbutton (binary package: iceweasel-torbutton) was automatically synced from Debian and depends on the iceweasel package not available in Ubuntu. So the package should either be fixed to depend on Ubuntu Firefox and to install into the correct directories or be removed from Ubuntu.

Related branches

Philipp Kern (pkern)
description: updated
Revision history for this message
Christophe Sauthier (christophe.sauthier) wrote :

I'm working on it.

Changed in torbutton:
assignee: nobody → christophe-sauthier
status: New → Confirmed
Changed in torbutton:
status: Confirmed → In Progress
Revision history for this message
Kyle M Weller (kylew) wrote :

torbutton does not work in Gutsy Beta's firefox, it causes 100% cpu usage on firefox restart

Revision history for this message
Christophe Sauthier (christophe.sauthier) wrote :

torbutton (1.0.4-2ubuntu1) gutsy; urgency=low

  * Add of a possible dependency to firefox or iceweasel (LP: #137513)
    - Modification of the Depend Field of the debian/control file
    - Modification of debian/iceweasel-torbutton.dirs,
      debian/iceweasel-torbutton.install and debian/iceweasel-torbutton.links
      to take into account firefox extensions directory.
  * Modify Maintainer value to match Debian-Maintainer-Field Spec

 -- Christophe Sauthier <email address hidden> Thu, 4 Oct 2007 12:16:48 +0200

Changed in torbutton:
assignee: christophe-sauthier → nobody
status: In Progress → Confirmed
Philipp Kern (pkern)
Changed in torbutton:
importance: Undecided → Medium
Revision history for this message
Philipp Kern (pkern) wrote :

Hm, this would be confusing as torbutton would be the only package prefixed with `iceweasel-'.

Revision history for this message
Christophe Sauthier (christophe.sauthier) wrote :

What can I do for that ?

Revision history for this message
Christophe Sauthier (christophe.sauthier) wrote :

torbutton (1.0.4-2ubuntu1) gutsy; urgency=low

  * Add of a possible dependency to firefox or iceweasel (LP: #137513)
    - Modification of the Depend Field of the debian/control file
    - Modification of debian/iceweasel-torbutton.dirs,
      debian/iceweasel-torbutton.install and debian/iceweasel-torbutton.links
      to take into account firefox extensions directory.
    - Linkage of the iceweasel extension directory to the firefox one, instead
      of duplicating the extension.
  * Modify Maintainer value to match Debian-Maintainer-Field Spec

 -- Christophe Sauthier <email address hidden> Thu, 4 Oct 2007 13:43:25 +0200

Revision history for this message
Christophe Sauthier (christophe.sauthier) wrote :

torbutton (1.0.4-2ubuntu1) gutsy; urgency=low

  * Rename of the binary package to remove the mozilla product name, and
    change it to torbutton-extension
  * Add of a possible dependency to firefox or iceweasel (LP: #137513)
    - Modification of the Depend Field of the debian/control file
    - Modification of debian/iceweasel-torbutton.dirs,
      debian/iceweasel-torbutton.install and debian/iceweasel-torbutton.links
      to take into account firefox extensions directory and renaming them
      to the new binary package schema (torbutton-extension.*)
    - Linkage of the iceweasel extension directory to the firefox one, instead
      of duplicating the extension.
    - Change of the description to reflect the firefox compatibility
  * Modify Maintainer value to match Debian-Maintainer-Field Spec

 -- Christophe Sauthier <email address hidden> Fri, 5 Oct 2007 12:34:
01 +0200

Changed in torbutton:
assignee: nobody → christophe-sauthier
Revision history for this message
Christophe Sauthier (christophe.sauthier) wrote :

torbutton (1.0.4-2ubuntu1) gutsy; urgency=low

  * Merge of the two extension (iceweasel and icedove) to the same one, that
    deals with both.
  * Rename of the binary package to remove the mozilla products name, and
    change it to torbutton-extension.
  * Add of a possible dependency to firefox or iceweasel (LP: #137513)
    - Modification of the Depend Field of the debian/control file
    - Modification of debian/iceweasel-torbutton.dirs,
      debian/iceweasel-torbutton.install and debian/iceweasel-torbutton.links
      to take into account firefox extensions directory and renaming them
      to the new binary package schema (torbutton-extension.*)
    - Linkage of the iceweasel extension directory to the firefox one, instead
      of duplicating the extension.
    - Change of the description to reflect the firefox compatibility
  * Add of a possible dependency to thunderbird or icedove
    - Modification of the Depend Field of the debian/control file
    - Modification of the debian/torbutton-extension.* files to take into
      account thunderbird extensions directory.
    - Linkage of the icedove extension directory to the firefox one, instead
      of duplicating the extension.
    - Linkage of the thunderbird extension directory to the firefox one, instead
      of duplicating the extension.
    - Change of the description to reflect the icedove compatibility
    - Change of the description to reflect the thunderbird compatibility
  * Modify Maintainer value to match Debian-Maintainer-Field Spec

 -- Christophe Sauthier <email address hidden> Wed, 10 Oct 2007 23:56:10 +0200

Changed in torbutton:
assignee: christophe-sauthier → nobody
Changed in torbutton:
status: Confirmed → Fix Committed
Revision history for this message
Cesare Tirabassi (norsetto) wrote :

Why is this fix committed?

Changed in torbutton:
assignee: nobody → christophe-sauthier
status: Fix Committed → Incomplete
Revision history for this message
Christophe Sauthier (christophe.sauthier) wrote :

Just because sometimes I am a bit dump, and that I've cheched the wrong option....

Changed in torbutton:
assignee: christophe-sauthier → nobody
status: Incomplete → Confirmed
Changed in torbutton:
assignee: nobody → norsetto
status: Confirmed → In Progress
Revision history for this message
Cesare Tirabassi (norsetto) wrote :

For gutsy please consider:

1) asking for a removal or
2) asking for an SRU or
3) asking for a backport

Changed in torbutton:
importance: Undecided → High
status: New → Confirmed
importance: High → Medium
Revision history for this message
Christophe Sauthier (christophe.sauthier) wrote :

torbutton (1.0.4-2ubuntu1) hardy; urgency=low

  * Merge the two extensions (iceweasel and icedove) to a unique one
  * Change the binary package name to torbutton-extension
  * Add a possible dependency to firefox or iceweasel (LP: #137513)
    - Modification of the Depend Field of the debian/control file
    - Modification of debian/iceweasel-torbutton.dirs,
      debian/iceweasel-torbutton.install and debian/iceweasel-torbutton.links
      to take into account firefox extensions directory and renaming them
      to the new binary package schema (torbutton-extension.*)
    - Linkage of the iceweasel extension directory to the firefox one, instead
      of duplicating the extension
    - Change of the description to reflect the firefox compatibility
  * Add a possible dependency to thunderbird or icedove
    - Modification of the Depend Field of the debian/control file
    - Modification of the debian/torbutton-extension.* files to take into
      account thunderbird extensions directory.
    - Linkage of the icedove extension directory to the firefox one, instead
      of duplicating the extension.
    - Linkage of the thunderbird extension directory to the firefox one, instead
      of duplicating the extension.
    - Change of the description to reflect the icedove compatibility
    - Change of the description to reflect the thunderbird compatibility
  * Modify Maintainer value to match Debian-Maintainer-Field Spec

 -- Christophe Sauthier <email address hidden> Wed, 10 Oct 2007 23:56:10 +0200

Changed in torbutton:
status: Fix Committed → Fix Released
Revision history for this message
Cesare Tirabassi (norsetto) wrote :

Uploaded to hardy. Thanks for your hard work!

Changed in torbutton:
assignee: norsetto → nobody
status: In Progress → Fix Committed
Revision history for this message
Philipp Kern (pkern) wrote :

I would say that a removal is unfeasible, a SRU not really appropriate and a backport the way to go if you want to fix this in Gutsy.

Revision history for this message
Christophe Sauthier (christophe.sauthier) wrote :

Ok, so let's go for a backport... The underlying question is : what do I have to do ? since it will be my first one... :)

Revision history for this message
Cesare Tirabassi (norsetto) wrote :

https://help.ubuntu.com/community/UbuntuBackports

It would help if you can backport, build and test the package already (I have never used sharkattack myself so I can't advise you on that).
You can contact jdong on #ubuntu-motu if you need help with the process.

Changed in torbutton:
status: Confirmed → Invalid
Revision history for this message
John Dong (jdong) wrote :

Spoke with requester in IRC, built in Gutsy pbuilder and installed fine, Approved:

 torbutton | 1.0.4-2ubuntu1 | hardy/universe | source

Changed in gutsy-backports:
status: New → In Progress
Revision history for this message
Martin Pitt (pitti) wrote :

 * Trying to backport torbutton...
  - <torbutton_1.0.4.orig.tar.gz: downloading from librarian>
  - <torbutton_1.0.4-2ubuntu1.diff.gz: downloading from librarian>
  - <torbutton_1.0.4-2ubuntu1.dsc: downloading from librarian>
I: Extracting torbutton_1.0.4-2ubuntu1.dsc ... done.
I: Building backport of torbutton-1.0.4 as 1.0.4-2ubuntu1~gutsy1 ... done.

Changed in gutsy-backports:
assignee: nobody → pitti
status: In Progress → Fix Released
Revision history for this message
Kyle M Weller (kylew) wrote : Re: [Bug 137513] Re: [UNMETDEPS] torbutton: auto-synced, depends on iceweasel

torbutton didnt work w/ubufox, does it now?
Thanks
Kyle
Happy Holidays!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers