systemd-sysusers exits with Segmentation fault while creating the tomcat user

Bug #1848614 reported by Allan Thompson on 2019-10-18
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
systemd
Fix Released
Unknown
tomcat9 (Ubuntu)
Undecided
Unassigned

Bug Description

When trying to run this manually from /var/lib/dpkg/info/tomcat9.postinst:
systemd-sysusers
Creating group tomcat with gid 998.
Creating user tomcat (Apache Tomcat) with uid 998 and gid 998.
Segmentation fault

We are fairly certain this is related to https://github.com/systemd/systemd/issues/6512

Some groups have lots of members (290+) which can make /etc/gshadow lines long

------------------------------------------------

OS Info:
Distributor ID: Ubuntu
Description: Ubuntu 18.04.3 LTS
Release: 18.04
Codename: bionic

------------------------------------------------
Package Install:
sudo apt-get install tomcat9
Reading package lists... Done
Building dependency tree
Reading state information... Done
Suggested packages:
  tomcat9-admin tomcat9-docs tomcat9-examples tomcat9-user
Recommended packages:
  libtcnative-1
The following NEW packages will be installed:
  tomcat9
0 upgraded, 1 newly installed, 0 to remove and 20 not upgraded.
Need to get 35.9 kB of archives.
After this operation, 306 kB of additional disk space will be used.
Get:1 http://internal_mirror/bionic-upstream-unstable bionic/main amd64 tomcat9 all 9.0.16-3ubuntu0.18.04.1 [35.9 kB]
Fetched 35.9 kB in 0s (366 kB/s)
Selecting previously unselected package tomcat9.
(Reading database ... 153075 files and directories currently installed.)
Preparing to unpack .../tomcat9_9.0.16-3ubuntu0.18.04.1_all.deb ...
Unpacking tomcat9 (9.0.16-3ubuntu0.18.04.1) ...
Setting up tomcat9 (9.0.16-3ubuntu0.18.04.1) ...
Creating group tomcat with gid 998.
Creating user tomcat (Apache Tomcat) with uid 998 and gid 998.
Segmentation fault
dpkg: error processing package tomcat9 (--configure):
 installed tomcat9 package post-installation script subprocess returned error exit status 139
Errors were encountered while processing:
 tomcat9
E: Sub-process /usr/bin/dpkg returned an error code (1)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in tomcat9 (Ubuntu):
status: New → Confirmed
Changed in systemd:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.