backport tomcat & dependencies for OpenJDK 11

Bug #1817567 reported by Matthias Klose on 2019-02-25
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
eclipse-debian-helper (Ubuntu)
Bionic
Undecided
Unassigned
eclipse-emf (Ubuntu)
Bionic
Undecided
Unassigned
eclipse-jdt-core (Ubuntu)
Bionic
Undecided
Unassigned
eclipse-jdt-debug (Ubuntu)
Bionic
Undecided
Unassigned
eclipse-jdt-ui (Ubuntu)
Bionic
Undecided
Unassigned
eclipse-platform-debug (Ubuntu)
Bionic
Undecided
Unassigned
eclipse-platform-resources (Ubuntu)
Bionic
Undecided
Unassigned
eclipse-platform-runtime (Ubuntu)
Bionic
Undecided
Unassigned
eclipse-platform-team (Ubuntu)
Bionic
Undecided
Unassigned
eclipse-platform-text (Ubuntu)
Bionic
Undecided
Unassigned
eclipse-platform-ua (Ubuntu)
Bionic
Undecided
Unassigned
eclipse-platform-ui (Ubuntu)
Bionic
Undecided
Unassigned
el-api (Ubuntu)
Bionic
Undecided
Unassigned
equinox-bundles (Ubuntu)
Bionic
Undecided
Unassigned
equinox-framework (Ubuntu)
Bionic
Undecided
Unassigned
equinox-p2 (Ubuntu)
Bionic
Undecided
Unassigned
jetty9 (Ubuntu)
Bionic
Undecided
Unassigned
Cosmic
Undecided
Unassigned
jsp-api (Ubuntu)
Bionic
Undecided
Unassigned
libeclipse-emf (Ubuntu)
Bionic
Undecided
Unassigned
servlet-api (Ubuntu)
Bionic
Undecided
Unassigned
swt4-gtk (Ubuntu)
Bionic
Undecided
Unassigned
tomcat-native (Ubuntu)
Bionic
Undecided
Unassigned
tomcat8 (Ubuntu)
Bionic
Undecided
Unassigned
Cosmic
Undecided
Unassigned
tomcat9 (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
Cosmic
Undecided
Unassigned
websocket-api (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

backport tomcat & dependencies for OpenJDK 11

Part of the LP: #1814133 transition.

NOTE TO SRU MEMBERS: The packages are to be released into bionic-security ONLY. This will be done/decided by the security team.

Matthias Klose (doko) on 2019-02-25
no longer affects: maven-debian-helper (Ubuntu)
description: updated
Changed in eclipse-emf (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Changed in jetty9 (Ubuntu Bionic):
status: New → Fix Committed
Changed in swt4-gtk (Ubuntu Bionic):
status: New → Fix Committed
Changed in tomcat-native (Ubuntu Bionic):
status: New → Fix Committed
Changed in tomcat8 (Ubuntu Bionic):
status: New → Fix Committed
Changed in eclipse-debian-helper (Ubuntu Bionic):
status: New → Fix Committed
Changed in eclipse-jdt-core (Ubuntu Bionic):
status: New → Fix Committed
Changed in eclipse-jdt-debug (Ubuntu Bionic):
status: New → Fix Committed
Changed in eclipse-jdt-ui (Ubuntu Bionic):
status: New → Fix Committed
Changed in eclipse-platform-debug (Ubuntu Bionic):
status: New → Fix Committed
Changed in eclipse-platform-resources (Ubuntu Bionic):
status: New → Fix Committed
Changed in eclipse-platform-runtime (Ubuntu Bionic):
status: New → Fix Committed
Changed in eclipse-platform-team (Ubuntu Bionic):
status: New → Fix Committed
Changed in eclipse-platform-text (Ubuntu Bionic):
status: New → Fix Committed
Changed in eclipse-platform-ua (Ubuntu Bionic):
status: New → Fix Committed
Changed in eclipse-platform-ui (Ubuntu Bionic):
status: New → Fix Committed
Changed in el-api (Ubuntu Bionic):
status: New → Fix Committed
Changed in equinox-bundles (Ubuntu Bionic):
status: New → Fix Committed
Changed in equinox-framework (Ubuntu Bionic):
status: New → Fix Committed
Changed in equinox-p2 (Ubuntu Bionic):
status: New → Fix Committed
Changed in jsp-api (Ubuntu Bionic):
status: New → Fix Committed
Changed in servlet-api (Ubuntu Bionic):
status: New → Fix Committed
Changed in tomcat9 (Ubuntu Bionic):
status: New → Fix Committed
Changed in websocket-api (Ubuntu Bionic):
status: New → Fix Committed
Changed in libeclipse-emf (Ubuntu Bionic):
status: New → Fix Committed
Steve Langasek (vorlon) on 2019-03-06
tags: added: verification-failed verification-failed-bionic
removed: verification-needed verification-needed-bionic
Matthias Klose (doko) on 2019-03-06
no longer affects: eclipse-emf (Ubuntu)
Steve Langasek (vorlon) wrote :

swt4-gtk has dropped several binaries in disco related to gtk2 deprecation, which means there are reverse-dependencies in bionic that would be made uninstallable by updating this package. This packaging change probably needs to be reverted to maintain compatibility.

Marking this verification-failed in the meantime; can be reset as soon as there's an updated package.

no longer affects: swt4-gtk (Ubuntu)
no longer affects: eclipse-platform-resources (Ubuntu)
no longer affects: eclipse-debian-helper (Ubuntu)
no longer affects: eclipse-jdt-core (Ubuntu)
no longer affects: eclipse-jdt-debug (Ubuntu)
no longer affects: eclipse-jdt-ui (Ubuntu)
no longer affects: eclipse-platform-debug (Ubuntu)
Changed in swt4-gtk (Ubuntu Bionic):
status: Fix Committed → Triaged
no longer affects: eclipse-platform-runtime (Ubuntu)
no longer affects: eclipse-platform-team (Ubuntu)
no longer affects: eclipse-platform-text (Ubuntu)
no longer affects: eclipse-platform-ua (Ubuntu)
Steve Langasek (vorlon) on 2019-03-06
no longer affects: eclipse-platform-ui (Ubuntu)
no longer affects: el-api (Ubuntu)
no longer affects: equinox-bundles (Ubuntu)
no longer affects: equinox-framework (Ubuntu)
no longer affects: equinox-p2 (Ubuntu)

Hello Matthias, or anyone else affected,

Accepted swt4-gtk into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/swt4-gtk/4.9.0-1~18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

no longer affects: jetty9 (Ubuntu)
no longer affects: jsp-api (Ubuntu)
Changed in swt4-gtk (Ubuntu Bionic):
status: Triaged → Fix Committed
no longer affects: libeclipse-emf (Ubuntu)
tags: added: verification-needed verification-needed-bionic
removed: verification-failed verification-failed-bionic
no longer affects: tomcat-native (Ubuntu)
no longer affects: servlet-api (Ubuntu)
no longer affects: tomcat8 (Ubuntu)

I think this regresses tomcat in some ways as for example outlined by a reporter that tested -proposed in bug 1819721.

I wonder if the switch to the systemd service is strictly needed for the overall target of using JDK11.

I read above that this is only going to the security pocket, but wouldn't an SRU template especially outlining and discussing the regression risks and why they are acceptable make sense?

I'm flagging as regression-proposed to make clear what https://bugs.launchpad.net/ubuntu/+source/tomcat8/+bug/1819721/comments/2 is until fixed or sorted out by discussion.

tags: added: regression-proposed
Łukasz Zemczak (sil2100) wrote :

Hello Matthias, or anyone else affected,

Accepted jetty9 into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/jetty9/9.4.15-1~18.04.1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in jetty9 (Ubuntu Cosmic):
status: New → Fix Committed
tags: added: verification-needed-cosmic
Łukasz Zemczak (sil2100) wrote :

Hello Matthias, or anyone else affected,

Accepted jetty9 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/jetty9/9.4.15-1~18.04.1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Łukasz Zemczak (sil2100) wrote :

Hello Matthias, or anyone else affected,

Accepted tomcat8 into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/tomcat8/8.5.39-1ubuntu1~18.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in tomcat8 (Ubuntu Cosmic):
status: New → Fix Committed
Łukasz Zemczak (sil2100) wrote :

Hello Matthias, or anyone else affected,

Accepted tomcat8 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/tomcat8/8.5.39-1ubuntu1~18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Steve Langasek (vorlon) wrote :

Hello Matthias, or anyone else affected,

Accepted tomcat9 into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/tomcat9/9.0.16-3~18.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in tomcat9 (Ubuntu Cosmic):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eclipse-debian-helper - 1.5~18.04

---------------
eclipse-debian-helper (1.5~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1817567.

eclipse-debian-helper (1.5) unstable; urgency=medium

  * Improved the detection of the bundle name

eclipse-debian-helper (1.4) unstable; urgency=medium

  * Team upload.
  * Support other bundle dirrectories than 'bundles' and the base directory

eclipse-debian-helper (1.3) unstable; urgency=medium

  * Add a symlink in /usr/lib/eclipse/plugins/ when installing a plugin
  * New parameter to set the shortname of a bundle

eclipse-debian-helper (1.2) unstable; urgency=medium

  * Made the source encoding configurable
  * Standards-Version updated to 4.2.1

eclipse-debian-helper (1.1) unstable; urgency=medium

  * Fixed the classpath when depending on other bundles
  * Include the resources from all source directories and not only src/
  * Set the source encoding to UTF-8 when compiling
  * Added eclipse-osgi.jar to the default classpath
  * Make the targeted Java release configurable

 -- Matthias Klose <email address hidden> Mon, 25 Feb 2019 15:48:13 +0100

Changed in eclipse-debian-helper (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eclipse-jdt-debug - 4.9-1~18.04

---------------
eclipse-jdt-debug (4.9-1~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1817567.

eclipse-jdt-debug (4.9-1) unstable; urgency=medium

  * New upstream release
    - Refreshed the patch
    - Depend on libeclipse-debug-core-java (>= 3.13)
    - Depend on libeclipse-debug-ui-java (>= 3.13.100)
    - Depend on libeclipse-jdt-ui-java (>= 3.15)
    - The license changed to EPL-2.0

eclipse-jdt-debug (4.8-1) unstable; urgency=medium

  * New upstream release
    - Depend on libeclipse-jdt-core-java (>= 3.14)

eclipse-jdt-debug (4.7.3-2) unstable; urgency=medium

  * Build the org.eclipse.jdt.debug.ui bundle

eclipse-jdt-debug (4.7.3-1) unstable; urgency=medium

  * Initial release (Closes: #911936)

 -- Matthias Klose <email address hidden> Thu, 07 Mar 2019 11:24:27 +0100

Changed in eclipse-jdt-debug (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eclipse-jdt-ui - 4.9-1~18.04

---------------
eclipse-jdt-ui (4.9-1~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1817567.

eclipse-jdt-ui (4.9-1) unstable; urgency=medium

  * New upstream release
    - Depend on libeclipse-jdt-core-java (>= 3.15)
    - Depend on libeclipse-jdt-launching-java (>= 3.11)
    - The license changed to EPL-2.0

eclipse-jdt-ui (4.8-1) unstable; urgency=medium

  * New upstream release
    - Depend on libeclipse-jdt-core-java (>= 3.14)
    - Depend on libeclipse-jdt-launching-java (>= 3.10)
    - Depend on libeclipse-jface-java (>= 3.14)
    - Depend on libeclipse-jface-text-java (>= 3.13)
    - Updated the bundle dependencies

eclipse-jdt-ui (4.7.3-2) unstable; urgency=medium

  * Build more bundles:
    - Build the org.eclipse.jdt.astview bundle
    - Build the org.eclipse.jdt.ui bundle
  * Fixed the watch file

eclipse-jdt-ui (4.7.3-1) unstable; urgency=medium

  * Initial release (Closes: #912257)

 -- Matthias Klose <email address hidden> Thu, 07 Mar 2019 11:25:32 +0100

Changed in eclipse-jdt-ui (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eclipse-platform-debug - 4.9-1~18.04

---------------
eclipse-platform-debug (4.9-1~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1817567.

eclipse-platform-debug (4.9-1) unstable; urgency=medium

  * New upstream release
    - Depend on libeclipse-ui-java (>= 3.110)
    - The license changed to EPL-2.0

eclipse-platform-debug (4.8-1) unstable; urgency=medium

  * New upstream release
    - Depend on libswt-gtk-4-java (>= 4.8)
    - Added equinox-preferences to the classpath of org.eclipse.ui.console

eclipse-platform-debug (4.7.3-1) unstable; urgency=medium

  * Initial release (Closes: #909610)

 -- Matthias Klose <email address hidden> Thu, 07 Mar 2019 11:27:15 +0100

Changed in eclipse-platform-debug (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eclipse-platform-resources - 4.9-1~18.04

---------------
eclipse-platform-resources (4.9-1~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1817567.

eclipse-platform-resources (4.9-1) unstable; urgency=medium

  * New upstream release

eclipse-platform-resources (4.8-1) unstable; urgency=medium

  * New upstream release
  * Fixed the URL in the watch file

eclipse-platform-resources (4.7.3-1) unstable; urgency=medium

  * Initial release (Closes: #903645)

 -- Matthias Klose <email address hidden> Thu, 07 Mar 2019 11:27:44 +0100

Changed in eclipse-platform-resources (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eclipse-platform-runtime - 4.9-1~18.04

---------------
eclipse-platform-runtime (4.9-1~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1817567.

eclipse-platform-runtime (4.9-1) unstable; urgency=medium

  * New upstream release
  * Depend on libeclipse-osgi-services-java (>= 3.7.0)

eclipse-platform-runtime (4.8-1) unstable; urgency=medium

  * New upstream release

eclipse-platform-runtime (4.7.3-2) unstable; urgency=medium

  * Enabled more bundles
  * Standards-Version updated to 4.2.1

eclipse-platform-runtime (4.7.3-1) unstable; urgency=medium

  * Initial release (Closes: #903632)

 -- Matthias Klose <email address hidden> Thu, 07 Mar 2019 11:29:08 +0100

Changed in eclipse-platform-runtime (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eclipse-platform-team - 4.9-1~18.04

---------------
eclipse-platform-team (4.9-1~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1817567.

eclipse-platform-team (4.9-1) unstable; urgency=medium

  * New upstream release
    - Refreshed the patch

eclipse-platform-team (4.8-1) unstable; urgency=medium

  * New upstream release
    - Fixed a compilation error in org.eclipse.team.ui

eclipse-platform-team (4.7.3-2) unstable; urgency=medium

  * Build more bundles:
    - org.eclipse.compare
    - org.eclipse.team.ui
    - org.eclipse.team.genericeditor.diff.extension

eclipse-platform-team (4.7.3-1) unstable; urgency=medium

  * Initial release (Closes: #909760)

 -- Matthias Klose <email address hidden> Thu, 07 Mar 2019 11:30:13 +0100

Changed in eclipse-platform-team (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eclipse-platform-text - 4.9-1~18.04

---------------
eclipse-platform-text (4.9-1~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1817567.

eclipse-platform-text (4.9-1) unstable; urgency=medium

  * New upstream release
    - Refreshed the patch
    - Updated the bundle dependencies
    - The license changed to EPL-2.0

eclipse-platform-text (4.8-1) unstable; urgency=medium

  * New upstream release
    - Fixed a compilation error in org.eclipse.jface.text
    - Depend on libswt-gtk-4-java (>= 4.8)
    - Updated the bundle dependencies

eclipse-platform-text (4.7.3-5) unstable; urgency=medium

  * Build more bundles:
    - org.eclipse.search

eclipse-platform-text (4.7.3-4) unstable; urgency=medium

  * Build more bundles:
    - org.eclipse.ui.editors
    - org.eclipse.ui.genericeditor
    - org.eclipse.ui.workbench.texteditor

eclipse-platform-text (4.7.3-3) unstable; urgency=medium

  * Build more bundles:
    - org.eclipse.core.filebuffers
    - org.eclipse.jface.text
  * Added the missing dependencies to libeclipse-text-java

eclipse-platform-text (4.7.3-2) unstable; urgency=medium

  * Removed the dependency on libequinox-osgi-java
  * Standards-Version updated to 4.2.1

eclipse-platform-text (4.7.3-1) unstable; urgency=medium

  * Initial release (Closes: #903653)

 -- Matthias Klose <email address hidden> Thu, 07 Mar 2019 10:43:41 +0100

Changed in eclipse-platform-text (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eclipse-platform-ua - 4.9-1~18.04

---------------
eclipse-platform-ua (4.9-1~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1817567.

eclipse-platform-ua (4.9-1) unstable; urgency=medium

  * New upstream release
    - The license changed to EPL-2.0

eclipse-platform-ua (4.8-1) unstable; urgency=medium

  * New upstream release

eclipse-platform-ua (4.7.3-1) unstable; urgency=medium

  * Initial release (Closes: #910187)

 -- Matthias Klose <email address hidden> Thu, 07 Mar 2019 11:17:49 +0100

Changed in eclipse-platform-ua (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eclipse-platform-ui - 4.9-1~18.04

---------------
eclipse-platform-ui (4.9-1~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1817567.

eclipse-platform-ui (4.9-1) unstable; urgency=medium

  * New upstream release
    - Refreshed the patch
    - Depend on libswt-gtk-4-java (>= 4.9)
    - Build the new org.eclipse.urischeme bundle
    - The license changed to EPL-2.0

eclipse-platform-ui (4.8-1) unstable; urgency=medium

  * New upstream release
    - Depend on libeclipse-e4-core-contexts-java (>= 1.7.0)
    - Updated the bundle dependencies
    - Updated debian/copyright

eclipse-platform-ui (4.7.3-5) unstable; urgency=medium

  * Fixed the dependencies of libeclipse-e4-ui-workbench-swt-java

eclipse-platform-ui (4.7.3-4) unstable; urgency=medium

  * Build more bundles:
    - org.eclipse.e4.ui.progress
    - org.eclipse.ui
    - org.eclipse.ui.browser
    - org.eclipse.ui.ide
    - org.eclipse.ui.ide.application
    - org.eclipse.ui.monitoring
    - org.eclipse.ui.navigator
    - org.eclipse.ui.views
    - org.eclipse.ui.views.properties.tabbed
  * Depend on xml-apis-1.4.01.jar instead of xml-apis.jar
  * Added the missing dependencies for:
    - libeclipse-ui-forms-java
    - libeclipse-ui-workbench-java
    - libeclipse-e4-ui-model-workbench-java
    - libeclipse-e4-ui-workbench-java
    - libeclipse-e4-ui-workbench3-java
    - libeclipse-e4-ui-workbench-addons-swt-java
    - libeclipse-e4-ui-workbench-renderers-swt-java
    - libeclipse-e4-ui-workbench-swt-java
  * Fixed the description of libeclipse-e4-ui-workbench-swt-java

eclipse-platform-ui (4.7.3-3) unstable; urgency=medium

  [ Emmanuel Bourg ]
  * Fixed debian/watch

  [ Jochen Sprickerhof ]
  * Package org.eclipse.ui.forms and it's dependencies
  * Remove unpackaged dependency (Closes: #910836)

eclipse-platform-ui (4.7.3-2) unstable; urgency=medium

  * Build more bundles:
    - org.eclipse.jface
    - org.eclipse.jface.databinding
    - org.eclipse.e4.ui.bindings
    - org.eclipse.e4.ui.css.core
    - org.eclipse.e4.ui.css.swt
    - org.eclipse.e4.ui.css.swt.theme
    - org.eclipse.e4.ui.di
    - org.eclipse.e4.ui.dialogs
    - org.eclipse.e4.ui.services
    - org.eclipse.e4.ui.swt.gtk
    - org.eclipse.e4.ui.widgets
  * Standards-Version updated to 4.2.1

eclipse-platform-ui (4.7.3-1) unstable; urgency=medium

  * Initial release (Closes: #903658)

 -- Matthias Klose <email address hidden> Thu, 07 Mar 2019 10:39:49 +0100

Changed in eclipse-platform-ui (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package el-api - 3.0.0-2~18.04

---------------
el-api (3.0.0-2~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1817567.

el-api (3.0.0-2) unstable; urgency=medium

  * Use a real pom for the 3.0 artifacts to improve the compatibility
    with Gradle and Ivy
  * libel-api-java also Breaks/Replaces libservlet2.5-java (Closes: #917273)
  * Standards-Version updated to 4.3.0

el-api (3.0.0-1) unstable; urgency=medium

  * Initial release (Closes: #916343)

 -- Matthias Klose <email address hidden> Mon, 25 Feb 2019 16:37:12 +0100

Changed in el-api (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package equinox-bundles - 4.9-2~18.04

---------------
equinox-bundles (4.9-2~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1817567.

equinox-bundles (4.9-2) unstable; urgency=medium

  * Depend on libtomcat9-java instead of libtomcat8-java
  * Fixed the compatibility with Jetty 9.4
  * The license changed to EPL-2.0

equinox-bundles (4.9-1) unstable; urgency=medium

  * New upstream release
    - Refreshed the patches

equinox-bundles (4.8-1) unstable; urgency=medium

  * New upstream release
    - Refreshed the patches
  * Standards-Version updated to 4.2.1

equinox-bundles (4.7.3-2) unstable; urgency=medium

  * Enabled most of the remaining bundles
  * Exclude the .dll and .jnilib files from the upstream tarball
  * Standards-Version updated to 4.2.0

equinox-bundles (4.7.3-1) unstable; urgency=medium

  * Initial release (Closes: #903575)

 -- Matthias Klose <email address hidden> Thu, 07 Mar 2019 11:39:32 +0100

Changed in equinox-bundles (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package equinox-framework - 4.9-1~18.04

---------------
equinox-framework (4.9-1~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1817567.

equinox-framework (4.9-1) unstable; urgency=medium

  * New upstream release
    - Refreshed the patch
    - Disabled the new OpenJ9 features (not in Debian)

equinox-framework (4.8-1) unstable; urgency=medium

  * New upstream release
    - Refreshed the patch
    - No longer build the removed org.eclipse.osgi.compatibility.plugins bundle
  * Fixed the watch file

equinox-framework (4.7.3-5) unstable; urgency=medium

  * Fixed the reversed groupId/artifactId in the Maven poms

equinox-framework (4.7.3-4) unstable; urgency=medium

  * Added the missing dependencies in the Maven poms
  * Added the Class-Path attribute in the manifest of the jar files

equinox-framework (4.7.3-3) unstable; urgency=medium

  * Mark the libeclipse-osgi-java, libeclipse-osgi-services-java and
    libeclipse-osgi-util-java package as breaking and replacing
    libequinox-osgi-java (<< 3.9.1-2~)

equinox-framework (4.7.3-2) unstable; urgency=medium

  * Handle the conflict between libeclipse-osgi-java and libequinox-osgi-java
    (Closes: #907863)
  * Standards-Version updated to 4.2.1

equinox-framework (4.7.3-1) unstable; urgency=medium

  * Initial release (Closes: #903617)

 -- Matthias Klose <email address hidden> Thu, 07 Mar 2019 11:20:00 +0100

Changed in equinox-framework (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package equinox-p2 - 4.9-1~18.04

---------------
equinox-p2 (4.9-1~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1817567.

equinox-p2 (4.9-1) unstable; urgency=medium

  * New upstream release
    - Refreshed the patch
    - No longer build the ie.wombat.jbdiff bundle (removed upstream)

equinox-p2 (4.8-1) unstable; urgency=medium

  * New upstream release

equinox-p2 (4.7.3-1) unstable; urgency=medium

  * Initial release (Closes: #909675)

 -- Matthias Klose <email address hidden> Thu, 07 Mar 2019 11:21:29 +0100

Changed in equinox-p2 (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.9 KiB)

This bug was fixed in the package jetty9 - 9.4.15-1~18.04.1ubuntu1

---------------
jetty9 (9.4.15-1~18.04.1ubuntu1) bionic; urgency=medium

  [ Matthias Klose ]
  * Backport for OpenJDK 11. LP: #1817567.

  [ Tiago Stürmer Daitx ]
  * debian/jetty9.init, debian/jetty9.default: revert conffiles to
    previous version, this allows unattended-upgrades to update the
    package even when there are local changes.

jetty9 (9.4.15-1) unstable; urgency=medium

  * New upstream release
    - Refreshed the patches
    - New build dependency on libjboss-logging-java
    - Ignore the new jetty-websocket-tests module
  * Standards-Version updated to 4.3.0

jetty9 (9.4.14-1) unstable; urgency=medium

  * New upstream release
    - Refreshed the patches
    - Ignore the new test dependencies
    - Build the new modules: jetty-alpn-java-*, jetty-alpn-openjdk8-*,
      jetty-http2-*, jetty-cdi-* and jetty-unixsocket
    - Ignore the new optional modules: jetty-alpn-conscrypt-*, jetty-memcached,
      jetty-cdi-servlet, jetty-gcloud, jetty-hazelcast and jetty-infinispan
    - No longer build the removed modules: jetty-monitor and jetty-rhttp-*
    - Updated the Maven rules
    - Derive the content of the jetty9 package from the output
      of the jetty-distribution module
    - Require Java 8 or higher to run
    - Depend on libasm-java (>= 7.0)
    - Updated the links in /usr/share/jetty9/lib/
    - Added jetty-util.jar to the classpath of jetty-start.jar
  * Added a systemd service file
  * Removed the default 256M heap limit
  * Removed the NO_START option from the service configuration
  * Depend on libtomcat9-java instead of libtomcat8-java
  * Don't follow the symlinks when setting the owner of the /var/cache/jetty9,
    /var/log/jetty9 and /var/lib/jetty9 directories in the postinst script
  * Updated the README file (Closes: #906770)
  * Exclude the documentation directory from the upstream tarball

jetty9 (9.2.26-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
  * Fixed the Maven rule for tomcat-jaspic-api (Closes: #907147)
  * Standards-Version updated to 4.2.1

jetty9 (9.2.25-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
    - Fixes CVE-2017-7656: A remote user can submit a specially crafted HTTP/0.9
      request containing invalid request headers to cause Jetty and an upstream
      HTTP agent (such as an origin server or another proxy) to interpret the
      boundary of the HTTP request differently. As a result, a malicious request
      may be embedded within another request as processed by the subsequent
      system. This allows a remote user to potentially poison the cache.
    - Fixes CVE-2017-7657: A remote user can submit a specially crafted HTTP
      request containing invalid Chunked Transfer-Encoding headers to cause
      Jetty and an upstream HTTP agent (such as an origin server or another
      proxy) to interpret the boundary of the HTTP request differently.
      As a result, a malicious request may be embedded within another request
      as processed by the subsequent system. This allows a remote user to
      potentially poison the cache.
    - Fixes CVE-2017-7658: A remote use...

Read more...

Changed in jetty9 (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jsp-api - 2.3.4-2~18.04

---------------
jsp-api (2.3.4-2~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1817567.

jsp-api (2.3.4-2) unstable; urgency=medium

  * Install Maven artifacts mimicking the version 2.3 to preserve the backward
    compatibility with the old libservlet3.1-java package
  * Standards-Version updated to 4.3.0

jsp-api (2.3.4-1) unstable; urgency=medium

  * Initial release (Closes: #916401)

 -- Matthias Klose <email address hidden> Mon, 25 Feb 2019 16:35:39 +0100

Changed in jsp-api (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libeclipse-emf - 2.16.0-1~18.04.1

---------------
libeclipse-emf (2.16.0-1~18.04.1) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1817567.
  * Upload as a new source package, so that we don't touch the existing
    eclipse-emf binary packages in 18.04.

eclipse-emf (2.16.0-1) unstable; urgency=medium

  * New upstream version 2.16.0
  * Bump policy version (no changes)
  * Add R³

eclipse-emf (2.15.0-1) unstable; urgency=medium

  * New upstream version 2.15.0
  * Update copyright (move to EPL-2.0)

eclipse-emf (2.14.0-1) unstable; urgency=medium

  [ Jelmer Vernooij ]
  * Use correct machine-readable copyright file URI.

  [ Emmanuel Bourg ]
  * Standards-Version updated to 4.2.1
  * Switch to debhelper level 11
  * Use salsa.debian.org Vcs-* URLs
  * Use XZ compression for the upstream tarball
  * Use the Files-Excluded field to remove the JET tutorial

  [ Jochen Sprickerhof ]
  * New upstream release
  * Rework packaging using eclipse-debian-helper

 -- Matthias Klose <email address hidden> Wed, 06 Mar 2019 12:28:10 +0100

Changed in libeclipse-emf (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package swt4-gtk - 4.9.0-1~18.04.1

---------------
swt4-gtk (4.9.0-1~18.04.1) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1817567.
  * Backport packaging changes from 4.10.0.
    - Patch build system to respect DEB_HOST_ARCH_BITS value passed to it.
      Fixes runtime problem with 32-bit builds. (Closes: #904754)
    - Removed the wrong --has-package-version flag for the SWT pom
    - libswt-webkit-gtk-4-jni: Depend on libwebkit2gtk-4.0-37.

swt4-gtk (4.9.0-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
    - Refreshed the patches

swt4-gtk (4.8.0-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
    - Refreshed the patches

swt4-gtk (4.7.3-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
    - Refreshed the patches
    - Changed target release to Java 8

swt4-gtk (4.6.3-3) unstable; urgency=medium

  * Team upload.

  [ Jochen Sprickerhof ]
  * Set javac release to 7 for JDK 10 compatibility (Closes: #908166)
  * Add patch for missing swt-gnome-gtk (Closes: #908281)

  [ Emmanuel Bourg ]
  * Standards-Version updated to 4.2.1
  * Use salsa.debian.org Vcs-* URLs

 -- Matthias Klose <email address hidden> Wed, 06 Mar 2019 21:35:51 +0100

Changed in swt4-gtk (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package servlet-api - 4.0.1-2~18.04

---------------
servlet-api (4.0.1-2~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1817567.

servlet-api (4.0.1-2) unstable; urgency=medium

  * libservlet-api-java-doc now replaces libservlet3.1-java-doc
  * Standards-Version updated to 4.3.0

servlet-api (4.0.1-1) unstable; urgency=medium

  * Initial release (Closes: #916354)

 -- Matthias Klose <email address hidden> Mon, 25 Feb 2019 16:34:46 +0100

Changed in servlet-api (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.5 KiB)

This bug was fixed in the package tomcat8 - 8.5.39-1ubuntu1~18.04.1

---------------
tomcat8 (8.5.39-1ubuntu1~18.04.1) bionic; urgency=medium

  [ Matthias Klose ]
  * Backport for OpenJDK 11. LP: #1817567.
    /usr/share/doc/tomcat8/NEWS.gz. LP: #1819721.

  [ Tiago Stürmer Daitx ]
  * debian/tomcat8.service: removed, use the init.d script instead.
    LP: #1819721.
  * debian/tomcat8.init, debian/logging.properties: revert back to the
    conffiles from the previous version; this allows unattended-upgrades
    to update tomcat8 even when local changes are present.
  * debian/series: no longer apply 0023-disable-shutdown-by-socket.patch
    so server.xml conffile is unmodified from previous version.

tomcat8 (8.5.39-1ubuntu1) disco; urgency=medium

  * Merge with Debian; remaining changes:
    - d/control: Break/replace tomcat8.0 binaries.

tomcat8 (8.5.39-1) experimental; urgency=medium

  * Team upload.
  * New upstream release
    - Refreshed the patches
  * Track and download the new releases from GitHub

tomcat8 (8.5.38-2ubuntu1) disco; urgency=medium

  * Merge with Debian; remaining changes:
    - d/control: Break/replace tomcat8.0 binaries.

tomcat8 (8.5.38-2) unstable; urgency=high

  * Team upload.
  * Apply upstream patch to unbreak the startup script (Closes: #922863)

tomcat8 (8.5.38-1ubuntu1) disco; urgency=medium

  * Merge with Debian unstable (LP: #1815601). Remaining changes:
    - d/control: Break/replace tomcat8.0 binaries. (LP: 1717998)
  Dropped Changes:
    - support-jre8.diff.

tomcat8 (8.5.38-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
    - Refreshed the patches

tomcat8 (8.5.37-2) unstable; urgency=medium

  * Team upload.
  * No longer build the JavaEE API packages
  * Standards-Version updated to 4.3.0

tomcat8 (8.5.37-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
    - Refreshed the patches

tomcat8 (8.5.35-3) unstable; urgency=medium

  * Team upload.
  * Split libservlet3.1-java into separate JavaEE API packages
    (libjsp-api-java, libel-api-java and libwebsocket-api-java)
  * Updated the version required for libtcnative-1 (>= 1.2.18)
  * Install the Russian translation added in Tomcat 8.5.33

tomcat8 (8.5.35-2) unstable; urgency=medium

  * Team upload.
  * Fixed the build failure with Easymock 4 (Closes: #913402)

tomcat8 (8.5.35-1) unstable; urgency=medium

  * Team upload.

  [ Thomas Opfer ]
  * Removed old version requirement for package ant-optional that is not
    required any more.

  [ Emmanuel Bourg ]
  * New upstream release
    - Refreshed the patches

tomcat8 (8.5.34-1ubuntu1) cosmic; urgency=medium

  * Merge from Debian unstable. Remaining changes:
    - control: Break/replace tomcat8.0 binaries. (LP: #1717998)
    - support-jre8.diff.

tomcat8 (8.5.34-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
    - Refreshed the patches

tomcat8 (8.5.33-1) unstable; urgency=medium

  * Team upload.
  * New upstream version 8.5.33.
    - Tomcat compiles to Java 7 bytecode and passes release=7 to javac now.
      This ensures backwards compatibility with older JREs. (Closes: #906447)
  * Declare compliance with Debian Policy 4.2....

Read more...

Changed in tomcat8 (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tomcat-native - 1.2.21-1~18.04.1

---------------
tomcat-native (1.2.21-1~18.04.1) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1817567.

tomcat-native (1.2.21-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
  * Standards-Version updated to 4.3.0

tomcat-native (1.2.19-1) unstable; urgency=medium

  * Team upload.
  * New upstream release

tomcat-native (1.2.18-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
  * Standards-Version updated to 4.2.1

tomcat-native (1.2.17-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
  * Changed the priority from extra to optional
  * Standards-Version updated to 4.1.4
  * Switch to debhelper level 11
  * Use salsa.debian.org Vcs-* URLs

 -- Matthias Klose <email address hidden> Mon, 25 Feb 2019 15:34:15 +0100

Changed in tomcat-native (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package websocket-api - 1.1-1~18.04

---------------
websocket-api (1.1-1~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1817567.

websocket-api (1.1-1) unstable; urgency=medium

  * Initial release (Closes: #916245)

 -- Matthias Klose <email address hidden> Mon, 25 Feb 2019 19:19:48 +0100

Changed in websocket-api (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eclipse-jdt-core - 4.9-1~18.04

---------------
eclipse-jdt-core (4.9-1~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1817567.

eclipse-jdt-core (4.9-1) unstable; urgency=medium

  * New upstream release
    - The license changed to EPL-2.0

eclipse-jdt-core (4.8-1) unstable; urgency=medium

  * New upstream release
  * Fixed the Vcs-Browser URL

eclipse-jdt-core (4.7.3-1) unstable; urgency=medium

  * Initial release (Closes: #903913)

 -- Matthias Klose <email address hidden> Thu, 07 Mar 2019 11:23:31 +0100

Changed in eclipse-jdt-core (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (23.0 KiB)

This bug was fixed in the package tomcat9 - 9.0.16-3~18.04.1

---------------
tomcat9 (9.0.16-3~18.04.1) bionic; urgency=medium

  * Don't set nologin shell in sysusers.d/tomcat9.conf
    It is the default anyway and systemd-sysusers in 18.04 can't parse it.
    (LP: #1823125)

tomcat9 (9.0.16-3~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1817567.

tomcat9 (9.0.16-3) unstable; urgency=medium

  * Removed read/write access to /var/lib/solr (Closes: #923299)
  * Removed the broken catalina-ws.jar and catalina-jmx-remote.jar
    symlinks in /usr/share/tomcat9/lib/

tomcat9 (9.0.16-2) unstable; urgency=medium

  * Team upload.
  * tomcat9.service: Permit read and write access to /var/lib/solr too.
    (Closes: #919638)

tomcat9 (9.0.16-1) unstable; urgency=medium

  * New upstream release
    - Refreshed the patches
    - Install the new Chinese, Czech, German, Korean and Portuguese translations
    - No longer build the extra WS and JMX jars
  * Standards-Version updated to 4.3.0

tomcat9 (9.0.14-1) unstable; urgency=medium

  * New upstream release
    - Refreshed the patches
  * Create the /var/log/tomcat9/ and /var/cache/tomcat9/ directories
    at install time (Closes: #915791)
  * Tightened the dependency on systemd

tomcat9 (9.0.13-2) unstable; urgency=medium

  * Install the tomcat-embed-* artifacts with the 9.x version (Closes: #915578)
  * Modified the dependencies required for creating the tomcat user
    (adduser is replaced by systemd) (Closes: #915586)
  * Fixed the tomcat-jasper pom to reference the ECJ dependency
    from libeclipse-jdt-core-java
  * Removed the redundant ReadWritePaths options in the service file for the log
    and cache directories (Thanks to Lennart Poettering for the suggestion)

tomcat9 (9.0.13-1) unstable; urgency=medium

  * New upstream release
    - Refreshed the patches
    - Renamed the package to tomcat9
    - Removed the libservlet3.1-java package. From now on the Servlet API
      is packaged in a separate package independent from Tomcat.
    - Depend on libeclipse-jdt-core-java (>= 3.14.0) instead of libecj-java
    - Updated the policy files in /etc/tomcat8/policy.d/
    - Use the OSGi metadata generated by the upstream build
    - Deploy the Tomcat artifacts in the Maven repository with the 9.x version
    - Updated the README file
  * Removed the SysV init script
  * Restart the server automatically on failures
  * Use a fixed non-configurable user 'tomcat' to run the server
  * Removed the debconf integration. The user being now unmodifiable,
    the remaining configuration parameter JAVA_OPTS can be edited in
    /etc/default/tomcat9
  * No longer add the 'common', 'server' and 'shared' directories under
    CATALINA_HOME and CATALINA_BASE to the classpath. Extra jar files should go
    to the 'lib' directory.
  * Let Tomcat handle the rotation of its log files with the maxDays parameter
    of the valves and log handlers instead of relying on a cron job
  * Renamed the TOMCAT_SECURITY parameter to SECURITY_MANAGER in the service
    configuration file
  * Simplified the postinst script by using systemd-sysusers to create
    the 'tomcat' user
  * No longer create the /etc...

Changed in tomcat9 (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.9 KiB)

This bug was fixed in the package jetty9 - 9.4.15-1~18.04.1ubuntu1

---------------
jetty9 (9.4.15-1~18.04.1ubuntu1) bionic; urgency=medium

  [ Matthias Klose ]
  * Backport for OpenJDK 11. LP: #1817567.

  [ Tiago Stürmer Daitx ]
  * debian/jetty9.init, debian/jetty9.default: revert conffiles to
    previous version, this allows unattended-upgrades to update the
    package even when there are local changes.

jetty9 (9.4.15-1) unstable; urgency=medium

  * New upstream release
    - Refreshed the patches
    - New build dependency on libjboss-logging-java
    - Ignore the new jetty-websocket-tests module
  * Standards-Version updated to 4.3.0

jetty9 (9.4.14-1) unstable; urgency=medium

  * New upstream release
    - Refreshed the patches
    - Ignore the new test dependencies
    - Build the new modules: jetty-alpn-java-*, jetty-alpn-openjdk8-*,
      jetty-http2-*, jetty-cdi-* and jetty-unixsocket
    - Ignore the new optional modules: jetty-alpn-conscrypt-*, jetty-memcached,
      jetty-cdi-servlet, jetty-gcloud, jetty-hazelcast and jetty-infinispan
    - No longer build the removed modules: jetty-monitor and jetty-rhttp-*
    - Updated the Maven rules
    - Derive the content of the jetty9 package from the output
      of the jetty-distribution module
    - Require Java 8 or higher to run
    - Depend on libasm-java (>= 7.0)
    - Updated the links in /usr/share/jetty9/lib/
    - Added jetty-util.jar to the classpath of jetty-start.jar
  * Added a systemd service file
  * Removed the default 256M heap limit
  * Removed the NO_START option from the service configuration
  * Depend on libtomcat9-java instead of libtomcat8-java
  * Don't follow the symlinks when setting the owner of the /var/cache/jetty9,
    /var/log/jetty9 and /var/lib/jetty9 directories in the postinst script
  * Updated the README file (Closes: #906770)
  * Exclude the documentation directory from the upstream tarball

jetty9 (9.2.26-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
  * Fixed the Maven rule for tomcat-jaspic-api (Closes: #907147)
  * Standards-Version updated to 4.2.1

jetty9 (9.2.25-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
    - Fixes CVE-2017-7656: A remote user can submit a specially crafted HTTP/0.9
      request containing invalid request headers to cause Jetty and an upstream
      HTTP agent (such as an origin server or another proxy) to interpret the
      boundary of the HTTP request differently. As a result, a malicious request
      may be embedded within another request as processed by the subsequent
      system. This allows a remote user to potentially poison the cache.
    - Fixes CVE-2017-7657: A remote user can submit a specially crafted HTTP
      request containing invalid Chunked Transfer-Encoding headers to cause
      Jetty and an upstream HTTP agent (such as an origin server or another
      proxy) to interpret the boundary of the HTTP request differently.
      As a result, a malicious request may be embedded within another request
      as processed by the subsequent system. This allows a remote user to
      potentially poison the cache.
    - Fixes CVE-2017-7658: A remote use...

Read more...

Changed in jetty9 (Ubuntu Cosmic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tomcat8 - 8.5.39-1ubuntu1~18.10

---------------
tomcat8 (8.5.39-1ubuntu1~18.10) cosmic; urgency=medium

  [ Matthias Klose ]
  * Backport for OpenJDK 11. LP: #1817567.
  * tomcat8 now uses systemd service instead of init scripts. See
    /usr/share/doc/tomcat8/NEWS.gz. LP: #1819721.

tomcat8 (8.5.39-1ubuntu1) disco; urgency=medium

  * Merge with Debian; remaining changes:
    - d/control: Break/replace tomcat8.0 binaries.

tomcat8 (8.5.39-1) experimental; urgency=medium

  * Team upload.
  * New upstream release
    - Refreshed the patches
  * Track and download the new releases from GitHub

tomcat8 (8.5.38-2ubuntu1) disco; urgency=medium

  * Merge with Debian; remaining changes:
    - d/control: Break/replace tomcat8.0 binaries.

tomcat8 (8.5.38-2) unstable; urgency=high

  * Team upload.
  * Apply upstream patch to unbreak the startup script (Closes: #922863)

tomcat8 (8.5.38-1ubuntu1) disco; urgency=medium

  * Merge with Debian unstable (LP: #1815601). Remaining changes:
    - d/control: Break/replace tomcat8.0 binaries. (LP: 1717998)
  Dropped Changes:
    - support-jre8.diff.

tomcat8 (8.5.38-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
    - Refreshed the patches

tomcat8 (8.5.37-2) unstable; urgency=medium

  * Team upload.
  * No longer build the JavaEE API packages
  * Standards-Version updated to 4.3.0

tomcat8 (8.5.37-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
    - Refreshed the patches

tomcat8 (8.5.35-3) unstable; urgency=medium

  * Team upload.
  * Split libservlet3.1-java into separate JavaEE API packages
    (libjsp-api-java, libel-api-java and libwebsocket-api-java)
  * Updated the version required for libtcnative-1 (>= 1.2.18)
  * Install the Russian translation added in Tomcat 8.5.33

tomcat8 (8.5.35-2) unstable; urgency=medium

  * Team upload.
  * Fixed the build failure with Easymock 4 (Closes: #913402)

tomcat8 (8.5.35-1) unstable; urgency=medium

  * Team upload.

  [ Thomas Opfer ]
  * Removed old version requirement for package ant-optional that is not
    required any more.

  [ Emmanuel Bourg ]
  * New upstream release
    - Refreshed the patches

 -- Tiago Stürmer Daitx <email address hidden> Wed, 10 Apr 2019 05:33:03 +0000

Changed in tomcat8 (Ubuntu Cosmic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package websocket-api - 1.1-1~18.04

---------------
websocket-api (1.1-1~18.04) bionic; urgency=medium

  * Backport for OpenJDK 11. LP: #1817567.

websocket-api (1.1-1) unstable; urgency=medium

  * Initial release (Closes: #916245)

 -- Matthias Klose <email address hidden> Mon, 25 Feb 2019 19:19:48 +0100

Changed in websocket-api (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.8 KiB)

This bug was fixed in the package tomcat9 - 9.0.16-3~18.10

---------------
tomcat9 (9.0.16-3~18.10) cosmic; urgency=medium

  * Backport for OpenJDK 11. LP: #1817567.

tomcat9 (9.0.16-3) unstable; urgency=medium

  * Removed read/write access to /var/lib/solr (Closes: #923299)
  * Removed the broken catalina-ws.jar and catalina-jmx-remote.jar
    symlinks in /usr/share/tomcat9/lib/

tomcat9 (9.0.16-2) unstable; urgency=medium

  * Team upload.
  * tomcat9.service: Permit read and write access to /var/lib/solr too.
    (Closes: #919638)

tomcat9 (9.0.16-1) unstable; urgency=medium

  * New upstream release
    - Refreshed the patches
    - Install the new Chinese, Czech, German, Korean and Portuguese translations
    - No longer build the extra WS and JMX jars
  * Standards-Version updated to 4.3.0

tomcat9 (9.0.14-1) unstable; urgency=medium

  * New upstream release
    - Refreshed the patches
  * Create the /var/log/tomcat9/ and /var/cache/tomcat9/ directories
    at install time (Closes: #915791)
  * Tightened the dependency on systemd

tomcat9 (9.0.13-2) unstable; urgency=medium

  * Install the tomcat-embed-* artifacts with the 9.x version (Closes: #915578)
  * Modified the dependencies required for creating the tomcat user
    (adduser is replaced by systemd) (Closes: #915586)
  * Fixed the tomcat-jasper pom to reference the ECJ dependency
    from libeclipse-jdt-core-java
  * Removed the redundant ReadWritePaths options in the service file for the log
    and cache directories (Thanks to Lennart Poettering for the suggestion)

tomcat9 (9.0.13-1) unstable; urgency=medium

  * New upstream release
    - Refreshed the patches
    - Renamed the package to tomcat9
    - Removed the libservlet3.1-java package. From now on the Servlet API
      is packaged in a separate package independent from Tomcat.
    - Depend on libeclipse-jdt-core-java (>= 3.14.0) instead of libecj-java
    - Updated the policy files in /etc/tomcat8/policy.d/
    - Use the OSGi metadata generated by the upstream build
    - Deploy the Tomcat artifacts in the Maven repository with the 9.x version
    - Updated the README file
  * Removed the SysV init script
  * Restart the server automatically on failures
  * Use a fixed non-configurable user 'tomcat' to run the server
  * Removed the debconf integration. The user being now unmodifiable,
    the remaining configuration parameter JAVA_OPTS can be edited in
    /etc/default/tomcat9
  * No longer add the 'common', 'server' and 'shared' directories under
    CATALINA_HOME and CATALINA_BASE to the classpath. Extra jar files should go
    to the 'lib' directory.
  * Let Tomcat handle the rotation of its log files with the maxDays parameter
    of the valves and log handlers instead of relying on a cron job
  * Renamed the TOMCAT_SECURITY parameter to SECURITY_MANAGER in the service
    configuration file
  * Simplified the postinst script by using systemd-sysusers to create
    the 'tomcat' user
  * No longer create the /etc/tomcat9/Catalina/localhost directory at install
    time and let Tomcat create it automatically
  * Let systemd automatically create /var/log/tomcat9 and /var/cache/tomcat9
  * Prevent Tomcat from writi...

Read more...

Changed in tomcat9 (Ubuntu Cosmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers