Tomcat 8.0.32 does not start with libraries compatible with Java 8 or older but compiled for Java 9

Bug #1904620 reported by Guillaume Penin
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tomcat8 (Ubuntu)
Invalid
Undecided
Unassigned
Xenial
Won't Fix
Undecided
Unassigned

Bug Description

An update to the BCEL library has been pushed upstream since Tomcat 8.0.42 : https://bz.apache.org/bugzilla/show_bug.cgi?id=60688

Without this update, loading libraries which are compatible with Java 8 or older but compiled for Java 9 on Tomcat 8.0.32 on Ubuntu Xenial prevents Tomcat from starting.

Is it possible to backport this update to the BECL library on Tomcat 8.0.32 ?

Thanks in advance.

Revision history for this message
Sergio Durigan Junior (sergiodj) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu
better.

If someone can prepare a backport, please follow the steps at:
https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

All the steps documented there need to be followed. In particular:

1) Explain the bug well enough so the SRU team (who are probably not
familiar with this package) can understand the real user impact in terms of
use case so they can make a decision as to whether backporting the fix to
stable releases justifies the regression risk to existing, unaffected users.

2) Make sure that the fixing this in a stable Ubuntu release does not
regress existing users of the module not affected by this bug (e.g. other
architectures or ways of consuming this module).

3) Have a test case that can be followed by someone not familiar with the
package for SRU verification purposes.

Changed in tomcat8 (Ubuntu):
status: New → Invalid
Revision history for this message
Sergio Durigan Junior (sergiodj) wrote :

Meanwhile, Guillaume Penin, could you provide the necessary steps to reproduce this issue? I am not familiar with Tomcat.

Thanks.

Revision history for this message
Guillaume Penin (guillaume-penin) wrote :

Hi,

I've asked the dev team for the most simple reproducer, that i will try to provide ASAP.

Please find the necessary commit applied on the 8.0.41 source tree : https://github.com/apache/tomcat80/commit/d491003658865af441a982c52dfaa1d2fa460d5f

Regards,

Revision history for this message
Guillaume Penin (guillaume-penin) wrote :

Hi,

Please find in attachment a relevant patch for the current Ubuntu Xenial Tomcat 8 source tree.

Regards,

Revision history for this message
Lucas Kanashiro (lucaskanashiro) wrote :

Hi Guillaume,

Thanks for providing the patch and the pointer to the upstream commit, appreciated.

However, we would need to have some detailed steps on how to reproduce this issue in a Xenial system to move forward. Could you do that?

We have a process to release updates to stable releases, you can find more information here:

https://wiki.ubuntu.com/StableReleaseUpdates

Revision history for this message
Utkarsh Gupta (utkarsh) wrote :

Hello,

Xenial has now reached the end of standard support. So marking this has "won't fix" for Xenial. Thanks!

Changed in tomcat8 (Ubuntu Xenial):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers