package tomcat7 7.0.68-1ubuntu0.1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #1721687 reported by sarath p on 2017-10-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tomcat7 (Ubuntu)
Undecided
Unassigned

Bug Description

it happened when do
sudo apt-get update
and sudo apt-get install crunch

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: tomcat7 7.0.68-1ubuntu0.1
ProcVersionSignature: Ubuntu 4.10.0-35.39~16.04.1-generic 4.10.17
Uname: Linux 4.10.0-35-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.10
AptOrdering:
 crunch: Install
 tomcat7: Configure
 crunch: Configure
 NULL: ConfigurePending
Architecture: amd64
Date: Fri Oct 6 09:35:11 2017
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationDate: Installed on 2017-06-27 (100 days ago)
InstallationMedia: Ubuntu 16.04.2 LTS "Xenial Xerus" - Release amd64 (20170215.2)
PackageArchitecture: all
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.2
 apt 1.2.24
SourcePackage: tomcat7
Title: package tomcat7 7.0.68-1ubuntu0.1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

sarath p (sarath-p) wrote :
tags: removed: need-duplicate-check

Hi,
part of this pulled in an update/install of tomctat 7.
That then failed to start.

From your log:
See "systemctl status tomcat7.service" and "journalctl -xe" for details.
[...]
Oct 06 09:35:11 sarath tomcat7[4823]: * no JDK or JRE found - ple...E

So I'd recommend doing exactly as suggested, run "systemctl status tomcat7.service" for a more detailed error message.
It likely is around a JDK being missing.
That can happen if you have a non default JDK installed, you then need to adapt tomcat to know about that. See [1] for more and some guidance how to do so.

See [1] for some details

[1]: https://askubuntu.com/questions/154953/specify-jdk-for-tomcat7

Changed in tomcat7 (Ubuntu):
status: New → Incomplete

Thank you for taking the time to report this bug and helping to make Ubuntu better.

Since it seems likely to me that this is a local configuration problem, rather than a bug in Ubuntu, I'm marking this bug as Incomplete.

If indeed this is a local configuration problem, you can find pointers to get help for this sort of problem here: http://www.ubuntu.com/support/community

Or if you believe that this is really a bug, then you may find it helpful to read "How to report bugs effectively" http://www.chiark.greenend.org.uk/~sgtatham/bugs.html. We'd be grateful if you would then provide a more complete description of the problem, explain why you believe this is a bug in Ubuntu rather than a problem specific to your system, and then change the bug status back to New.

Launchpad Janitor (janitor) wrote :

[Expired for tomcat7 (Ubuntu) because there has been no activity for 60 days.]

Changed in tomcat7 (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers