dependency to tomcat-native is too weak (no version for libtcnative-1 specified)

Bug #1092548 reported by H.-Dirk Schmitt on 2012-12-20
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
tomcat7 (Debian)
Fix Released
Unknown
tomcat7 (Ubuntu)
High
Unassigned

Bug Description

As I backported tomcat7 7.0.34 from raring to precise I have seen the following error message:

> An incompatible version 1.1.22 of the APR based Apache Tomcat Native library is installed, while Tomcat requires version 1.1.24

The reason is that the suggests line doesn't set a minimum version for libtcnative-1.
The tomcat 7.0.34 needs libtcnative-1 1.1.24 (not 1.1.22).

tags: added: dependency-problem raring
summary: - dependency to tomcat-native is to weak (no version specified)
+ dependency to tomcat-native is too weak (no version for libcnative-1
+ specified)
summary: - dependency to tomcat-native is too weak (no version for libcnative-1
+ dependency to tomcat-native is too weak (no version for libtcnative-1
specified)
Changed in tomcat7 (Ubuntu):
status: New → Confirmed
importance: Undecided → High
teledyn (garym-teledyn) wrote :

the current repository version for amd64 is still incompatible with tomcat7:

SEVERE: An incompatible version 1.1.23 of the APR based Apache Tomcat Native library is installed, while Tomcat requires version 1.1.24

this causes the APR SSL support to fail:

org.apache.catalina.LifecycleException: The configured protocol [org.apache.coyote.http11.Http11AprProtocol] requires the APR/native library which is not available

I think this bug should be forwarded in debian. could you please forward it?

Problem still exists in 7.0.40-2
See also http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=712638

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

no longer affects: tomcat7
Changed in tomcat7 (Debian):
status: Unknown → New
Changed in tomcat7 (Debian):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tomcat7 - 7.0.42-1

---------------
tomcat7 (7.0.42-1) unstable; urgency=low

  [ Gianfranco Costamagna ]
  * Team upload.
  * New upstream release.
  * Added libhamcrest-java >= 1.3 as build-dep,
    tweaked debian/rules.
  * Bumped compat level to 9.
  * Removed some version checks, newer releases already in oldstable.
  * Refresh patches.
  * debian/control: changed Vcs-Git and Vcs-Browser fields,
    now they are canonical.
  * Fixed error message in Tomcat init script,
    patch by Thijs Kinkhorst (Closes: #714348)

 -- Gianfranco Costamagna <email address hidden> Tue, 16 Jul 2013 17:34:58 +0200

Changed in tomcat7 (Ubuntu):
status: Confirmed → Fix Released
Hendy Irawan (ceefour) wrote :

Is this fixed for Ubuntu 12.10 ?

See bug #1088687

It seems the bug still exists, tomcat7 unable to use APR.

Hendy Irawan (ceefour) wrote :

Here's our Tomcat log catalina.out :

Aug 30, 2013 5:00:57 AM org.apache.catalina.core.AprLifecycleListener init
SEVERE: An incompatible version 1.1.23 of the APR based Apache Tomcat Native library is installed, while Tomcat requires version 1.1.24

Using the latest 12.10 updates

Robie Basak (racb) wrote :

It was fixed in 7.0.42-1. 12.10 was released with 7.0.30-0ubuntu1 and is now on 7.0.30-0ubuntu1.2. So I don't believe this is fixed or expected to be fixed in 12.10.

It could be fixed in 12.10 though if someone can identify a fix, the bug and fix meet the SRU criteria and somebody follows through the SRU procedure. Please see https://wiki.ubuntu.com/StableReleaseUpdates#Procedure for details.

Robie Basak (racb) wrote :

(since 12.04 is the LTS, I expect that we'd want to fix 12.04 at the same time also, if 12.04 is affected)

See backport request in https://bugs.launchpad.net/ubuntu/+source/tomcat7/+bug/1073159
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.