tomcat7 upgrades fail if /etc/tomcat7/tomcat-users.xml is removed

Bug #1010791 reported by Ma Anning on 2012-06-09
44
This bug affects 7 people
Affects Status Importance Assigned to Milestone
tomcat7 (Ubuntu)
Low
Unassigned

Bug Description

I uninstalled tomcat6 manually, and encountered an error when I tried to install tomcat7.
When I updated unbuntu to 12.04 with tomcat7 not being fixed, met the error message above.
I'd appreciate any of your help. Thanks.

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: tomcat7 7.0.26-1ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-24.39-generic-pae 3.2.16
Uname: Linux 3.2.0-24-generic-pae i686
ApportVersion: 2.0.1-0ubuntu8
Architecture: i386
Date: Sat Jun 9 16:01:32 2012
ErrorMessage: ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
PackageArchitecture: all
SourcePackage: tomcat7
Title: package tomcat7 7.0.26-1ubuntu1 failed to install/upgrade: ErrorMessage: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: Upgraded to precise on 2012-06-09 (0 days ago)

Ma Anning (maanning19840318) wrote :
Robert Roth (evfool) wrote :

The relevant part of the log is:
Not replacing deleted config file /etc/default/tomcat7
grep: /etc/logrotate.d/tomcat7: No such file or directory
chmod: cannot access `/etc/tomcat7/tomcat-users.xml': No such file or directory
dpkg: error processing tomcat7 (--configure):
 subprocess installed post-installation script returned error exit status 1

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in tomcat7 (Ubuntu):
status: New → Confirmed
James Page (james-page) wrote :

Thanks for taking the time to report this bug in Ubuntu.

Looks like you deleted some configuration files that Tomcat 7 depends on prior to the upgrade.

I would recommend that you purge and re-install tomcat7:

    sudo apt-get purge tomcat7\*
    sudo apt-get install tomcat7

This should resolve your issue.

The maintainer script could be a little more resilient to this file disappearing - marking 'Low' and 'Triaged' as there is sufficient information to resolve this bug now.

summary: - package tomcat7 7.0.26-1ubuntu1 failed to install/upgrade: ErrorMessage:
- subprocess installed post-installation script returned error exit status
- 1
+ tomcat7 upgrade fail if /etc/tomcat7/tomcat-users.xml is removed
Changed in tomcat7 (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
summary: - tomcat7 upgrade fail if /etc/tomcat7/tomcat-users.xml is removed
+ tomcat7 upgrades fail if /etc/tomcat7/tomcat-users.xml is removed
Emmanuel Bourg (ebourg) wrote :

A fix has been applied in Debian for tomcat7 (>> 7.0.63-1) and tomcat8 (>> 8.0.24-1).

Changed in tomcat7 (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tomcat7 - 7.0.64-1

---------------
tomcat7 (7.0.64-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
    - Refreshed the patches
  * Install the missing WebSocket jars in /usr/share/tomcat7/lib/
    (Closes: #787220, LP: #1326687)
  * Changed the authbind configuration to allow IPv6 connections (LP: #1443041)
  * Fixed an upgrade error when /etc/tomcat7/tomcat-users.xml is removed
    (LP: #1010791)
  * Fixed a minor HTML error in the default index.html file (LP: #1236132)

 -- Emmanuel Bourg <email address hidden> Fri, 28 Aug 2015 09:47:33 +0200

Changed in tomcat7 (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers