Ubuntu

unable to setup ip-based virtual hosting due to "Bugzilla 48612"

Reported by Benjamin Rampe on 2010-11-02
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Apache Tomcat6 Package for Ubuntu
Fix Released
Medium
tomcat6 (Ubuntu)
Medium
Unassigned
Lucid
Medium
Unassigned

Bug Description

Binary package hint: tomcat6

To setup IP-based virtual hosting the connector needs the "address" parameter set.
That's impossible with Tomcat 6 candidate 6.0.24-2ubuntu1.4 because it's affected by https://issues.apache.org/bugzilla/show_bug.cgi?id=48612
(That is fixed with Tomcat 6.0.25 onwards. So newer Ubuntu releases than 10.04 LTS shouldn't be affected.)

James Page (james-page) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

Unfortunately from the information provided in the bug report I have been unable to reproduce this issue; I have successfully bound multiple tomcat6 connectors to different IP addresses using the 'address' parameter of the connector on a up-to-date Lucid build.

It would be really helpful if you could provide example configuration and details of your deployment such as the version of Java that you are using so that we can complete further diagnosis of this issue.

Thanks

Changed in tomcat6 (Ubuntu):
status: New → Incomplete
Benjamin Rampe (benjamin-rampe) wrote :

James, thank _you_ for your ongoing interest and contributions.

Hopefully the following informations give answer your requests
(the "undisclosed" parts are meaningful in its original setting. If you want to make sure, without further ado I'm only allowed to provide the files to you in private.):

Tomcat (tomcat6-user):
tomcat6-user:
  Installiert: 6.0.24-2ubuntu1.4
  Kandidat: 6.0.24-2ubuntu1.4
  Versions-Tabelle:
 *** 6.0.24-2ubuntu1.4 0

Java:
apt-cache policy sun-java6-jdk
sun-java6-jdk:
  Installiert: 6.20dlj-0ubuntu1.8.04.1
  Kandidat: 6.20dlj-0ubuntu1.8.04.1
  Versions-Tabelle:
 *** 6.20dlj-0ubuntu1.8.04.1 0
        100 /var/lib/dpkg/status

virtual ip entry in /etc/network/interfaces:
------------------------------------------------------
[..]
up ip address add undisclosed.service.virtual.ip/22 dev eth0
[..]

Changed lines in server.xml (everything else is default):
---------------
<Connector port="80" address="virtual.ip.of.service" protocol="HTTP/1.1"
[..]
useIPVHosts="true" />
[..]
<Engine name="Catalina" defaultHost="ip.of.undisclosed.service">
<Host name="dns.entry.of.undisclosed.service" appBase="webapps"
[..]
<Valve className="org.apache.catalina.valves.AccessLogValve" directory="logs"
prefix="undisclosed_service.access" suffix=".log" pattern="common" resolveHosts="false"/>

This setup works flawless with a self compiled Tomcat6.
The config files of the setups are untouched copies.

Conditionally:
the Ubuntu-provided Tomcat works with simple JSPs -- like the introductory example in "Pro Tomcat6"(don't ask me why that makes a difference towards the binding...but that was my first test case) -- but as soon as I try a real webapp (webprotege from Univ. o. Stanford) the setup fails with the Ubuntu-provided Tomcat but works as expected with the compiled one.
If you can't reproduce it and if you are willing to wait, I could try to setup the working setup with the Ubuntu-provided package again and make a test protocol. Just to make sure I didn't hallucinate the test case with the simple JSPs.

I'm willing to help, but might not be able to answer or test daily. So any delay isn't meant to be a lack of courtesy.

Regards

Thierry Carrez (ttx) on 2010-11-24
Changed in tomcat6 (Ubuntu):
status: Incomplete → New
importance: Undecided → Medium
Changed in tomcat6:
importance: Unknown → Medium
status: Unknown → Fix Released
James Page (james-page) wrote :

Hi Benjamin

I've spent the last few hours trying to re-produce your issue - alas with no success.

I've attached the configuration I used to this bug report; if you could review much appreciated.

I've successfully run webprotege on a fresh tomcat installation configured to your spec; I'm either missing something obvious or your problem is being caused by something else.

Do you get exactly the same log error messages as seen in the upstream report? Any log data that you have may also help identify the issue.

Thanks

James Page (james-page) wrote :
James Page (james-page) wrote :
James Page (james-page) wrote :
James Page (james-page) wrote :
Chuck Short (zulcss) wrote :

According to the upstream bug report this is fixed. If possible can you test this in a newer release?

Changed in tomcat6 (Ubuntu):
status: New → Incomplete
Clint Byrum (clint-fewbar) wrote :

Fixed upstream, marking as affecting lucid as its a decent candidate for SRU if somebody wants to take on the task of preparing an SRU package with the patch attached.

Changed in tomcat6 (Ubuntu):
status: Incomplete → Fix Released
Changed in tomcat6 (Ubuntu Lucid):
status: New → Triaged
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.