tomcat6 (6.0.24) "Duplicate local variable" error

Bug #563642 reported by Märt Suga on 2010-04-15
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Apache Tomcat6 Package for Ubuntu
Fix Released
Critical
tomcat6 (Ubuntu)
Medium
Unassigned
Lucid
Medium
Thierry Carrez

Bug Description

Binary package hint: tomcat6

version: tomcat 6.0.24

Since it is already reported in bugzilla I am not going to copy-paste it all here.
Full description of the bug can be found here: https://issues.apache.org/bugzilla/show_bug.cgi?id=48616

Since 6.0.24 is the default version in lucid and the bug is fixed in newer versions the solution could be to upgrade the lucid package.

== SRU Report ==
Impact:
Regression for applications using Struts 1.2 or bean:define, they can't work after upgrading to Lucid.

Development branch fix:
6.0.26 upstream has this fix, and a sync request to 6.0.26-1 was filed.

Minimal patch:
http://bazaar.launchpad.net/~ttx/tomcat6/lucid-sru/revision/20

TEST CASE:
$ sudo apt-get install tomcat6
$ cd /tmp && tar zxvf testcase.tar.gz
$ sudo mv /tmp/struts-blank /var/lib/tomcat6/webapps
Access http://localhost:8080/struts-blank/pages/Welcome.jsp
Affected version returns: HTTP status 500 Unable to compile class for JSP / Duplicate local variable
Fixed version returns: a "Welcome" page.

Regression potential:
Given the nature of the patch it is regression-prone, however that patch was applied upstream, released in 6.0.25+ and did not trigger known regressions.

Scott Moser (smoser) wrote :
Changed in tomcat6 (Ubuntu):
importance: Undecided → High
status: New → Triaged
Märt Suga (mart-suga) wrote :

Tried it. Seems to work perfectly in my case.

Thierry Carrez (ttx) wrote :

Only affects Struts / bean:define users so lowering to Medium, nominating to Lucid regardless, as I plan to fix this.

Changed in tomcat6 (Ubuntu):
importance: High → Medium
Thierry Carrez (ttx) on 2010-04-21
Changed in tomcat6 (Ubuntu Lucid):
assignee: nobody → Thierry Carrez (ttx)
Thierry Carrez (ttx) on 2010-04-23
Changed in tomcat6 (Ubuntu Lucid):
assignee: Thierry Carrez (ttx) → nobody
milestone: none → lucid-updates
Thierry Carrez (ttx) on 2010-05-21
Changed in tomcat6 (Ubuntu Lucid):
assignee: nobody → Thierry Carrez (ttx)
status: Triaged → In Progress
Thierry Carrez (ttx) wrote :
description: updated
Märt Suga (mart-suga) wrote :

I can confirm that the patch fixed the testcase for me.

Thierry Carrez (ttx) on 2010-05-21
Changed in tomcat6 (Ubuntu):
status: Triaged → Fix Released
Changed in tomcat6 (Ubuntu Lucid):
status: In Progress → Fix Committed

Accepted tomcat6 into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Märt Suga (mart-suga) wrote :

Works for me correctly.

Thierry Carrez (ttx) on 2010-06-04
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tomcat6 - 6.0.24-2ubuntu1.1

---------------
tomcat6 (6.0.24-2ubuntu1.1) lucid-proposed; urgency=low

  * debian/patches/fix-jsp-regression.patch: Fix regression in JSP compilation
    that resulted in "Duplicate local variable" errors when using Struts 1.2
    or bean:define (LP: #563642)
  * debian/tomcat6.{postinst,prerm}: Respect TOMCAT6_USER and TOMCAT6_GROUP
    as defined in /etc/default/tomcat6 when setting directory permissions and
    authbind configuration (LP: #557300)
  * debian/tomcat6.postinst: Use group "tomcat6" instead of "adm" for
    permissions in /var/lib/tomcat6, so that group "adm" doesn't get write
    permissions over /var/lib/tomcat6/webapps (LP: #569118)
 -- Thierry Carrez <email address hidden> Fri, 21 May 2010 10:11:35 +0200

Changed in tomcat6 (Ubuntu Lucid):
status: Fix Committed → Fix Released
Changed in tomcat6:
importance: Unknown → Critical
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.