Ubuntu

server.number reports 6.0.0.0 not 6.0.X.0

Reported by Disconnect on 2009-12-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Server papercuts
Low
Thierry Carrez
tomcat6 (Ubuntu)
Low
Thierry Carrez

Bug Description

Binary package hint: tomcat6

Upstream tomcat6 server properties is:
server.info=Apache Tomcat/6.0.18
server.number=6.0.18.0
server.built=Jul 22 2008 02:00:36

Ubuntu (for 6.0.18-2ubuntu6) reports:
server.info=Apache Tomcat/6.0.18
server.number=6.0.0.0
server.built=Jun 10 2009 08:27:38

This makes version detection impossible using the "correct" method (http://tomcat.apache.org/tomcat-6.0-doc/api/org/apache/catalina/util/ServerInfo.html) and breaks upstream compatibility.

ProblemType: Bug
Architecture: amd64
Date: Fri Dec 11 09:51:55 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: tomcat6 (not installed)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: tomcat6
Uname: Linux 2.6.31-14-generic x86_64
XsessionErrors: (polkit-gnome-authentication-agent-1:7855): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

Thierry Carrez (ttx) wrote :

Right, we use upstream build.xml file and it says:
  <property name="version.major" value="6" />
  <property name="version.minor" value="0" />
  <property name="version.build" value="0" />
  <property name="version.patch" value="0" />
  <property name="version.number" value="${version.major}.${version.minor}.${version.build}.${version.patch}" />

We should update that at buildtime.

Changed in tomcat6 (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Thierry Carrez (ttx) on 2010-02-11
Changed in server-papercuts:
importance: Undecided → Low
status: New → Confirmed
Thierry Carrez (ttx) on 2010-03-02
Changed in server-papercuts:
milestone: none → lucid-beta-2
Ludovic Claude (ludovicc) wrote :

I'm adding the following to debian/rules in Debian. Do you see any problem with starting Tomcat or is it only in Debian?
Ludovic

T_VER_MAJOR := $(echo $(T_VER) | cut -d'.' -f1)
T_VER_MINOR := $(echo $(T_VER) | cut -d'.' -f2)
T_VER_BUILD := $(echo $(T_VER) | cut -d'.' -f3)

ANT_ARGS := -Dcompile.debug=true \
 -Dant.build.javac.source=1.5 \
 -Dant.build.javac.target=1.5 \
 -Djdt.jar=/usr/share/java/ecj.jar \
 -Dversion=$(T_VER) \
    -Dversion.major="$(T_VER_MAJOR)" \
    -Dversion.minor="$(T_VER_MINOR)" \
    -Dversion.build="$(T_VER_BUILD)" \
    -Dversion.patch="0" \
    -Dversion.suffix=""

Thierry Carrez (ttx) on 2010-03-17
Changed in server-papercuts:
assignee: nobody → Thierry Carrez (ttx)
Ludovic Claude (ludovicc) wrote :

Fixed in tomcat6-6.0.24-4, soon to be in Debian unstable

Thierry Carrez (ttx) on 2010-03-22
Changed in tomcat6 (Ubuntu):
assignee: nobody → Thierry Carrez (ttx)
importance: Medium → Low
status: Triaged → In Progress
Changed in server-papercuts:
status: Confirmed → In Progress
Thierry Carrez (ttx) wrote :

Blocked on sync bug 543443

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tomcat6 - 6.0.24-2ubuntu1

---------------
tomcat6 (6.0.24-2ubuntu1) lucid; urgency=low

  [ Thierry Carrez ]
  * Uploading what 6.0.24-5 should be (upload is blocked in Debian due to
    current infrastructure issues), in order to meet Beta2Freeze.

  [ Niels Thykier ]
  * Added optimised garbage collection options to tomcat6's default options.
    Thanks to Aaron J. Zirbes and Thierry Carrez for research and the patch.
    (Closes: LP: #541520)
  * Updated the changelog to mention closed CVE's in the 6.0.24-1 release.
  * Applied patch from Arto Jantunen fixing an issue with cleaning up the
    pid-file. (Closes: #574084)

  [ Ludovic Claude ]
  * debian/tomcat6.postrm: fix removal of Tomcat (Closes: #567548)
  * Set UTF-8 as default character encoding - Patch by Thomas Koch
    (Closes: #573539)
  * Set the major, minor and build versions when calling Ant
    (Closes: LP: #495505)
  * Rebuild with a more recent version of maven-repo-helper which puts
    the javax jars at the correct location in the Maven repository.
    Fixes several FTBFS in other packages.
 -- Thierry Carrez <email address hidden> Wed, 31 Mar 2010 10:47:51 +0200

Changed in tomcat6 (Ubuntu):
status: In Progress → Fix Released
Thierry Carrez (ttx) on 2010-03-31
Changed in server-papercuts:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers