libtomcat6-java depends on libecj-java

Bug #352446 reported by stephen mulcahy on 2009-03-31
2
Affects Status Importance Assigned to Milestone
tomcat6 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: tomcat6

libtomcat6-java depends on libecj-java which in turn installs gcj.

In practice, if I have sun-java6-jdk installed and then install tomcat6 with

sudo aptitude -R install tomcat6

which doesn't pull

ecj-gcj libecj-java-gcj

as dependencies, everything works fine and my environment continues using sun java6 (which I need
for my project).

Can we rectify the dependencies here to avoid this implicit dependency on gcj?

Thierry Carrez (ttx) wrote :

The problem is in libecj-java recommending gcj. So this is a duplicate of bug 347393

So it is, apologies for not checking all the dependencies before opening this. Feel free to close.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers