Tomboy not connecting to Ubuntu One server note store

Bug #857192 reported by nick on 2011-09-23
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
tomboy (Ubuntu)
Undecided
Unassigned

Bug Description

When trying to configure Tomboy to connect to my note store via the Tomboy web synchronization method , applications fails with the following error.

9/23/2011 2:54:48 PM [ERROR]: Failed to get auth URL from https://one.ubuntu.com/notes/. Exception was: System.Net.WebException: The remote server returned an error: (400) BAD REQUEST.
  at System.Net.HttpWebRequest.CheckFinalStatus (System.Net.WebAsyncResult result) [0x00000] in <filename unknown>:0
  at System.Net.HttpWebRequest.SetResponseData (System.Net.WebConnectionData data) [0x00000] in <filename unknown>:0

This was working perfectly with Ubuntu 11.04, but is now broken in 11.10 beta 1 & 2

1) Using Ubuntu 11.10 latest Updates applied as of 23/09/2011
2) Tomboy 1.7.6
3) I should be able to connect to the remote note store
4) Tomboy errored and is unable to connect to the note store

I have not tried using the Ubuntu one synchronization method, as it does not work through a proxy, and this is a work machine and has to work through a proxy.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: tomboy 1.7.6-1ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
Date: Fri Sep 23 14:58:31 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: tomboy
UpgradeStatus: Upgraded to oneiric on 2011-09-22 (0 days ago)

nick (swcodfather) wrote :
nick (swcodfather) wrote :

Ok, progress is being made in the latest version.

Tomboy now connects to the server, and attempts authorization. It then sends you back to Tomboy to click save, unfortunately that box is greyed out, so you can't

This still means that Tomboy is not useable at the moment with Web storage.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in tomboy (Ubuntu):
status: New → Confirmed
nick (swcodfather) wrote :

This problem still exist's, and I have a screen capture of the problem. Tomboy is now authorising the sync link to the Ubuntu one note store, but when you come back to the Tomboy app to select save, it is greyed out and you can't. Perhaps the two components are not talking together properly?

Anyway, I now have a screen capture of what is not happening.

I have tried it with both Firefox and Google Chrome browsers, and Chrome actually gets further. You get a can't connect to port 3000 with Firefox.

nick (swcodfather) wrote :

Here is a screenshot of the error you get when using Firefox, just for completeness

Jacopo Moronato (jmoronat) wrote :

I'm marking as duplicate as it seems it is the same issue.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers