Ubuntu

Unable to setup Ubuntu One sync with Tomboy

Reported by Sean Sosik-Hamor on 2011-09-09
500
This bug affects 130 people
Affects Status Importance Assigned to Milestone
Ubuntu One Servers
Undecided
Unassigned
tomboy (Ubuntu)
Medium
Unassigned
Oneiric
Medium
Unassigned
Precise
Medium
Unassigned

Bug Description

When setting up Tomboy to sync with Ubuntu One I'm unable to click Save in the Synchronization tab in Tomboy Preferences.

After getting the "Tomboy Web Authorization Successful - Please return to the Tomboy Preferences window and press Save to start synchronizing." screen in my browser I'm unable to actually click Save.

The Tomboy Preferences is stuck at "Authorizing in browser (Press to reset connection)" and the Save dialog is grayed out.

Screenshot attached in next comment.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: tomboy 1.7.6-1ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
NonfreeKernelModules: nvidia wl
ApportVersion: 1.22.1-0ubuntu2
Architecture: amd64
CheckboxSubmission: 15c9c9b122c9273f52b28c9a5df794ac
CheckboxSystem: 7e42599bda39ea7ff8b528272b6ef52b
Date: Thu Sep 8 23:28:48 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64+mac (20110901)
SourcePackage: tomboy
UpgradeStatus: Upgraded to oneiric on 2011-09-08 (1 days ago)

Workaround:
After getting the "Tomboy Web Authorization Successful - Please return to the Tomboy Preferences window and press Save to start synchronizing." you return to the Tomboy Preferences and edit the server field to make the Save button clickable. The server field reads https://one.ubuntu.com/notes/. If you delete then retype the trailing slash '/' in the server field the Save button will be clickable.

Sean Sosik-Hamor (sciri) wrote :
Sean Sosik-Hamor (sciri) wrote :

Screenshot showing grayed-out Save button.

Changed in tomboy (Ubuntu):
status: New → Confirmed
Rainer Rohde (rainer-rohde) wrote :

I have the same issue. Tomboy allows me to select Ubuntu One in the sync options, but it doesn't stick. I am unable to sync to Ubuntu One.

Tom (teeks99) wrote :

I also tried:
sudo dpkg-reconfigure tomboy, but to no avail

This is on a fresh install of oneiric beta 1 plus updates (Sept 10, 2011).

Attached is the screen video of what the problem looks like. I've already activated ubuntu one, so it doesn't have that step. Just the bug trying to select it for synchronization.

Rodrigo Moya (rodrigo-moya) wrote :

Can you please quit tomboy and, on a terminal, run:

$ tomboy --debug

and then try to configure syncing to U1 as normal and, when it fails, please copy all the output in the terminal and paste it here.

Tom (teeks99) wrote :
Download full text (5.2 KiB)

1) Ran tomboy --debug
2) Right clicked on tray icon and selected preferences
3) Synchronization tab: set to local folder, so I hit the "clear" button to enable the selection of a different source
4) Selected "Ubuntu One" from the drop down
5) Confirmed that the "Save" button was grayed out, but the (also grayed out) button immediately below the drop down that said "Ubuntu One" said "Already Registered"
6) Clicked "Close" button for preferences
7) Quit tomboy from the tray icon
8) Copied terminal output here:

tomkent@abe:~$ tomboy --debug
** Running Mono with --debug **
[DEBUG 11:57:59.787] Failed to register with session manager: org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
[DEBUG 11:57:59.872] NoteManager created with note path "/home/tomkent/.local/share/tomboy".
[INFO 11:58:00.390] Initializing Mono.Addins
[DEBUG 11:58:00.465] AddinManager.OnAddinLoaded: Tomboy.Tomboy
[DEBUG 11:58:00.465] Name: Tomboy.Tomboy,0.10
[DEBUG 11:58:00.465] Description:
[DEBUG 11:58:00.465] Namespace: Tomboy
[DEBUG 11:58:00.465] Enabled: True
[DEBUG 11:58:00.465] File: /usr/lib/tomboy/Tomboy.exe
[DEBUG 11:58:00.980] AddinManager.OnAddinLoaded: Tomboy.ExportToHtmlAddin
[DEBUG 11:58:00.980] Name: Export to HTML
[DEBUG 11:58:00.980] Description: Exports individual notes to HTML.
[DEBUG 11:58:00.980] Namespace: Tomboy
[DEBUG 11:58:00.980] Enabled: True
[DEBUG 11:58:00.980] File: /usr/lib/tomboy/addins/ExportToHtml.dll
[DEBUG 11:58:00.983] AddinManager.OnAddinLoaded: Tomboy.WebDavSyncServiceAddin
[DEBUG 11:58:00.983] Name: WebDav Sync Service Add-in
[DEBUG 11:58:00.983] Description: Synchronize Tomboy Notes to a WebDav URL
[DEBUG 11:58:00.983] Namespace: Tomboy
[DEBUG 11:58:00.983] Enabled: True
[DEBUG 11:58:00.983] File: /usr/lib/tomboy/addins/WebDavSyncService.dll
[DEBUG 11:58:01.005] Unable to locate 'gnomesu' in your PATH
[DEBUG 11:58:01.005] Using '/usr/bin/gksu' as GUI 'su' tool
[DEBUG 11:58:01.005] Successfully found all system tools
[DEBUG 11:58:01.006] Unable to locate 'wdfs' in your PATH
[DEBUG 11:58:01.006] AddinManager.OnAddinLoaded: Tomboy.WebSyncServiceAddin
[DEBUG 11:58:01.007] Name: Web Sync Service Add-in
[DEBUG 11:58:01.007] Description: Synchronize Tomboy Notes with Tomboy Online and other compatible web services
[DEBUG 11:58:01.007] Namespace: Tomboy
[DEBUG 11:58:01.007] Enabled: True
[DEBUG 11:58:01.007] File: /usr/lib/tomboy/addins/WebSyncServiceAddin.dll
[DEBUG 11:58:01.009] AddinManager.OnAddinLoaded: Tomboy.FileSystemSyncServiceAddin
[DEBUG 11:58:01.010] Name: Local Directory Sync Service Add-in
[DEBUG 11:58:01.010] Description: Synchronize Tomboy Notes to a local file system path
[DEBUG 11:58:01.010] Namespace: Tomboy
[DEBUG 11:58:01.010] Enabled: True
[DEBUG 11:58:01.010] File: /usr/lib/tomboy/addins/FileSystemSyncService.dll
[DEBUG 11:58:01.013] Loading notes
[DEBUG 11:58:01.139] AddinManager.OnAddinLoaded: Tomboy.StickyNoteImportAddin
[DEBUG 11:58:01.139] Name: Sticky Notes Importer
[DEBUG 11:58:01.139] Description: Import your no...

Read more...

Sean Sosik-Hamor (sciri) wrote :

1) Launched tomboy --debug
2) Selected Tomboy Preferences -> Synchronization
3) Selected Tomboy Web per the HowTo in the Ubuntu One note
4) Clicked Authorize
5) Authorize button turned into Authorizing in browser (Press to reset connection) button
6) Browser opened and authorized
7) Returned to Tomboy; Save button is grayed out

Actual tokens in logs replaced with REDACTED.

[DEBUG 17:53:21.855] Listening on http://localhost:8000/tomboy-web-sync/ for OAuth callback
[DEBUG 17:53:21.858] Building web request for URL: https://one.ubuntu.com/oauth/request/
[DEBUG 17:53:22.041] Response from request for auth url: oauth_token_secret=REDACTED&oauth_token=REDACTED&oauth_callback_confirmed=true
[DEBUG 17:53:22.042] Launching browser to authorize web sync: https://one.ubuntu.com/oauth/authorize/?oauth_token=REDACTED&oauth_callback=http%3a%2f%2flocalhost%3a8000%2ftomboy-web-sync%2f

(google-chrome:13165): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(google-chrome:13165): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(google-chrome:13165): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(google-chrome:13165): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
Created new window in existing browser session.
[DEBUG 17:53:32.012] Context request uri query section: ?oauth_token=REDACTED&oauth_verifier=REDACTED&return=https://one.ubuntu.com
[DEBUG 17:53:32.013] Asking server for access token based on authorization token.
[DEBUG 17:53:32.013] Building web request for URL: https://one.ubuntu.com/oauth/access/
[DEBUG 17:53:32.152] Received response from server: oauth_token_secret=REDACTED&oauth_token=REDACTED
[DEBUG 17:53:32.152] Got access token from server
[DEBUG 17:53:32.152] Successfully authorized web sync

At this point the Save dialog is still grayed out per my original screenshot attached above.

Changing from Tomboy Web to Ubuntu One results in the Authorizing in browser (Press to reset connection) button changing to Already Registered and the Save button is grayed out.

** (Tomboy:13138): DEBUG: SyncDaemon already running, initializing SyncdaemonDaemon object

PeterPall (peterpall) wrote :

A temporary solution would be to tell tomboy that sync is set up directly by setting the respective gconf key:
 - close tomboy
 - Make sure you are logged in into ubuntu one e.G. using ubuntuone-control-panel-gtk
 - start gconf-editor
 - select the key /apps/tomboy/sync/sync_selected_service_addin
 - change it's value to the following word: ubuntuone
 - close gconf-editor
 - start tomboy
 - preferences/sync preferences
 - synchronize now
 - sync Works.
Unfortunately tomboy seems to forget about this once in a while.

d0ti5 (d0ti5) wrote :

Concur with PeterPall; solution works, very easy.

Barry Warsaw (barry) wrote :

Note too that when asked to confirm adding the computer in my browser, the computer name is given as "None" (sans quotes). I don't know if that's related.

My computer is also listed as "None." The fix that PeterPall gave didn't work for me, it stills shows a grayed out save button.

Mike Chelen (mchelen) wrote :

Suggested fix did not work here either.

Nick B. (futurepilot) wrote :

This is what worked for me. Follow the instructions in comment #8 except instead of using "ubuntuone" use "tomboyweb".

But then Tomboy will save the notes on the tomboy web server instead to ubuntu one;
My old fix seems to have stopped working for me, too, in the meantime.

Nick B. (futurepilot) wrote :

No it won't. They dropped the separate ubuntuone sync option and rolled it into the tomboy web one. It should have https://one.ubuntu.com/notes already in the server field. If it doesn't, (it really should though) just put that address in there.

On 10/04/2011 12:23 PM, PeterPall wrote:
> But then Tomboy will save the notes on the tomboy web server instead to ubuntu one;
> My old fix seems to have stopped working for me, too, in the meantime.
>

Tobias Bradtke (webwurst) wrote :

The save button was always greyed out for me. Today I tried again and found out, that editing the server field enabeld the save button for me.

1. Edit server field. (Add a character and remove again)
2. Connect do server
3. Save

@Tobias: for a moment I taught this might work for me as well. Unfortunatelly, just one single note was taken from server, and an error occured. Manually sync I can not obtain the other notes, so I will wait for the automatic sync in 30 min.

PeterPall (peterpall) wrote :

I seem to remember that there was a separate bug report that that the mechanism that resolves conflicts sometimes decides to abort the sync. Perhaps you have encountered this problem.

Alex Moldovan (alexmoldovan) wrote :

Comment #16 worked for me

Till Sachau (till-sachau) wrote :

Comment #16 works for me as well. I believe that I remember the same problem several Ubuntu-iterations ago.

#16 works for me but whenever I do a sync (manual or auto), it doesn't upload my notes to the server and says sync failed. It also asks me to download the server copy of the same note and rename my local note as old. But my local note is the newer note and it should have uploaded. For me only download is working.

PeterPall (peterpall) wrote :

What I sometimes experience if I try to sync after tomboy has lost track
of what really happens is that tomboy doesn't dare to touch the contents
of notes on the local computer or on the server and finds it less risky to
 - rename all notes on the local computer it doesn't dare to replace
 - download all notes from the server
 - and afterwards to upload all notes it has renamed.
The advantage of this approach is that you are sure not to loose a thing
The disadvantage is that you might end up with loads of notes in two
versions: An old and a new one.

Not sure if you encountered this kind of behavior.

I've had that behaviour which is fine since its safer, but this one is definitely a bug. It fails to sync on every sync right now, and this is a fresh and updated 11.10 beta 2 install. If I edit an existing note and sync, it doesn't upload my one at all, it just downloads the old one from the server (I'm syncing to Ubuntu One) and asks me to overwrite or rename my local note. It just doesn't want to upload at all.

It works for me after remove the last slash char.

Herbert Balagtas (hbalagtas) wrote :

Removing the trailing slash worked for me too!

Lucazade (lucazade) wrote :

The workaround doesn't work well here...
removing the slash I can only sync half of my notes and sync says it fails.
I tried also to purge all the tomboy config files locally and tried again but same error.. just a part of available notes are synced with u1 servers.

Same issue here, removing the slash doesn't help, it just downloads the notes from the servers and ignores my local changes.

Michael Spall (spalmich) wrote :

What fixed it for me was in "tomboy preferences" -> "Synchronization" changing the server from https://one.ubuntu.com/notes/ to https://edge.one.ubuntu.com/notes/

I think this is a duplicate of:
https://bugs.launchpad.net/ubuntu/+source/tomboy/+bug/842278

Michael Spall (spalmich) wrote :

I have done a fresh install with the daily build from today and it fails to sync after 9 notes. The switch from https://one.ubuntu.com/notes/ to https://edge.one.ubuntu.com/notes/ seems to be more of an issue of making a change in the box to allow saving (see #16). Both allow the sync of a few notes before failing.

enolive (enolive) wrote :

I experienced this bug on two machines (x86 and x64). Workaround #16 works well, though

nick (swcodfather) wrote :

When I either change a character or the server , I still get an error wgen clicking save, see attachment picture, and then I see the following error in the logs. In fact that is all there is in the logs ;-)

10/14/2011 10:25:15 AM [INFO]: Initializing Mono.Addins
10/14/2011 10:25:15 AM [ERROR]: Unparsable last-sync-date element in /home/<username>/.config/tomboy/manifest.xml

This is how the manifest.xml looks like

<?xml version="1.0" encoding="utf-8"?>
<manifest xmlns="http://beatniksoftware.com/tomboy">
  <last-sync-date>0001-01-01T00:00:00.0000000+01:00</last-sync-date>
  <last-sync-rev>-1</last-sync-rev>
  <server-id />
  <note-revisions />
  <note-deletions />
</manifest>

Hope this information helps the fix.

Regards

Nick

Changed in tomboy (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
importance: Undecided → Medium
milestone: none → oneiric-updates

Changing the "Server" input field to https://edge.one.ubuntu.com/notes/ in Tomboy's Synchronization preference pane did the trick for me.

Michael Spall (spalmich) wrote :

This is the error I see in .config/tomboy/tomboy.log

10/14/2011 1:24:23 PM [ERROR]: Synchronization failed with the following exception: A note with this title already exists: New Note Template
  at Tomboy.NoteManager.CreateNewNote (System.String title, System.String xml_content, System.String guid) [0x00000] in <filename unknown>:0
  at Tomboy.NoteManager.CreateNoteFromTemplate (System.String title, Tomboy.Note template_note, System.String guid) [0x00000] in <filename unknown>:0
  at Tomboy.NoteManager.CreateNewNote (System.String title, System.String guid) [0x00000] in <filename unknown>:0
  at Tomboy.NoteManager.CreateWithGuid (System.String title, System.String guid) [0x00000] in <filename unknown>:0
  at Tomboy.Sync.SyncManager+<CreateNoteInMainThread>c__AnonStorey11.<>m__3F () [0x00000] in <filename unknown>:0
  at Tomboy.GuiUtils+<GtkInvokeAndWait>c__AnonStoreyC.<>m__2F (System.Object , System.EventArgs ) [0x00000] in <filename unknown>:0

I couldn't see a note called "New Note Template" when I visited https://one.ubuntu.com/notes/ by web browser.
I solved this by creating a Note called "New Note Template" using Tomboy on another computer, syncing the other computer, and then deleting it from that other computer and syncing the other computer again.

citosid (abraham-sustaita) wrote :

I can confirm that changing the URI to https://edge.one.ubuntu.com/notes/ fix the issue

Thanks to Sébastien Pierre for the tip

Not for me, and I can not belive that this bug cannot be resolved, because Tomboy is an application widelly used.

Ken VanDine (ken-vandine) wrote :

To use the work around, you need to remove the last "/" and then add it again BEFORE you authenticate. The bug really has nothing to do with the url, it is the "Save" button is insensitive until that entry has changed. I have a fix waiting for the SRU team to approve.

Hello Sean, or anyone else affected,

Accepted tomboy into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Changed in tomboy (Ubuntu Oneiric):
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Ken VanDine (ken-vandine)
Changed in tomboy (Ubuntu Precise):
milestone: oneiric-updates → none
Changed in tomboy (Ubuntu Oneiric):
milestone: none → oneiric-updates
Miklos Juhasz (mjuhasz) wrote :

The version in proposed works fine.
After successful authentication I returned to Tomboy and the Save button was enabled and pressing it completed the setup and the synchronization went fine.

tags: added: indicator-application
tags: added: verification-done
removed: indicator-application verification-needed
nick (swcodfather) wrote :

I can also confirm that the new version in proposed works fine, and I have been able to set up my account and sync the notes correctly.

Thanks for that.

Nick

dagr (dag-ringdal) wrote :

When will the fix be out in the ordinary update? Sorry for asking. You guys seem very experienced, but I'm new to this.

--dag

Torsten Spindler (tspindler) wrote :

It usually takes a week or two.

Mauricio Pretto (pretto) wrote :

I'm to setup sync now but only a hand full of notes get synced than the other fails

Mauricio Pretto (pretto) wrote :

I'm able :)

Now the trick for activating the Save button works, but the sync failed. So the upgrade adress this issue, too?

Ken VanDine (ken-vandine) wrote :

Sync failures aren't related, please file a separate bug.

Excerpts from Torsten Spindler's message of Wed Oct 19 06:28:53 UTC 2011:
> It usually takes a week or two.
>

The update must be published in -proposed for 7 days no matter what. After
that, if verification of the fix has been done, it will progress into updates.

So, expect to see it in about 6 days.

dyess002 (dyess002) wrote :

#29 worked for me

Tobias Bradtke (webwurst) wrote :

For sync failures you may have a look at https://bugs.launchpad.net/ubuntu/+source/tomboy/+bug/848250

igi (igor-cali) on 2011-10-22
tags: added: i386
Mathias Dietrich (theghost) wrote :

#16 worked fine here with Tomboy 1.8.0. Just removed the last slash and readded it. Then the save button became activated and synchronization / authentication with server worked fine.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tomboy - 1.8.0-1ubuntu1.1

---------------
tomboy (1.8.0-1ubuntu1.1) oneiric-proposed; urgency=low

  [ Iain Lane ]
  * debian/control: Remove syncdaemon BD which is no longer required due to
    the dropping of the SSO patch in 1.8.0-1ubuntu1

  [ Ken VanDine ]
  * debian/patches/02_sync_save_button_sensitive.patch
    - Set save button sensitive when needed (LP: #845321)
 -- Ken VanDine <email address hidden> Fri, 14 Oct 2011 09:38:21 -0400

Changed in tomboy (Ubuntu Precise):
status: Confirmed → Fix Released
Changed in tomboy (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Leo Arias (elopio) wrote :

Thanks for the fix Ken. It works here.
(hug)

Jim Raredon (decoy-umd) wrote :

Fixed for me on three instances of Oneiric. Thanks!

alex (aarw2) wrote :

I just sudo dpkg-reconfigure tomboy and it improves things a bit in that i was able to connect to the Server. But Tomboy crashes at the start of synchronisation. Synchronisation is totally borked in 11.10 for Tomboy

Ken VanDine (ken-vandine) wrote :

@aarw2 please look at bug 848250 to see if that might be what you are experiencing. If not, please open a new bug for the sync problem. Thanks!

Changed in tomboy (Ubuntu Oneiric):
assignee: Ken VanDine (ken-vandine) → nobody
Changed in tomboy (Ubuntu Precise):
assignee: Ken VanDine (ken-vandine) → nobody
description: updated
Rick McBride (rmcbride) wrote :

Marking invalid in u1-servers, as the issue manifests client side.

Changed in ubuntuone-servers:
status: New → Invalid
Richard Ssekibuule (rkayondo) wrote :

I am trying to sync my notes and I get page not found for https://one.ubuntu.com/notes/

What's going on? Ubuntu should have a better page at https://one.ubuntu.com/notes/ to inform users better. This used to work out of the box. Please help.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers