Ubuntu

Hitting delete key while focus in search box triggers deletion of note

Reported by Abhinav Upadhyay on 2011-04-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tomboy
Fix Released
Medium
tomboy (Ubuntu)
Low
Abhinav Upadhyay

Bug Description

Binary package hint: tomboy

I came across this problem today:

I searched for a particular note by typing in the search box, some notes displayed in the search results. I opened one of the notes and closed it after reading. Now I wanted to search something else, so I had to clear the text box. Unknowingly I used Ctrl+A and Delete key to clear the text (rather than using the clear text button available in Tomboy UI) .

What should have happened: The search box should have cleared.

What happened instead: A message box popped up, asking me if I am sure I want to delete the selected note ?

p.s.: Using Ctrl+A and backspace clears the text box as expected.
You don't need to select text and then hit the delete key to reproduce this bug. Even if you select one of the notes in the right pane, and then move the keyboard focus to the search drop down box, and then hit Delete, you will face this problem.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: tomboy 1.4.2-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.35-28.49-generic 2.6.35.11
Uname: Linux 2.6.35-28-generic i686
NonfreeKernelModules: fglrx
Architecture: i386
Date: Mon Apr 11 20:21:39 2011
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
ProcEnviron:
 LANG=en_IN
 SHELL=/bin/bash
SourcePackage: tomboy

Changed in tomboy (Ubuntu):
status: New → Confirmed
Changed in tomboy:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in tomboy (Ubuntu):
assignee: nobody → Abhinav Upadhyay (er-abhinav-upadhyay)
Changed in tomboy (Ubuntu):
status: Confirmed → In Progress

Attached is a fix for this problem. The bug is confirmed by tomboy developers (upstream). I have also sent the patch upstream and it is due to be reviewed by them.

Thanks

tags: added: patch
summary: - Selecting all text in search box and hitting Delete key triggers the
- deletion of note
+ Hitting delete key while focus in search box triggers deletion of note
description: updated
Changed in tomboy (Ubuntu):
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tomboy - 1.6.0-0ubuntu3

---------------
tomboy (1.6.0-0ubuntu3) natty; urgency=low

  * debian/patches/31_prevent_inadvertent_deletion_of_notes.patch:
    - Tomboy/RecentChanges.cs: Added code for handling FocusInEvent of the search
      combo box, it disables the "Delete" option in the menu bar when the focus is
      is in the search box, which prevents deletion of notes on hitting the delete
      key. (LP: #757635)
 -- Abhinav Upadhyay <email address hidden> Wed, 20 Apr 2011 12:20:25 +0200

Changed in tomboy (Ubuntu):
status: In Progress → Fix Released
Changed in tomboy:
status: Confirmed → In Progress
Changed in tomboy:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.