Ubuntu One sync points to the edge server

Bug #745721 reported by Alejandro J. Cura on 2011-03-30
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tomboy (Ubuntu)
Medium
Ken VanDine
Maverick
Medium
Unassigned
Natty
Medium
Ken VanDine

Bug Description

Binary package hint: tomboy

Tomboy synchronization points to the edge servers instead of the production servers.
So "https://edge.one.ubuntu.com/notes/" will need to be changed to: "https://one.ubuntu.com/notes/" on the Ubuntu diff.
This happens both on the Natty and the Maverick package.

Changed in tomboy (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
Changed in tomboy (Ubuntu Maverick):
assignee: nobody → Ken VanDine (ken-vandine)
Alejandro J. Cura (alecu) wrote :

To test if this bug is fixed, make sure your tomboy is already syncing with Ubuntu One, and follow these steps:

1) gconftool -g /apps/tomboy/sync/ubuntuone/server
2) it should print the wrong url: "https://edge.one.ubuntu.com/notes/"
3) start tomboy, select "Edit->Preferences" from the menu, and in the "Synchronization" tab click on "Clear"
4) shut down tomboy
5) the gconftool as in 1) should now print an empty line
6) install the fixed version of the tomboy package
7) start tomboy, select "Edit->Preferences" from the menu, and in the "Synchronization" tab select "Ubuntu One" as the service, then "Register this Computer", and finally "Save".
8) finally, gconftool as in 1) should now show the right url: "https://one.ubuntu.com/notes/"

Changed in tomboy (Ubuntu Maverick):
assignee: Ken VanDine (ken-vandine) → nobody
Changed in tomboy (Ubuntu Natty):
assignee: Ken VanDine (ken-vandine) → nobody
Changed in tomboy (Ubuntu Maverick):
importance: Undecided → Medium
Changed in tomboy (Ubuntu Natty):
importance: Undecided → Medium
Martin Pitt (pitti) wrote :

Please fix this in natty ASAP, so that this can progress to -updates.

Changed in tomboy (Ubuntu Maverick):
status: New → Fix Committed
tags: added: verification-needed

Accepted tomboy into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in tomboy (Ubuntu Natty):
assignee: nobody → Rodrigo Moya (rodrigo-moya)
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

ok, seems ken already uploaded to the natty queue but just didn't update the bug, sorry for the noise rodrigo

Changed in tomboy (Ubuntu Natty):
assignee: Rodrigo Moya (rodrigo-moya) → Ken VanDine (ken-vandine)
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tomboy - 1.5.2-1ubuntu5

---------------
tomboy (1.5.2-1ubuntu5) natty; urgency=low

  * debian/patches/06_use_ubuntu_sso.patch
    - Use the Ubuntu One production services instead of edge
      servers (LP: #745721)
 -- Ken VanDine <email address hidden> Wed, 30 Mar 2011 10:19:09 -0400

Changed in tomboy (Ubuntu Natty):
status: Fix Committed → Fix Released
Pedro Villavicencio (pedro) wrote :

I've followed the test case posted on comment #1 and i can confirm that the proposed package indeed change the server to the production on and the synchronization still works fine, marking this as verification-done, thanks all.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tomboy - 1.4.2-0ubuntu2

---------------
tomboy (1.4.2-0ubuntu2) maverick-proposed; urgency=low

  * debian/patches/06_use_ubuntu_sso.patch
    - Use the Ubuntu One production services instead of edge
      servers (LP: #745721)
 -- Ken VanDine <email address hidden> Wed, 30 Mar 2011 10:28:48 -0400

Changed in tomboy (Ubuntu Maverick):
status: Fix Committed → Fix Released

I am still seeing my Natty Tomboy notes sync going to edge.

[DEBUG 10:16:53.283] Sync: GetNoteUpdatesSince rev 171
[DEBUG 10:16:53.285] Building web request for URL: https://edge.one.ubuntu.com/notes/api/1.0/op/?include_notes=true&since=171
[DEBUG 10:16:54.327] Sync: 0 updates since rev 171
[DEBUG 10:16:54.329] Building web request for URL: https://edge.one.ubuntu.com/notes/api/1.0/op/
[DEBUG 10:16:55.300] Sync: Uploading 0 note updates
[DEBUG 10:16:55.300] Building web request for URL: https://edge.one.ubuntu.com/notes/api/1.0/op/
[DEBUG 10:16:56.875] Sync: New revision: 171

alan@wopr:~$ gconftool -g /apps/tomboy/sync/ubuntuone/server
https://edge.one.ubuntu.com/notes/

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers