Syncing notes crashes TomBoy

Bug #713495 reported by Jono Bacon on 2011-02-05
44
This bug affects 9 people
Affects Status Importance Assigned to Milestone
tomboy (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: tomboy

I just installed Natty and selected Ubuntu One in the synchronization options. When I then start the sync it updates a few notes and crashes. If I then restart TomBoy and do the same, it syncs another few notes and crashes.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: tomboy 1.5.2-1ubuntu4
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Uname: Linux 2.6.38-1-generic i686
Architecture: i386
Date: Fri Feb 4 20:56:52 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202)
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
SourcePackage: tomboy

Jono Bacon (jonobacon) wrote :
Adam Hathaway (ahathaway21) wrote :

Not sure if this is helpful or not but here is the output of the crash:

[INFO 01:02:47.092] Initializing Mono.Addins
Stacktrace:

  at (wrapper managed-to-native) LibProxy.ProxyFactory.px_proxy_factory_free (System.Runtime.InteropServices.HandleRef) <0x00004>
  at (wrapper managed-to-native) LibProxy.ProxyFactory.px_proxy_factory_free (System.Runtime.InteropServices.HandleRef) <0x00004>
  at LibProxy.ProxyFactory.Finalize () <0x00030>
  at (wrapper runtime-invoke) object.runtime_invoke_virtual_void__this__ (object,intptr,intptr,intptr) <0x00046>

Native stacktrace:

 mono() [0x80dbc6b]
 mono() [0x811370b]
 [0x81540c]
 /usr/lib/libproxy/0.3.1/modules/pacrunner_webkit.so(+0xbb1) [0x42b0bb1]
 /usr/lib/libproxy/0.3.1/modules/pacrunner_webkit.so(+0xbf2) [0x42b0bf2]
 /usr/lib/libproxy.so.0(+0x2741) [0x45db741]
 /usr/lib/libproxy.so.0(px_array_free+0x42) [0x45dab72]
 /usr/lib/libproxy.so.0(+0x4168) [0x45dd168]
 /usr/lib/libproxy.so.0(px_array_free+0x42) [0x45dab72]
 /usr/lib/libproxy.so.0(px_strdict_free+0x29) [0x45dd449]
 /usr/lib/libproxy.so.0(px_module_manager_free+0x30) [0x45db900]
 /usr/lib/libproxy.so.0(px_proxy_factory_free+0x31) [0x45dcf41]
 [0x5812fe4]
 [0x5812f61]
 [0x532c57]
 mono() [0x8117f41]
 mono() [0x820dd20]
 mono() [0x8118184]
 mono() [0x81b7e84]
 mono() [0x81ec43a]
 mono() [0x8216c72]
 /lib/libpthread.so.0(+0x5e99) [0xbcbe99]
 /lib/libc.so.6(clone+0x5e) [0x1e05ce]

Debug info from gdb:

Could not attach to process. If your uid matches the uid of the target
process, check the setting of /proc/sys/kernel/yama/ptrace_scope, or try
again as the root user. For more details, see /etc/sysctl.d/10-ptrace.conf
ptrace: Operation not permitted.

=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================

Aborted (core dumped)

Changed in tomboy (Ubuntu):
status: New → Confirmed
Redsandro (redsandro) wrote :

This bug affects me too, while syncing to Ubuntu One. I have about 40 notes.
Tomboy 1.6.0 (1.6.0-0ubuntu3-1mint1) on Linux 2.6.38-8-generic #42-Ubuntu 11.04 SMP Mon Apr 11 03:31:24 UTC 2011 x86_64

I removed all notes locally, tried to sync again a bunch of times, and Tomboy crashed every single time.

WARNING: DO NOT REMOVE YOUR NOTES AND SYNC AGAIN.
I thought removing ~/.local/share/tomboy would fix the problem and get me a fresh batch of notes from the server. Instead it removed everything from the server.

I tried everything with ~/.config/tomboy/manifest.xml revision numbers while putting notes from ~/.local/share/tomboy/Backup back, but the server would remove them everytime.
Turns out all you have to do is put the backup notes back, no need to hack the manifest.xml. They sync right back. Phew!

No more crash since I fiddled around.

@Jono, @ahaythaway:

Next time start tomboy from the terminal with a
tomboy --debug > tomboy-debug.txt
do a sync, make it crash, and upload the tomboy-debug.txt
The devs will surely want that.

Redsandro (redsandro) wrote :

I just reinstalled Windows (unrelated reasons), and installed Gtk-Sharp. Then I launched Tomboy, which was still in Program Files on the other drive. Settings were ofcourse gone. So I chose one.ubuntu.com, synced, and now I have all my notes and the Search Notes dialog works.

I know it's only a matter of time before it breaks, but interesting to know that it's probably not the amount or size of notes that causes this. It even has my notebooks back, so those aren't the cause either. Strange.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers