tomboy sync with ubuntuone fails without any detail information

Bug #711192 reported by Oehm on 2011-02-01
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
tomboy (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: tomboy

trying to manually sync tomboy notes (with ubuntuone) i get an error message saying that the sync failed and asking me to check the 'details below' and try again. there are no details given below (just an empty list of notes).

the sync seemed to fail during the first step "acquiring a sync lock" (my translation from german).

i would expect a failure message saying something like: "there is an error on the server-side" or "check your login credentials".

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: tomboy 1.4.2-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-25.44-generic 2.6.35.10
Uname: Linux 2.6.35-25-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Tue Feb 1 12:17:47 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcEnviron:
 LANG=de_DE.utf8
 SHELL=/bin/bash
SourcePackage: tomboy

Oehm (oehmannemuere) wrote :
Andres Muniz (andresmp) wrote :

Same here with 11.04.

Andres Muniz (andresmp) wrote :

funny enough ran tomboy on terminal and then did the sync with no problem. I restarted through the unity gui and it now syncs no problem. Wierd.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in tomboy (Ubuntu):
status: New → Confirmed
CristianCantoro (kikkocristian) wrote :

I got the same error on Ubuntu 11.10 with Tomboy version 1.8.0, a dialog said that note sync failed but the "details" box was empty. Quitting tomboy and starting it from command line, after trying to sync notes I saw:

[ERROR 15:10:43.880] Synchronization failed with the following exception: A note with this title already exists: Oggi: mercoledì 22 agosto 2012
  at Tomboy.NoteManager.CreateNewNote (System.String title, System.String xml_content, System.String guid) [0x00000] in <filename unknown>:0
  at Tomboy.NoteManager.CreateNoteFromTemplate (System.String title, Tomboy.Note template_note, System.String guid) [0x00000] in <filename unknown>:0
  at Tomboy.NoteManager.CreateNewNote (System.String title, System.String guid) [0x00000] in <filename unknown>:0
  at Tomboy.NoteManager.CreateWithGuid (System.String title, System.String guid) [0x00000] in <filename unknown>:0
  at Tomboy.Sync.SyncManager+<CreateNoteInMainThread>c__AnonStorey11.<>m__3F () [0x00000] in <filename unknown>:0
  at Tomboy.GuiUtils+<GtkInvokeAndWait>c__AnonStoreyC.<>m__2F (System.Object , System.EventArgs ) [0x00000] in <filename unknown>:0

(Tomboy:11544): GLib-CRITICAL **: g_source_remove: assertion `tag > 0' failed

So deleting the named note (after copying its content somewhere else) solved the problem, but this messag should be in the dialog box.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers