Ubuntu

tomboy notes disappeared

Reported by Andy Hird on 2010-05-14
114
This bug affects 23 people
Affects Status Importance Assigned to Milestone
Ubuntu One Infrastructure
Undecided
Unassigned
tomboy
Fix Released
Critical
tomboy (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: tomboy

andyh@dylan:~$ lsb_release -rd
Description: Ubuntu 10.04 LTS
Release: 10.04

andyh@dylan:~$ aptitude show tomboy
Package: tomboy
State: installed
Automatically installed: no
Version: 1.2.1-0ubuntu1

Hi. I recently upgraded to Lucid beta on my laptop from karmic. Things seemed ok. Today I noticed that all but two (which may be new) of my tomboy notes have disappeared. There's still a stack in .tomboy but only two in .local/share/tomboy. This makes me very sad :-(

I suspect that tomboy may not be the culprit, and the culprit may be ubuntu-one which I've struggled to get going (without much success).

I doubt there's anything you can do to help me (unless there's a super secret place where tomboy notes are copied to) but I felt I should file an issue just incase there's something you can do for others.

Possibly related after upgrade/ubuntu one usage all of my podcasts disappeared from rhythmbox and I had to resubscribe. No idea if the two things are related.

I've been using Ubuntu since warty days and this is the first time an upgrade has resulted in data loss!

Thanks Andy Hird

Dr. Kenobi (drkenobi) wrote :

Why are you using Lucid Beta?

Tomboy notes are now stored in ~/.local/share/tomboy, and have been since Tomboy 1.0 (which was shipped in Karmic).

If you still have notes in ~/.tomboy, they are from Tomboy 0.14.x (Jaunty).

I'm not aware of any Tomboy dataloss bugs that would cause you to lose notes like this. On the off-chance that you accidentally deleted them using Tomboy's UI, you might want to check in ~/.local/share/tomboy/Backup.

Andy Hird (andy-hird) wrote :

I don't have a ~/.local/share/tomboy/Backup (and generally don't delete notes which is probably why). I knew the notes had moved - just wanted to point out I had lots more notes in the old directory.

Why am I using Lucid Beta? Good question :-) I generally upgrade relatively early just to see whats new in a release. I'm much more conservative nowadays and don't run pre-beta builds. I keep up to date with updates using aptitude pretty regularly (every couple of days) as well.

Andy

Owen Williams (ywwg) wrote :

I don't know if this is the same bug, but I just lost my primary, most-used tomboy note ("General Todo"). This note was so old, the filename was New_Note_1.note (instead of an MD5 whatever). The file is still there, but it's 0 bytes.

I restored a version of that note from backup, but I'm pissed because I update it all the time and I've never lost anything in tomboy before. I definitely did not accidentally delete the note. This is with Lucid (non-beta).

Owen, that sounds like a file system error. I've heard periodic reports of 0 byte notes after loss of power or other crashes where apparently ext4 partitions can be victim to broken writes.

I'd recommend regularly backing up ~/.local/share/tomboy/ until we think of a way to work around this, if we can.

Mike Pelley (mikepelley) wrote :

I just had several notes disappear from my list at work (gone after I returned from the weekend). I'm not sure exactly when they disappeared, but it would have been quite recently as I use one of them every day as my "ToDo" list. I estimate there are four notes missing, and I have four zero byte MD5 files in ~/.local/share/tomboy. I have files in Backup, but the missing ones are not there.

I'm running 64-bit Lucid - let me know if you need any additional information.

Mike Pelley (mikepelley) wrote :

One more note - it occurs to me that the notes that disappeared might have been the ones that were "pinned". I had about 12 notes altogether, and I think the missing 4 were pinned, but I can't be sure as I don't remember exactly.

On Tue, Sep 7, 2010 at 8:59 AM, Mike Pelley <email address hidden> wrote:
> I just had several notes disappear from my list at work (gone after I
> returned from the weekend).  I'm not sure exactly when they disappeared,
> but it would have been quite recently as I use one of them every day as
> my "ToDo" list.  I estimate there are four notes missing, and I have
> four zero byte MD5 files in ~/.local/share/tomboy.

If you have four zero byte .note files in your tomboy directory, then
it appears you have lost some notes due to file corruption. They will
not be recoverable.

Did your laptop lose power or shut down uncleanly while Tomboy was
running, perhaps?

> I have files in
> Backup, but the missing ones are not there.

Backup only contains notes you've explicitly deleted.

Sandy

Mike Pelley (mikepelley) wrote :

My work machine is a workstation class desktop and I leave it on all the time. It does get rebooted occasionally, usually for kernel updates and such, but I don't believe it has been power cycled "hard" for quite some time.

Mossroy (mossroy) wrote :

Sandy, Mike, Owen, I just experienced the same loss of tomboy notes as you described.
My filesystem is in ext4 format, I'm running Ubuntu 10.04 64bit with all current updates.
The notes disappeared just after a system crash (everything frozen).

Usually, if my system crashes or is shut down violently, the notes that where open on my desktop do not re-open automatically... but I can find them in the tomboy drop-down list.
This time, I could not find those notes any more in this list.
I looked at the content of ~/.local/share/tomboy : the note files are still there, but with a zero byte length.

I made a manual e2fsck on the system (from a liveCD) : it did report any error to me, and my /lost+found folder is empty.
I seems like I had 4 open notes (based on the number of zero-length note files I have)

That's really annoying to have a loss of data of this kind! I could find some external backups of 3 of these files, but I lost everything I did in between, of course.

Sandy, if there is a more specific bug on that issue (either on launchpad or elsewhere), maybe you could tell us where.

Let me know if I might help in any way.

Ales Novy (alesny) wrote :

I have the same problem. After a restart, one note disappeared and when I look at the ~/.local/share/tomboy, it has 0 byte length. The version of Tomboy I've used is 1.0.0.

babygenius55 (babygenius55a) wrote :

So what's the status of this ? Still not assigned huh?

babygenius55 (babygenius55a) wrote :

Since this is what came up when I typed my symptoms...my notes are still on the pc. I can read the pertinent content in a text editor. They simply do not show up in Tomboy. They are where they're supposed to be (~/.local/share/tomboy) . i can't open them with tomboy. I need help. Not from the command line will it open. Not from the 'open with...' will it open. this is a pain.

Babygenius, you seem to be describing a different bug than everybody else here.

If the files are readable in a text editor, than Tomboy should be able to read them just fine. Did you open the Search window and look in there? The Tomboy notes menu only shows the most recent notes.

If you still have trouble, please file a new bug.

Changed in tomboy (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Matt Lavin (matt-lavin) wrote :

I am also seeing the 0 length file problem after a computer crash. There hasn't been any update in this defect in a while, is anybody still looking into the cause? Is there some data I can provide to help debugging?

Eloquence (eloquence) wrote :

Hit the same bug, lost my general to-do list. Very frustrating.

deefactorial (deefactorial) wrote :

Bump, my computer had to hard boot and I lost my very important note. This is frustrating I would think that there would be some other way that the notes were stored, not just in memory. for example when I open a text document. sometimes it creates ~filename file that it edits while the file is open then when I save it it will over write the original. If the system crashes before I saved the file then ~filename still exists with the changes I made and the original is still there. This bug leaves me with nothing.

Atheg (hoganaj) wrote :

Help, me too! My to-do list is gone. This is a critical note. Sporadic and unpredictable data-loss renders tomboy useless as a note-taking application. There's no reference to an error, nothing---just lost critical data.

This has happened to me now 3 times. I've noticed it tends to be a note that is open when a session ends (usually my to do list). I can confirm that the shutdowns were clean.

Can someone address this? Please save us from org-mode!

Atheg (hoganaj) wrote :

Edit from above---I can confirm based on time-stamps that the deleted notes in question still have the same filename they had, but that the contents have been deleted (overwritten as 0 bytes).

SJ (meta-sj) wrote :

I had the same thing happen to me. Losing my latest notes to corruption on pwoer off or any other sudden shock is precisely what I was trying to avoid by using tomboy; until this bug is fixed I cannot continue to use it.

In this case I lost the lates note I had taken and could only try to reconstitute a long meeting's notes from memory.

SJ (meta-sj) wrote :

Update; I had two notes open on crash; cursor focus was in one, and that one disappeared from the notes list and ended up with 0 bytes in the share/tomboy folder, timestamped with the time of the crash. the second one disappeared at first from the notes title list, but I could find it by searching for words in it, after which it reappeared in the title list (and remained there through successive power cycles).

Changed in tomboy:
importance: Unknown → Critical
status: Unknown → New
ixtos (ixtos) wrote :

Same happened to me several times. My most important note is open most of the time. I lost it several times not only in crashes but also sometimes when shutting down the with it being open. I backup my notes now, but this is not satisfying. I rather have to push a "save" button and then really have the note saved than having an automatic "as-you-type" save that works unreliably.

Changed in tomboy:
status: New → In Progress
Anders Murphy (kneb2) wrote :

This problem has plagued me for months now, very frustrating when you most valuable notes end get set to 0 bytes! With all data lost! I'm amazed this problem has not been addressed yet, this is a serious problem for note taking software and defeats the whole point.

Anders Murphy (kneb2) wrote :

Still no news? I can't afford to lose entire notes every time my system doesn't shut down properly (some that are years old). Time to look for alternatives.

Redsandro (redsandro) wrote :

I have now something similar. When I sync my notes, al my 140 notes get removed.

So I delete ~/.config/tomboy/manifest.xml
I copy my note backups to ~/.local/share/tomboy
I sync, and all 140 notes are uploaded to server (Ubuntu One).
I sync a 2nd time, and all notes are removed locally again.

I followed this guide to purge the server: https://one.ubuntu.com/help/faq/how-can-i-delete-all-my-tomboy-notes-from-the-server/
But I still have the same behavior. Every computer I power on gets all my notes removed. I restore backup to ~/.local/share/tomboy, all notes uploaded again and removed again on 2nd sync.

The part about purging your couchdb locally doesn't work as the linked script is not available anymore. Is that still relevant, or for older tomboy versions?

Redsandro (redsandro) wrote :

Also I tried increasing the <last-sync-date/>, <last-sync-rev/> and latest-revision values, but still same behavior.
Is there a trick to nuke every trace of tomboy life and start over with my backup, without them getting removed?

Tim Abell (tim-abell) wrote :

Tomboy 1.10.1, Ubuntu 12.04 LTS, auto sync set up to Ubuntu One. Today all my notes disappeared having had no problems with the sync for about a year. I am a rather unhappy bunny right now. :'-(

~/.local/share/tomboy/ is empty except for Backup/ which has lots of notes in it.

This is a horrific bug.

Tim Abell (tim-abell) wrote :

I restored my notes folder from backup (thankyou simple backup!), and attempted to re-sync, got an error, killed tomboy and ran from terminal, got the following output after manually kicking off a sync. Perhaps it is related:

tim@atom:~$ tomboy
[INFO 21:16:16.365] Initializing Mono.Addins
[ERROR 21:16:28.442] Caught exception. Message: The remote server returned an error: (503) Service Temporarily Unavailable.
[ERROR 21:16:28.447] Stack trace for previous exception: at System.Net.HttpWebRequest.CheckFinalStatus (System.Net.WebAsyncResult result) [0x00000] in <filename unknown>:0
  at System.Net.HttpWebRequest.SetResponseData (System.Net.WebConnectionData data) [0x00000] in <filename unknown>:0
[ERROR 21:16:28.450] Rest of stack trace for above exception: at System.Environment.get_StackTrace()
   at Tomboy.WebSync.Api.OAuth.MakeWebRequest(RequestMethod method, System.String url, System.Collections.Generic.List`1 parameters, System.String postData)
   at Tomboy.WebSync.Api.OAuth.WebRequest(RequestMethod method, System.String url, System.String postData)
   at Tomboy.WebSync.Api.OAuth.Get(System.String uri, IDictionary`2 queryParameters)
   at Tomboy.WebSync.Api.RootInfo.GetRoot(System.String rootUri, IWebConnection connection)
   at Tomboy.WebSync.WebSyncServer.BeginSyncTransaction()
   at Tomboy.Sync.SyncManager.SynchronizationThread()
   at System.Threading.Thread.StartInternal()
[ERROR 21:16:28.451] Synchronization failed with the following exception: The remote server returned an error: (503) Service Temporarily Unavailable.
  at System.Net.HttpWebRequest.CheckFinalStatus (System.Net.WebAsyncResult result) [0x00000] in <filename unknown>:0
  at System.Net.HttpWebRequest.SetResponseData (System.Net.WebConnectionData data) [0x00000] in <filename unknown>:0

(Tomboy:4272): GLib-CRITICAL **: g_source_remove: assertion `tag > 0' failed

Looks like the ubuntu one server has gone walkies. I'm guessing either that triggers this horrific bug, or something the server did before it went down completely triggered the bug. Either way, this is still a really nasty data loss bug. Such a shame, because generally I <3 tomboy. I seem to be having a bad time with OSS recently.

Joshua Hoover (joshuahoover) wrote :

This is a server side issue and we're working on the fix right now. For information on restoring notes in Tomboy, please see: https://one.ubuntu.com/help/faq/how-can-i-recover-my-deleted-tomboy-notes/

Tim Abell (tim-abell) wrote :

Thanks for the info, can you give any more details (to restore my faith in the sync system)?

Tim Abell (tim-abell) wrote :

Excellent my other machine has just REVERTED ALL MY NOTES TO AN OLD VERSION. What is going on here?! Really unimpressed with the silence from canonical here. Grumble.

This might be related to this bug. I disabled ubuntu one tomboy sync months ago so it wasn't (or should not have been) syncing. But when I upgraded from 12.04.1 to 12.04.2, all my notes where gone from ~/.local/share/tomboy. (maybe an update or something else re-established the ubuntu one syncing of tomboy notes?)

To top it off: I had cleaned years of notes, deleting lots, classifying others.. now the Backup seems to contain both notes from before and after.

I don't know if server side was my issue too but seriously, server side issues should never be able to wipe all my locally created stuff. never.

Julien Funk (jaboing) on 2013-04-04
tags: added: u1-notrack
Changed in tomboy:
status: In Progress → Fix Released
Dave Morley (davmor2) wrote :

Ubuntu one no longer supports tomboy notes so I have removed u1 from this.

Changed in ubuntuone-infrastructure:
status: New → Invalid
Changed in tomboy (Ubuntu):
status: Confirmed → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.