Tomboy fails to synchronize its notes with ubuntu one

Bug #534488 reported by Erik Andrén on 2010-03-08
66
This bug affects 14 people
Affects Status Importance Assigned to Milestone
tomboy (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: tomboy

Tomboy fails to synchronize with ubuntu one on one of my karmic machines with the following error:

[ERROR]: Synchronization failed with the following exception: a name did not start with a legal character 10 (
) Line 9, position 30.
  at Mono.Xml2.XmlTextReader.ReadName (System.String& prefix, System.String& localName) [0x00000]
  at Mono.Xml2.XmlTextReader.ReadName () [0x00000]
  at Mono.Xml2.XmlTextReader.ReadEntityReference (Boolean ignoreEntityReferences) [0x00000]
  at Mono.Xml2.XmlTextReader.ReadReference (Boolean ignoreEntityReferences) [0x00000]
  at Mono.Xml2.XmlTextReader.ReadText (Boolean notWhitespace) [0x00000]
  at Mono.Xml2.XmlTextReader.ReadContent () [0x00000]
  at Mono.Xml2.XmlTextReader.Read () [0x00000]
  at System.Xml.XmlTextReader.Read () [0x00000]
  at Tomboy.Sync.NoteUpdate..ctor (System.String xmlContent, System.String title, System.String uuid, Int32 latestRevision) [0x00000]
  at Tomboy.WebSync.WebSyncServer.GetNoteUpdatesSince (Int32 revision) [0x00000]
  at Tomboy.Sync.SyncManager.SynchronizationThread () [0x00000]

(/usr/lib/tomboy/Tomboy.exe:14029): GLib-CRITICAL **: g_source_remove: assertion `tag > 0' failed
Created new window in existing browser session.

I've got two other machines synching to the same account using karmic which works properly.

ProblemType: Bug
Architecture: i386
Date: Mon Mar 8 17:11:18 2010
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/yelp
InstallationMedia: Ubuntu-Netbook-Remix 9.10 "Karmic Koala" - Release i386 (20091028.4)
Package: yelp 2.28.0-0ubuntu2
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SourcePackage: yelp
Uname: Linux 2.6.33-rc8-tip i686

Erik Andrén (erik-andren) wrote :
tags: added: karmic
Erik Andrén (erik-andren) wrote :

I now receive the following error message when syncing:

[ERROR]: Synchronization failed with the following exception: A note with this title already exists: Anteckningsmall för Xelerated (old)
  at Tomboy.NoteManager.CreateNewNote (System.String title, System.String xml_content, System.String guid) [0x00000]
  at Tomboy.NoteManager.CreateNewNote (System.String title, System.String guid) [0x00000]
  at Tomboy.NoteManager.CreateWithGuid (System.String title, System.String guid) [0x00000]
  at Tomboy.Sync.SyncManager+<CreateNoteInMainThread>c__AnonStorey7.<>m__A (System.Object , System.EventArgs ) [0x00000]

The note neither exists locally or on ubuntu one

Bruno Bigras (brunoqc) wrote :

I know it's an old bug but if someone find this like I did because I had the "A note with this title already exists", you may try to delete (make a copy first) the manifest.xml file in ~/.config/tomboy. It worked for me.

Changed in tomboy (Ubuntu):
status: New → Confirmed
Matt Deaton (matt-d10online) wrote :

This is affects me as well on a fresh Oneiric Beta install. I have reinstalled Tomboy, and also tried as suggested to delete the manifest.xml file. My 3 other machines on 10.04 and 11.04 sync fine just the one on the 11.10 beta won't.

9/8/2011 8:01:42 AM [DEBUG]: Sync: 29 updates since rev -1
9/8/2011 8:01:42 AM [DEBUG]: SyncManager: Deleting auto-generated note: New Note Template
9/8/2011 8:01:42 AM [DEBUG]: Removing tag from New Note Template: system:template
9/8/2011 8:01:42 AM [DEBUG]: Watchers.OnTagRemoved popularity count: 0
9/8/2011 8:01:42 AM [DEBUG]: Deleting note 'New Note Template'.
9/8/2011 8:01:42 AM [DEBUG]: Creating Buffer for 'New Note Template'...
9/8/2011 8:01:42 AM [DEBUG]: Tag added to New Note Template: system:template
9/8/2011 8:01:42 AM [DEBUG]: Loading notebooks
9/8/2011 8:01:42 AM [ERROR]: Synchronization failed with the following exception: A note with this title already exists: New Note Template
  at Tomboy.NoteManager.CreateNewNote (System.String title, System.String xml_content, System.String guid) [0x00000] in <filename unknown>:0
  at Tomboy.NoteManager.CreateNoteFromTemplate (System.String title, Tomboy.Note template_note, System.String guid) [0x00000] in <filename unknown>:0
  at Tomboy.NoteManager.CreateNewNote (System.String title, System.String guid) [0x00000] in <filename unknown>:0
  at Tomboy.NoteManager.CreateWithGuid (System.String title, System.String guid) [0x00000] in <filename unknown>:0
  at Tomboy.Sync.SyncManager+<CreateNoteInMainThread>c__AnonStorey11.<>m__3F () [0x00000] in <filename unknown>:0
  at Tomboy.GuiUtils+<GtkInvokeAndWait>c__AnonStoreyC.<>m__2F (System.Object , System.EventArgs ) [0x00000] in <filename unknown>:0
9/8/2011 8:01:46 AM [DEBUG]: Saving 'New Note Template'...

Colin Law (colin-law) wrote :

I am seeing this also, complaining about New Note Template as Matt Deaton describes. I am also running Oneiric Beta. In my case I am attempting to sync with a local folder which is synced by Dropbox with a folder on a machine running Ubuntu 11.04
I am not sure that this is the same bug originally posted, perhaps we should start a new bug report.

Colin Law (colin-law) wrote :

Matt: I have opened a new bug #848250 specifically for the New Note Template issue on Oneiric. Could you add your comments to that (if you think appropriate).

alex (aarw2) wrote :

11.10 I can not get Tomboy to connect the ubuntu One server without crashing. Therefore it does not synch. Might be a different bug, not sure, but certainly in 11.10 something horrid has happened to synching, the ubuntu One option has been removed, if I try to use the Ubuntu One option in the Tomboy web drop down I can not get it to synch at all, no errors just a crash.

I have a solution for those who get this error: "Synchronization failed with the following exception: A note with this title already exists: New Note Template"

Apparently, there is already a note with the name "New Note Template" but I don't see it in Tomboy for some reason. However, it does exists. I took the following action:

- Browse to the folder /home/username/.local/share/tomboy
- Open each file in there with a text editor (I used Gedit) one by one until you find one containing: "<title>New Note Template</title>"
- Change the content of <title> tag and save it. (For example "<title>New Note Template1234</title>"
- Synchronize your tomboy notes

That's it! Hopefully that will work for you.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers