tomboy crashes on ARM hardware if notification icon is clicked

Bug #391124 reported by Oliver Grawert on 2009-06-23
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tomboy
Fix Released
Undecided
Unassigned
tomboy (Ubuntu)
High
Oliver Grawert
Karmic
High
Oliver Grawert

Bug Description

Binary package hint: tomboy

starting tomboy freshly on an ARM board gets me working application windows, lets me search, create and link notes, but as soon as i click the notification icon the app crashes:

ogra@babbage2:~$ tomboy
[DEBUG]: NoteManager created with note path "/home/ogra/.tomboy".
[INFO]: Initializing Mono.Addins

Unhandled Exception: System.InvalidOperationException: Could not read add-in description
  at Mono.Addins.Addin.get_Description () [0x00000]
  at Mono.Addins.AddinSessionService.CheckHostAssembly (System.Reflection.Assembly asm) [0x00000]
  at Mono.Addins.AddinSessionService.ActivateRoots () [0x00000]
  at Mono.Addins.AddinSessionService.Initialize () [0x00000]
  at Mono.Addins.AddinManager.Initialize (System.String configDir) [0x00000]
  at Tomboy.AddinManager.InitializeMonoAddins () [0x00000]
  at Tomboy.AddinManager..ctor (System.String tomboy_conf_dir) [0x00000]
  at Tomboy.NoteManager.CreateAddinManager () [0x00000]
  at Tomboy.NoteManager..ctor (System.String directory, System.String backup_directory) [0x00000]
  at Tomboy.NoteManager..ctor (System.String directory) [0x00000]
  at Tomboy.Tomboy.Main (System.String[] args) [0x00000]
ogra@babbage2:~$ tomboy
[DEBUG]: NoteManager created with note path "/home/ogra/.tomboy".
[INFO]: Initializing Mono.Addins
[DEBUG]: AddinManager.OnAddinLoaded: Tomboy.Tomboy
[DEBUG]: Name: Tomboy.Tomboy,0.10
[DEBUG]: Description:
[DEBUG]: Namespace: Tomboy
[DEBUG]: Enabled: True
[DEBUG]: File: /usr/lib/tomboy/Tomboy.exe
[DEBUG]: AddinManager.OnAddinLoaded: Tomboy.ExportToHtmlAddin
[DEBUG]: Name: Export to HTML
[DEBUG]: Description: Exports individual notes to HTML.
[DEBUG]: Namespace: Tomboy
[DEBUG]: Enabled: True
[DEBUG]: File: /usr/lib/tomboy/addins/ExportToHtml.dll
[DEBUG]: AddinManager.OnAddinLoaded: Tomboy.PrintNotesAddin
[DEBUG]: Name: Printing Support
[DEBUG]: Description: Allows you to print a note.
[DEBUG]: Namespace: Tomboy
[DEBUG]: Enabled: True
[DEBUG]: File: /usr/lib/tomboy/addins/PrintNotes.dll
[DEBUG]: AddinManager.OnAddinLoaded: Tomboy.BacklinksAddin
[DEBUG]: Name: Backlinks
[DEBUG]: Description: See which notes link to the one you're currently viewing.
[DEBUG]: Namespace: Tomboy
[DEBUG]: Enabled: True
[DEBUG]: File: /usr/lib/tomboy/addins/Backlinks.dll
[DEBUG]: AddinManager.OnAddinLoaded: Tomboy.EvolutionAddin
[DEBUG]: Name: Evolution Mail Integration
[DEBUG]: Description: Allows you to drag an email from Evolution into a tomboy note. The message subject is added as a link in the note.
[DEBUG]: Namespace: Tomboy
[DEBUG]: Enabled: True
[DEBUG]: File: /usr/lib/tomboy/addins/Evolution.dll
[DEBUG]: AddinManager.OnAddinLoaded: Tomboy.FixedWidthAddin
[DEBUG]: Name: Fixed Width
[DEBUG]: Description: Adds fixed-width font style.
[DEBUG]: Namespace: Tomboy
[DEBUG]: Enabled: True
[DEBUG]: File: /usr/lib/tomboy/addins/FixedWidth.dll
[DEBUG]: AddinManager.OnAddinLoaded: Tomboy.StickyNoteImportAddin
[DEBUG]: Name: Sticky Notes Importer
[DEBUG]: Description: Import your notes from the Sticky Notes applet.
[DEBUG]: Namespace: Tomboy
[DEBUG]: Enabled: True
[DEBUG]: File: /usr/lib/tomboy/addins/StickyNoteImport.dll
[DEBUG]: StickyNoteImporter: Sticky Notes XML file does not exist or is invalid!
[DEBUG]: Creating Buffer for 'Start Here'...
[DEBUG]: Matching Note title 'Using Links in Tomboy' at 386-407...
[DEBUG]: Matching Note title 'Using Links in Tomboy' at 439-460...
[DEBUG]: Start Here tags:
[DEBUG]: AddinManager.OnAddinLoaded: Tomboy.WebDavSyncServiceAddin
[DEBUG]: Name: WebDav Sync Service Add-in
[DEBUG]: Description: Synchronize Tomboy Notes to a WebDav URL
[DEBUG]: Namespace: Tomboy
[DEBUG]: Enabled: True
[DEBUG]: File: /usr/lib/tomboy/addins/WebDavSyncService.dll
[DEBUG]: AddinManager.OnAddinLoaded: Tomboy.FileSystemSyncServiceAddin
[DEBUG]: Name: Local Directory Sync Service Add-in
[DEBUG]: Description: Synchronize Tomboy Notes to a local file system path
[DEBUG]: Namespace: Tomboy
[DEBUG]: Enabled: True
[DEBUG]: File: /usr/lib/tomboy/addins/FileSystemSyncService.dll
[DEBUG]: Unable to locate 'gnomesu' in your PATH
[DEBUG]: Using '/usr/bin/gksu' as GUI 'su' tool
[DEBUG]: Successfully found all system tools
[DEBUG]: Unable to locate 'wdfs' in your PATH
[DEBUG]: Tomboy remote control disabled (DBus exception): Unable to open the session message bus.
[DEBUG]: EnableDisable Called: enabling... True
[DEBUG]: Binding key '<Alt>F12' for '/apps/tomboy/global_keybindings/show_note_menu'
[DEBUG]: Binding key '<Alt>F11' for '/apps/tomboy/global_keybindings/open_start_here'
[DEBUG]: Saving 'Start Here'...
[DEBUG]: Saving 'Using Links in Tomboy'...
[DEBUG]: Saving 'Start Here'...
Exception in Gtk# callback delegate
  Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
System.NullReferenceException: Object reference not set to an instance of an object
at (wrapper native-to-managed) GtkSharp.MenuPositionFuncWrapper.NativeCallback (intptr,int&,int&,byte,intptr) <0x00060>
at Gtk.Menu.Popup (Gtk.Widget,Gtk.Widget,Gtk.MenuPositionFunc,uint,uint) <0x000d0>
at Tomboy.GuiUtils.PopupMenu (Gtk.Menu,Gdk.EventButton,Gtk.MenuPositionFunc) <0x000f3>
at Tomboy.TomboyTrayIcon.OnPopupMenu (uint,uint) <0x0008f>
at Gtk.StatusIcon.popupmenu_cb (intptr,uint,uint) <0x00087>

   at GLib.ExceptionManager.RaiseUnhandledException(System.Exception e, Boolean is_terminal)
   at Gtk.StatusIcon.popupmenu_cb(IntPtr status_icon, UInt32 button, UInt32 activate_time)
   at Gtk.Application.gtk_main()
   at Gtk.Application.Run()
   at Gnome.Program.Run()
   at Tomboy.GnomeApplication.StartMainLoop()
   at Tomboy.Application.StartMainLoop()
   at Tomboy.Tomboy.StartTrayIcon()
   at Tomboy.Tomboy.Main(System.String[] args)
ogra@babbage2:~$

Related branches

Sebastien Bacher (seb128) wrote :

to be debugged by somebody having access to an arm config

Changed in tomboy (Ubuntu):
importance: Undecided → Low
Paul Larson (pwlars) on 2009-08-21
tags: added: armel
Paul Larson (pwlars) on 2009-08-24
Changed in tomboy (Ubuntu):
status: New → Confirmed
Oliver Grawert (ogra) on 2009-08-24
Changed in tomboy (Ubuntu):
importance: Low → High
assignee: nobody → Oliver Grawert (ogra)
milestone: none → karmic-alpha-5
status: Confirmed → New
Changed in tomboy (Ubuntu Karmic):
status: New → Confirmed

What version of Tomboy is this?

Can you get output with `tomboy --debug` please? Thanks!

Oliver Grawert (ogra) wrote :
Oliver Grawert (ogra) wrote :

probably some packaging info might help too ...

ogra@babbage2:~$ dpkg -l tomboy|grep ii
ii tomboy 0.15.6-0ubuntu1

So basically any time we pop up a menu, you're crashing. This sucks. I wish I had hardware I could test on.

Are you willing to build from source if I post patches for you to try?

Loïc Minier (lool) wrote :

Absolutely, thanks for the offer!

Oliver Grawert (ogra) wrote :

just on a sidenote i'd like to mention that f-spot works just fine on the same system, probably that helps to identify the offending code

On Thu, Aug 27, 2009 at 11:19 AM, Oliver Grawert<email address hidden> wrote:
> just on a sidenote i'd like to mention that f-spot works just fine on
> the same system, probably that helps to identify the offending code

When you say F-Spot works just fine, I assume you mean popup menus
work just fine? Right-click on a photo or something to test.

I'm going out of town for a bit, but I'll try to get to this next
weekend, before the next unstable release.

Oliver Grawert (ogra) wrote :

just checked, all context menus and popups work just fine in f-spot, i havent found a sigle function there that wouldnt work or make it crash...

testing tomboy again, i found that clicking the "notebook" button makes it crash too ...

Oliver Grawert (ogra) wrote :

should we file that upstream ?

Oliver Grawert (ogra) wrote :

bumping to alpha6 milestone

Changed in tomboy (Ubuntu Karmic):
milestone: karmic-alpha-5 → karmic-alpha-6
Changed in tomboy:
status: Unknown → New

The Notebook (and Tools) buttons in the note window pop up menus, too, so it's probably the same bug. Thanks for filing upstream, looking into it.

There's a debian bug from a PPC user, too:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=544022

Please see this bug for a patch (I marked the bug you filed as a dupe once I realized they were the same):

http://bugzilla.gnome.org/show_bug.cgi?id=586605

I would appreciate immediate testing of this patch, as I'm putting together a release tomorrow. If you can't get to it, there is still one more release to go this cycle. ;-)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tomboy - 0.15.6-0ubuntu3

---------------
tomboy (0.15.6-0ubuntu3) karmic; urgency=low

  * debian/patches/04_armel_crasher_fix.patch: new upstream patch to fix popup
    menu crashes on armel and ppc (LP: #391124)
    Thanks to Sandy Armstrong <email address hidden> for the fix

 -- Oliver Grawert <email address hidden> Mon, 07 Sep 2009 09:42:16 +0200

Changed in tomboy (Ubuntu Karmic):
status: Confirmed → Fix Released
Oliver Grawert (ogra) wrote :

works perfectly, thanks so much !
i added it as a patch to our package until you got it in upstream ...

Thanks so much for the quick feedback Oliver. Pushed upstream, release will be in ~12 hours.

tags: added: iso-testing
Paul Larson (pwlars) wrote :

upstream bug is https://bugzilla.gnome.org/show_bug.cgi?id=593422 - which is duped to a bug that is fixed. For some reason, LP doesn't seem to see that. Closing.

Changed in tomboy:
status: New → Unknown
importance: Unknown → Undecided
status: Unknown → New
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.