tmux session in weird semi-zombie state

Bug #1578431 reported by Thiago Martins on 2016-05-04
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
tmux (Ubuntu)
High
Unassigned
Xenial
High
Unassigned

Bug Description

Guys,

 The tmux version shipped on Ubuntu, freezes from time to time.

 Problem reported here:

 https://github.com/tmux/tmux/issues/298

Thanks,
Thiago

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: tmux 2.1-3build1
ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
Uname: Linux 4.4.0-21-generic x86_64
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity
Date: Wed May 4 20:07:53 2016
EcryptfsInUse: Yes
InstallationDate: Installed on 2016-01-30 (95 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160130)
SourcePackage: tmux
UpgradeStatus: No upgrade log present (probably fresh install)

Thiago Martins (martinx) wrote :
Ivan Kozik (ludios) wrote :

I am seeing my tmuxes hang very frequently on Ubuntu 16.04, especially after disconnecting my SSH sessions without first detaching from the tmux. I am currently working around this by using tmux-next from ppa:pi-rho/dev, but it seems to lack an armv7l build for my ARM servers. I might have to downgrade to the tmux in Ubuntu 14.04, or build tmux myself.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in tmux (Ubuntu):
status: New → Confirmed
Thiago Martins (martinx) wrote :

I think that there are more problems...

It is not possible to use "mc" (Midnight Commander) under tmux, the refresh is buggy.

Changed in tmux (Ubuntu):
importance: Undecided → High
ChristianEhrhardt (paelzer) wrote :

According to the comment "I have removed the backoff timer so this should be resolved in master." in https://github.com/tmux/tmux/issues/298 this should be fixed in 2.3, so zesty is fine.

Changed in tmux (Ubuntu):
status: Confirmed → Fix Released
Changed in tmux (Ubuntu Xenial):
status: New → Confirmed
importance: Undecided → Medium
importance: Medium → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.