New windows don't open in the current working directory

Bug #1350813 reported by Michał Sawicz on 2014-07-31
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Tmux
New
Undecided
Unassigned
byobu (Ubuntu)
Medium
Unassigned
tmux (Ubuntu)
Medium
Unassigned

Bug Description

When opening a new window under tmux 1.9, it starts in the wd in which tmux was started, not in the one from the currently focused window.

This is a regression from 1.8.

Michał Sawicz (saviq) wrote :

I'll file an upstream bug after lunch, can't target to distro versions though (or assign you, Dustin).

Michał Sawicz (saviq) wrote :

Can't link the bug, but here it is: https://sourceforge.net/p/tmux/tickets/145/

Robie Basak (racb) on 2014-08-04
Changed in byobu (Ubuntu):
importance: Undecided → Medium
Changed in tmux (Ubuntu):
importance: Undecided → Medium
Michał Sawicz (saviq) wrote :

Excerpt from CHANGES file (https://sourceforge.net/p/tmux/tmux-code/ci/1.9/tree/CHANGES):

* 'default-path' has been removed. The new-window command accepts '-c' to
  cater for this. The previous value of "." can be replaced with: 'neww -c
  $PWD', the previous value of '' which meant current path of the pane can
  be specified as: 'neww -c "#{pane_current_path}"'

Changed in byobu (Ubuntu):
status: New → Triaged
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in tmux (Ubuntu):
status: New → Confirmed
Mathieu Delarue (mathipu) wrote :

My experience with this, and forgive me if it's not related, is that -c '~/dir' isn't expainding the tilde. To fix this, I've had to replace the tilde with the actual homedir of my user.

Dustin Kirkland  (kirkland) wrote :

So the attached patch fixes this in Byobu with tmux 1.9, however, this patch is not compatible with tmux 1.8, so it would break users of PPA users of Byobu running on Trusty, for example.

Changed in byobu (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package byobu - 5.92-0ubuntu1

---------------
byobu (5.92-0ubuntu1) vivid; urgency=medium

  * usr/bin/byobu-launcher-install.in: LP: #1396959
    - silence warnings if byobu-launch doesn't exist (e.g., uninstalled it)
  * usr/bin/byobu-config.in: LP: #1383669
    - revert commit to LP: #1316050, which hardcoded LANG=C
    - this should fix rendering of Japanese characters in the menu
  * usr/share/byobu/keybindings/f-keys.tmux: LP: #1350813
    - handle tmux 1.9's default path changes, per:
      https://sourceforge.net/p/tmux/tmux-code/ci/1.9/tree/CHANGES
 -- Dustin Kirkland <email address hidden> Sat, 07 Mar 2015 18:59:37 -0500

Changed in byobu (Ubuntu):
status: Fix Committed → Fix Released
tags: added: patch
Johan van Dijk (johanvandijk) wrote :

This change breaks the F2 functionality in Ubuntu 12.04
(This one: http://bazaar.launchpad.net/~kirkland/byobu/trunk/revision/2405)

Johan van Dijk (johanvandijk) wrote :

I didn't see comment #6...
So is there a solution for 12.04 users who use the PPA version?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers