blt::RemoveBindTag not found

Bug #1772905 reported by Ole Streicher on 2018-05-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tkblt (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

[Impact]

The tkblt package lacks the definitions that come in the `graph.tcl` file:

    % package require tkblt
    3.2
    % blt::RemoveBindTag
    invalid command name "blt::RemoveBindTag"

This affects the saods9 package: When one selects the "Analysis -> Line plot tool" menu item, an error message pops up with

  An internal error has been detected
  invalid command name "blt::RemoveBindTag"

and the following graph is empty.

Similar error messages come up in several places, significantly decreasing the usability of saods9.

The problem is fixed in the Debian version 3.2.8-1. I will provide a backport for Ubuntu.

[Test Case]

1. install tkblt, and then run the "wish" Tcl shell. With the bug, it will present the output shown above.

2. install saods9, start "ds9", open the "Analysis" menu and select "Line Plotting tool...". With the bug, an error message will appear.

[Regression Potential]

saods9 (and tksao, which is also in the saods9 source package) is the only reverse dependency of tkblt (in fact, upstream made tkblt an split-off from saods9), and saods9 is tested with the fix. Also, the fix is quite straightforward; so no regression is expected. In the worst case (if the fix would be completely wrong), it would make saods9 unusable.

[Other info]

Relevant upstream pull request: https://github.com/wjoye/tkblt/pull/13

Ole Streicher (olebole) wrote :
Ole Streicher (olebole) wrote :

This attachment is a backport of the relevant change in tkblt 3.2.8-1 that fixes the bug. The fix has been tested, discussed upstream, and is uploaded to Debian unstable. Since the bug causes a major decrease of saods9 functionality, I ask to apply it to the stable Ubuntu 18.04 release.

(I am the maintainer of tkblt in Debian)

Thanks!

Ole

Ole Streicher (olebole) on 2018-05-23
Changed in tkblt (Ubuntu):
status: New → In Progress
Ole Streicher (olebole) on 2018-05-23
description: updated
Ole Streicher (olebole) on 2018-05-23
description: updated
description: updated

Hello Ole, or anyone else affected,

Accepted tkblt into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/tkblt/3.2.7-1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in tkblt (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Ole Streicher (olebole) wrote :

I tested the package tkblt-3.2.7-1ubuntu1 as updated from bionic-proposes. All tests were successfull:

* loading tkblt within wish as stated in the original bug description

* testing saods9 as described above, and additionally did some random usage of saods9 using the graphics widgets that require tkblt

Therefore, I am setting the tag to verification-done-bionic.

Thanks for uploading

Ole

tags: added: verification-done-bionic
removed: verification-needed-bionic
Changed in tkblt (Ubuntu):
status: In Progress → Fix Released
Łukasz Zemczak (sil2100) wrote :

Thank you for the verification! Sadly, there seems to be an autopkgtest regression reported for this upload in saods9 (for i386). I tried re-running it and it looks like the failure is persistent when ran against tkblt 3.2.7-1ubuntu1. To make sure it's not saods9 that's broken in bionic release, I ran the tests against what's in the archive but then the autopkgtests passed. Might be just bad luck, but so far it seems that the new tkblt is causing a regression in saods9 on i386 - it needs someone to at least investigate it.

Could you or someone else take a look and try to assess why the ADT test-suite suddenly fails against the new tkblt? Might be unrelated, but we'd need some proof of that.

http://autopkgtest.ubuntu.com/packages/s/saods9/bionic/i386

Ole Streicher (olebole) wrote :

The failure is a bit mystic to me. It definitely has nothing to do with the tkblt problem: tkblt is a widget set, while the failure comes from a networking test (XPA is a network protocol somehow specific to saods9).

I have never seen this problem on Debian (only 64 bit, however); but it happened occasionally on Ubuntu -- unrelated to tkblt update, f.e.:

* xorg-server/2:1.19.6-1ubuntu3, 2018-03-14 19:53:47 UTC
* starlink-ast/8.6.2+dfsg-2 2018-01-25 00:34:41 UTC

etc. The problem also exists since a while on armhf; http://autopkgtest.ubuntu.com/packages/s/saods9/bionic/armhf

It just depends on the speed of the test platform: the testscript (debian/tests/saods9-xpa) starts ds9, waits one second to come up and then tries to communicate with it. If the one second is not enough, the communication will fail (and the test as well).

This is ofcourse a bug in the test script (will attempt to fix than in the next release of saods9); however I don't know how to proceed here. I am however sure that this is not related to the patch proposed here.

Łukasz Zemczak (sil2100) wrote :

Ok, thank you for your investigation! Might be that we're either simply very unlucky or things got a bit slower. I guess let's release it as is.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tkblt - 3.2.7-1ubuntu1

---------------
tkblt (3.2.7-1ubuntu1) bionic-proposed; urgency=low

  * SRU: Load graph.tcl when the package is loaded (LP: #1772905)

 -- Ole Streicher <email address hidden> Wed, 23 May 2018 14:46:49 +0200

Changed in tkblt (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for tkblt has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers