Tinyproxy segfault at logrotate

Bug #625751 reported by Yannis Aribaud on 2010-08-28
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
tinyproxy (Debian)
Fix Released
Unknown
tinyproxy (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: tinyproxy

Description: Ubuntu 10.04.1 LTS
Release: 10.04
Package: tinyproxy 1.8.1-3

Tinyproxy segfaults everyday at the log rotation time.
There is the syslog trace:

Aug 27 06:53:14 gwtex kernel: [714289.697157] __ratelimit: 6 callbacks suppressed
Aug 27 06:53:14 gwtex kernel: [714289.697163] tinyproxy[9556]: segfault at 0 ip 00007f1f8b91c53a sp 00007fff9b6ac4b8 error 4 in libc-2.11.1.so[7f1f8b89b000+17a000]
Aug 27 06:53:14 gwtex kernel: [714289.706658] tinyproxy[9555]: segfault at 0 ip 00007f1f8b91c53a sp 00007fff9b6ac4b8 error 4 in libc-2.11.1.so[7f1f8b89b000+17a000]
Aug 27 06:53:14 gwtex kernel: [714289.716107] tinyproxy[9553]: segfault at 0 ip 00007f1f8b91c53a sp 00007fff9b6ac4b8 error 4 in libc-2.11.1.so[7f1f8b89b000+17a000]
Aug 27 06:53:14 gwtex kernel: [714289.725047] tinyproxy[9554]: segfault at 0 ip 00007f1f8b91c53a sp 00007fff9b6ac4b8 error 4 in libc-2.11.1.so[7f1f8b89b000+17a000]
Aug 27 06:53:14 gwtex kernel: [714289.732658] tinyproxy[9558]: segfault at 0 ip 00007f1f8b91c53a sp 00007fff9b6ac4b8 error 4 in libc-2.11.1.so[7f1f8b89b000+17a000]
Aug 27 06:53:14 gwtex kernel: [714289.734861] tinyproxy[9561]: segfault at 0 ip 00007f1f8b91c53a sp 00007fff9b6ac4b8 error 4 in libc-2.11.1.so[7f1f8b89b000+17a000]
Aug 27 06:53:14 gwtex kernel: [714289.737191] tinyproxy[9560]: segfault at 0 ip 00007f1f8b91c53a sp 00007fff9b6ac4b8 error 4 in libc-2.11.1.so[7f1f8b89b000+17a000]
Aug 27 06:53:14 gwtex kernel: [714289.739771] tinyproxy[9562]: segfault at 0 ip 00007f1f8b91c53a sp 00007fff9b6ac4b8 error 4 in libc-2.11.1.so[7f1f8b89b000+17a000]
Aug 27 06:53:14 gwtex kernel: [714289.742725] tinyproxy[9559]: segfault at 0 ip 00007f1f8b91c53a sp 00007fff9b6ac4b8 error 4 in libc-2.11.1.so[7f1f8b89b000+17a000]
Aug 27 06:53:14 gwtex kernel: [714289.745879] tinyproxy[9552]: segfault at 0 ip 00007f1f8b91c53a sp 00007fff9b6ac998 error 4 in libc-2.11.1.so[7f1f8b89b000+17a000]

It seems that it is a known bug from a Debian package.

Changed in tinyproxy (Debian):
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in tinyproxy (Ubuntu):
status: New → Confirmed

This issue is still present in 1.8.4-2 (from 17.04). Currently upgrading to 17.10 is discouraged, so I'd rather not check whether it is fixed there.

However, please note, that https://github.com/tinyproxy/tinyproxy/issues/25 seems to have a fix for the bug.

gesasgerol (ekkhsa-launchpad) wrote :

I do have the issue on 17.10.

my temporary fix would be to change the logging to syslog in
/etc/tinyproxy/tinyproxy.conf
`Syslog On`

or to insert
`create 640 tinyproxy tinyproxy
`
into the /etc/logrotate.d/tinyproxy
```
# cat /etc/logrotate.d/tinyproxy
/var/log/tinyproxy/tinyproxy.log {
 rotate 14
 daily
 compress
 missingok
 create 640 tinyproxy tinyproxy
 postrotate
  invoke-rc.d --quiet tinyproxy reload > /dev/null
 endscript
 notifempty
}
```
Testet on Ubuntu 17.10

Please, note that it is possible to intall cosmic package onto bionic. Updating the version for bionic is stressless.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.