Dropping connections for some requests through the proxy

Bug #153744 reported by Andrew on 2007-10-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tinyproxy (Ubuntu)
Low
Unassigned
xfce4-weather-plugin (Ubuntu)
Low
Lionel Le Folgoc

Bug Description

Binary package hint: tinyproxy

This bug can be re-produced using xfce4-weather-plugin

When using my work proxy on port 80 everything works. When I attempt to use tinyproxy, the plugin is unable to get the page

Headers (seen using wireshark) when I connect directly to my work proxy:

GET http://xoap.weather.com/weather/local/80111?cc=*&dayf=5&unit=i HTTP/1.0\r\n

When I am using tinyproxy with my work proxy as the upstream proxy:

GET http://xoap.weather.com:80/weather/local/80111?cc=*&dayf=5&unit=i HTTP/1.0\r\n
Host: xoap.weather.com\r\n
Connection: close\r\n
Via: 1.0 tinyproxy (tinyproxy/1.6.3)\r\n
\r\n

The tinyproxy.log file contains this:

CONNECT Oct 16 09:35:19 [7984]: Connect (file descriptor 8): localhost [127.0.0.1]
CONNECT Oct 16 09:35:19 [7984]: Request (file descriptor 8): GET http://xoap.weather.com/weather/local/80111?cc=*&dayf=5&unit=i HTTP/1
INFO Oct 16 09:35:19 [7984]: Found proxy mywork.com:80 for xoap.weather.com
CONNECT Oct 16 09:35:19 [7984]: Established connection to upstream proxy "mywork.com" using file descriptor 9.
INFO Oct 16 09:35:20 [7984]: Closed connection between local client (fd:8) and remote client (fd:9)

Without more information, it seems like tinyproxy is closing the connection.

I can reproduce this with or without using an upstream proxy

Andrew (andrew-rw-robinson) wrote :

FYI the log line was cut off by my copy, it should be:
CONNECT Oct 16 09:35:19 [7984]: Request (file descriptor 8): GET http://xoap.weather.com/weather/local/80111?cc=*&dayf=5&unit=i HTTP/1.0

Andrew (andrew-rw-robinson) wrote :

Any status on this?

Squid works, but tinyproxy is still failing. I hate using squid as not only is it overkill, but it is really slow to start and stop, which is painful on a laptop that I go from home to work often and reconfigure the proxy per location.

Even if I use squid as my upstream proxy to tiny proxy it works, so there seems to be a situation where tinyproxy is unable to communicate with my works proxy server for certain HTTP connections (some seem to work fine)

If I use w3m to connect to "http://xoap.weather.com/weather/local/80124?cc=*&dayf=5&unit=i", it works. Therefore the request by the xfce4-weather-plugin must not be done in a compatible manor.

The problem is that tinyproxy with INFO logging, seemingly the most verbose according to the etc file is not showing any difference between the request. Perhaps it is an HTTP header difference that is not logged?

How can I get more information to help you debug this?

Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10?

Changed in tinyproxy:
status: New → Incomplete
Andrew (andrew-rw-robinson) wrote :

Yes, the problem is reproducible in Intrepid. I have given up with tinyproxy and am using Squid3 now as it is working, but I can test this bug in the future if you need me to. My co-worker was also having problems with tiny-proxy dropping some connections. There seems to be a communication problem with tiny-proxy and our upstream proxy. It seems like the connection is prematurely terminated. Perhaps some HTTP header is not what is expected by our proxy server?

Vladimir Hidalgo (vlad88sv) wrote :

Watch out that TinyProxy likes to block itself from time to time. I'm having the need to do "sudo invoke-rc.d tinyproxy restart" almost each hour or so.

Btw, seems that tiniproxy lacks a truly Debian/Ubuntu-like Init script.

Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in tinyproxy:
importance: Undecided → Low
status: Incomplete → Triaged
Lionel Le Folgoc (mrpouit) wrote :

Latest xfce4-weather-plugin releases in karmic should have improved the situation with proxies, could you retry please? (anyway, if it only has issues with tinyproxy and not with other proxies, maybe the bug is in tinyproxy…)

Changed in xfce4-weather-plugin (Ubuntu):
assignee: nobody → Lionel Le Folgoc (mrpouit)
importance: Undecided → Low
status: New → Incomplete

It may be a bit, I have switched to Gnome and no longer have all the
xfce libraries installed at the moment.

On Sun, Aug 16, 2009 at 11:37 AM, Lionel Le Folgoc<email address hidden> wrote:
> Latest xfce4-weather-plugin releases in karmic should have improved the
> situation with proxies, could you retry please? (anyway, if it only has
> issues with tinyproxy and not with other proxies, maybe the bug is in
> tinyproxy…)
>
> ** Changed in: xfce4-weather-plugin (Ubuntu)
>   Importance: Undecided => Low
>
> ** Changed in: xfce4-weather-plugin (Ubuntu)
>       Status: New => Incomplete
>
> ** Changed in: xfce4-weather-plugin (Ubuntu)
>     Assignee: (unassigned) => Lionel Le Folgoc (mrpouit)
>
> --
> Dropping connections for some requests through the proxy
> https://bugs.launchpad.net/bugs/153744
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Lionel Le Folgoc (mrpouit) wrote :

Okay, thanks for the feedback. Let's consider it is fixed then, but please reopen if you can still reproduce the issue with latest xfce4-weather-plugin on karmic.

Changed in xfce4-weather-plugin (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers