timidity crackles during the first second of output

Bug #1587215 reported by martinwguy on 2016-05-31
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
timidity (Ubuntu)
Undecided
Unassigned

Bug Description

Timidity burps half a dozen random samples at random moments during the first second of output.

Attached is an example MIDI file demonstrating the bug: a single note on the default instrument (Grand Piano). Just say "timidity note.mid"

The Debian bug report is
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=693011#17
an includes a one-line fix, replacing one > by >=

I have tested this fix compiling Ubuntu sources and it works.

This is present in timidity 2.13.2-40.3, from Ubuntu 14.04 to 16.04
The bug has been fixed upstream in their 2.14.0 release but Debian has not updated to this version yet, not even in unstable.

As this bug makes timidity useless for any serious work, another solution would be to apply the bug fix to 2.13.2, thereby repairing everyone's existing systems next time they upgrade...

martinwguy (martinwguy) wrote :
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in timidity (Ubuntu):
status: New → Confirmed
James Klaas (jklaas) wrote :

Whenever a new song is played in a playlist in the Gnome version, it spits out some errors on the console when it crackles:

(timidity:27280): Gtk-WARNING **: Invalid text buffer iterator: either the iterator is uninitialized, or the characters/pixbufs/widgets in the buffer have been modified since the iterator was created.
You must use marks, character numbers, or line numbers to preserve a position across buffer modifications.
You can apply tags and insert marks without invalidating your iterators,
but any mutation that affects 'indexable' buffer contents (contents that can be referred to by character offset)
will invalidate all outstanding iterators

(timidity:27280): Gtk-CRITICAL **: IA__gtk_text_buffer_insert: assertion 'gtk_text_iter_get_buffer (iter) == buffer' failed

Not sure if this is related.

martinwguy (martinwguy) wrote :

Hi
  I've placed Ubuntu packages fixing this bug under http://martinwguy.co.uk/ubuntu/
using the fix suggested in the Debian bug report above.

Ash Holland (sersorrel) wrote :

A suggested workaround from the linked Debian bug report is to pass the "--noise-shaping=1" flag to timidity, which works fine for me with no obvious side effects.

vmagnin (vincent-magnin) wrote :

The workaround suggested by Josh Holland works for me (no cracks anymore), but there is still a problem concerning pan: the sound is mainly in the left channel. Note that cracks were in the right channel.

When viewing in Audacity, one can see that the volume in the right channel is far less than in the left one (probably it was normalized with the cracks).

With Fluidsynth, everything is OK when playing the midi file.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package timidity - 2.14.0-1

---------------
timidity (2.14.0-1) unstable; urgency=low

  [ Reiner Herrmann ]
  * QA upload.
  * New upstream release. (Closes: #649274)
    - fix clicking at beginning of output (Closes: #693011, LP: #1587215)
  * Convert to dh-style build.
    - register mime types again (Closes: #587187)
  * Bump debhelper compat/dependency to 11.
  * Update Standards-Version to 4.1.4.
    - drop obsolete menu file
  * debian/control:
    - remove duplicated section
    - change libaudio-dev B-D arch to linux-any (Closes: #634745)
    - timidity-daemon requires lsb-base for the init script
    - depend on wish for tcl scripts in timidity-interfaces-extra
    - drop ancient version restrictions and replace relations
    - drop unused build dependency libaudiofile-dev (Closes: #857672)
  * debian/patches:
    - drop patches no longer needed or already applied upstream
    - fix spelling errors found by lintian.
    - add patch to honour LDFLAGS while linking interface addons
    - split up huge debian-changes-2.13.2-36 patch into smaller ones;
      drop several hunks that have been applied upstream or are no longer
      needed (like aRts- and autotools-related changes)
  * Move .desktop file to timidity package and rename appropriately.
    (Closes: #761472)
  * Fix build failure with Tcl/Tk 8.6. (Closes: #728089)
  * Allow opening files via .desktop file. (LP: #1072179)
  * Recommend and configure fluid-soundfont-gm by default.
    (Closes: #870429, #610266)
  * Drop unneeded debian/*.dirs files.
  * Rename lintian overrides to timidity.lintian-overrides.
  * Add upstream metadata file.
  * Set home directory of timidity system user during creation.
  * Convert debian/copyright to machine-readable format.
  * Move /etc/default/timidity into timidity-daemon, as it is only
    used by the init script provided there.
  * Drop mostly outdated debian/TODO file.
  * Drop obsolete maintainer scripts that have no function or were (re)moving
    long gone conffiles.

  [ Guillem Jover ]
  * Fix LSB init output (Closes: #823083)

  [ Frank Heckenbach ]
  * Register .mod files with timidity in mime database. (Closes: #587187)

  [ Helmut Grohne ]
  * Don't assume availability of libOggFLAC for cross compilation.
    (Closes: #885857)

 -- Reiner Herrmann <email address hidden> Thu, 07 Jun 2018 21:42:56 +0200

Changed in timidity (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers