timblserver version 1.2-4 failed to build on i386

Bug #803205 reported by Stefano Rivera on 2011-06-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
timblserver (Debian)
Fix Released
Unknown
timblserver (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

timblserver version 1.2-4 failed to build on i386
Link to failed build: https://launchpad.net/ubuntu/+source/timblserver/1.2-4/+build/2480990

Direct link to the build log: https://launchpad.net/ubuntu/+source/timblserver/1.2-4/+build/2480990/+files/buildlog_ubuntu-oneiric-i386.timblserver_1.2-4_FAILEDTOBUILD.txt.gz

This log snippet might be of interest, since it triggered the matcher 'Purging chroot-autobuild'.
Excerpt 1291 lines into the build log:

/usr/lib/libtimbl.so: undefined reference to `omp_get_thread_num'
/usr/lib/libtimbl.so: undefined reference to `omp_get_num_threads'
/usr/lib/libtimbl.so: undefined reference to `GOMP_parallel_start'
/usr/lib/libtimbl.so: undefined reference to `GOMP_critical_start'
/usr/lib/libtimbl.so: undefined reference to `GOMP_parallel_end'
/usr/lib/libtimbl.so: undefined reference to `omp_set_num_threads'
collect2: ld returned 1 exit status
make[3]: *** [sockettestServer] Error 1
make[3]: Leaving directory `/build/buildd/timblserver-1.2/demos'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/build/buildd/timblserver-1.2'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/build/buildd/timblserver-1.2'
make: *** [debian/stamp-makefile-build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2
******************************************************************************
Build finished at 20110505-1209
FAILED [dpkg-buildpackage died]
Purging chroot-autobuild/build/buildd/timblserver-1.2

Changed in timblserver (Ubuntu):
importance: Undecided → Medium
Julian Taylor (jtaylor) wrote :

this bug is caused by a problem in timbl.
See the debian bug for details.

Changed in timblserver (Ubuntu):
status: New → Triaged
Changed in timblserver (Debian):
status: Unknown → New
Matthias Klose (doko) on 2011-08-29
Changed in timblserver (Ubuntu):
importance: Medium → High
Matthias Klose (doko) wrote :

fixed with the recent timbl in oneiric

Changed in timblserver (Ubuntu Oneiric):
status: Triaged → Fix Released
Changed in timblserver (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.