Tilix symbol lookup error

Bug #1756594 reported by hva
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
tilix (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

I'm experiencing an issue with Tilix on ubuntu-budgie 18.04 beta.

Launching tilix give this error:

tilix: symbol lookup error: tilix: undefined symbol: _D3gtk6Widget6Widget10__mixin74820getImplementorStructMFbZPS3atk1c5types14AtkImplementor

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: tilix 1.7.5-2ubuntu2
ProcVersionSignature: Ubuntu 4.15.0-12.13-generic 4.15.7
Uname: Linux 4.15.0-12-generic x86_64
ApportVersion: 2.20.8-0ubuntu10
Architecture: amd64
CurrentDesktop: Budgie:GNOME
Date: Sat Mar 17 21:25:38 2018
InstallationDate: Installed on 2018-03-12 (5 days ago)
InstallationMedia: Ubuntu-Budgie 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180307.1)
SourcePackage: tilix
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
hva (francesco-hermanitosverdes) wrote :
summary: - Tilix not starting since last update
+ Tilix symbol lookup error
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in tilix (Ubuntu):
status: New → Confirmed
Revision history for this message
fossfreedom (fossfreedom) wrote :

The recent uplift of libvted-3-0 from 3.7.3-1ubuntu 1 to 3.7.5-2 has broken tilix

Revision history for this message
fossfreedom (fossfreedom) wrote :

new tilix release has been made - marking this as fix released

Changed in tilix (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Joseph Maillardet (jokx) wrote :

18.10 up-to-date

tilix 1.7.9-2ubuntu1 amd64
tilix-common 1.7.9-2ubuntu1 all

Running tilix :
$ tilix
tilix: symbol lookup error: tilix: undefined symbol: _D4glib3StrQe9toStringzFAyaZPa

Revision history for this message
galen (galen-technomage) wrote :

Same as Joseph... :/

Ubuntu 18.10 x86_64

tilix 1.7.9-2ubuntu1
tilix-common 1.7.9-2ubuntu1

tilix: symbol lookup error: tilix: undefined symbol: _D4glib3StrQe9toStringzFAyaZPa

Revision history for this message
fossfreedom (fossfreedom) wrote :

Guys - this bug report is specific to 18.04 - please raise a new bug report on the tilix package - libvted-3.0 changes is the likely cause - its probably a question of uplifting or patching the tilix package.

Revision history for this message
Joseph Maillardet (jokx) wrote :

Ok, sorry.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers