Hyperlink feature unexpectedly removed by PCRE2 patch

Bug #1718909 reported by Egmont Koblinger on 2017-09-22
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
tilix (Ubuntu)
Undecided
Unassigned

Bug Description

vte-0.49 and tilix-1.5.8 introduce a brand new feature: custom hyperlinks (just like on webpages; the visible text is arbitrary, and the target URL is specified by an escape sequence).

This feature technically has nothing to with PCRE2. Since the target URL is explicitly specified and never guessed, no regex matching is involved at all.

Your patch that removes PCRE2 support (or actually makes it conditional to a future vte version 0.60) also removes the custom hyperlink feature for no apparent reason. (And by the way it prints 0.50 in a debug message instead of 0.60, I guess that's a typo.)

Please fix that patch to only bump the version requirement for PCRE2 and not for custom hyperlinks.

I know at this moment Artful ships vte-0.48 so there's no immediate user visible problem here. However:
- I'm not sure if it will upgrade to 0.50 before the final release, and then filing/fixing the Tilix issue might be too late;
- People might compile a newer VTE manually or install from GNOME3 Staging once it appears there, and would expect this feature to work;
- This problem will probably remain for 18.04 and you'd have to fix there anyways, so why not now.

How to reproduce:

After upgrading libvte-2.91-0 to 0.50, execute this command in Tilix:

echo -e '\e]8;;https://www.ubuntu.com/\aCtrl+click here\e]8;;\a'

Expected: "Ctrl+click here" appears with dotted underline, continuous underline on hover, and Ctrl+clicking opens Ubuntu's homepage in a browser. The right-click menu also contains corresponding "Open Link" and "Copy Link Address" entries.

Actual: "Ctrl+click here" appears as simple text and nothing special happens upon hovering or Ctrl+clicking, and no related entries in the right-click menu.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: tilix (not installed)
ProcVersionSignature: Ubuntu 4.13.0-11.12-generic 4.13.1
Uname: Linux 4.13.0-11-generic x86_64
ApportVersion: 2.20.7-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity:Unity7:ubuntu
Date: Fri Sep 22 12:23:55 2017
InstallationDate: Installed on 2016-11-09 (316 days ago)
InstallationMedia: Ubuntu 16.10 "Yakkety Yak" - Release amd64 (20161012.2)
SourcePackage: tilix
UpgradeStatus: Upgraded to artful on 2017-09-21 (0 days ago)

Egmont Koblinger (egmont-gmail) wrote :
description: updated
Jeremy Bicha (jbicha) wrote :

I think this attached diff is what you mean but I don't have vte2.91 0.50 at the moment to try out. Ubuntu 17.10 will stay with vte2.91 0.48 (LP: #1721412)

tags: added: patch
Egmont Koblinger (egmont-gmail) wrote :

Hi,

Thanks for looking into this!

So this is a patch to a patch... my mind is exploding :D

You'll need to revert the changes in the immediate surrounding lines of "vte.setAllowHyperlink(true)" as well.

Thx!

Jeremy Bicha (jbicha) wrote :

Ok, here's just the patch (without the patch to a patch).

Egmont Koblinger (egmont-gmail) wrote :

I've tested:
- VTE from git master (no PCRE patch)
- Tilix from git master, with this patch only

Hyperlinks work as expected. That is, if the PCRE stuff works correctly with Ubuntu's pcre-patched 0.48, which I assume you tested, then this patch is good.

Thanks!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in tilix (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :

I think we can reduce the pcre2 patch down to this one for tilix 1.7.5. I am waiting for the ongoing ldc transition in Ubuntu to progress before uploading this since tilix is currently unbuildable in bionic-proposed.

Egmont Koblinger (egmont-gmail) wrote :

Indeed, nice simplification, and nice refactoring from Tilix (irrelevant: https://github.com/gnunn1/tilix/issues/1264).

0.60 is due in a mere two years, why not 0.99 or so? :)

Jeremy Bicha (jbicha) on 2018-01-21
Changed in tilix (Ubuntu):
status: Confirmed → Triaged
Jeremy Bicha (jbicha) wrote :

> 0.60 is due in a mere two years, why not 0.99 or so? :)

I sure hope we can drop this patch before then!

I truly hope so too, but that's not a guarantee for this to happen :) Anyway, it's not worth spending any more time on this nitpicking, do as you please, I'm fine with whichever.

Jeremy Bicha (jbicha) wrote :

This will be stuck in bionic-proposed for a bit because of the ongoing ldc transition

https://launchpad.net/ubuntu/+source/tilix/1.7.5-1ubuntu1

https://people.canonical.com/~ubuntu-archive/transitions/html/ldc.html

Changed in tilix (Ubuntu):
status: Triaged → Fix Committed
Jeremy Bicha (jbicha) on 2018-05-12
Changed in tilix (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.