Tilda: "TERM environment variable needs set"

Bug #635804 reported by Detlef Lechner on 2010-09-11
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
tilda (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: tilda

[Maverick Beta]Tilda reports: "TERM environment variable needs set."
This is a regression: Tilda did not produce this error message in Ubuntu 10.04.1 on the same computer befor distribution upgrading.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: tilda 0.09.6-2
ProcVersionSignature: Ubuntu 2.6.35-20.29-generic 2.6.35.4
Uname: Linux 2.6.35-20-generic i686
Architecture: i386
Date: Sat Sep 11 17:19:11 2010
ProcEnviron:
 LANGUAGE=de_DE:de
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: tilda

Detlef Lechner (detlef-lechner) wrote :
Joel Berger (joel-a-berger) wrote :

Just updated today, same problem here. I've noticed that guake and terminator. There seems to be some info there.

http://guake.org/ticket/249
https://bugs.launchpad.net/ubuntu/+source/terminator/+bug/621632

Joel Berger (joel-a-berger) wrote :

Sorry one more link with relevant info.

https://bugs.launchpad.net/terminator/+bug/621606

Joel Berger (joel-a-berger) wrote :

On Ubuntu I think the easiest way to fix this problem, both workaround and packaged as a solution, is to make a simple script in /etc/profile.d/ . I called mine set_term.sh (must end in .sh). The file need only have in it

export TERM=xterm

and then either run "source /etc/profile" or reboot. This will set the $TERM variable for all users on each boot without hardcoding the variable as some of the other programs I listed above have done. In one command, for those who need it run:

echo "export TERM=xterm" | sudo tee /etc/profile.d/set_term.sh && source /etc/profile

Hope that helps.

Zaur Nasibov (basicwolf) wrote :

Thank you very much, Joel, your solution helped. I hope the bug will be fixed before release.

cyber-punk (cyber-punk) wrote :

I noticed an interesting feature. If tilda run from a gnome-terminal, then no errors occur. If run on the ALT + F2 then pops up an error "TERM environment variable needs set." when you enter "clear".

Richard James (rjames13) wrote :

I'm having the same error
TERM environment variable needs set.

in xfce4-term after upgrading to 10.10 worked in 10.04

I wonder if these 2 bugs are related?

Charlie Kravetz (charlie-tca) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 621927, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

Changed in tilda (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.