Tilda:9793 GTK Error

Bug #111571 reported by Jojje
18
Affects Status Importance Assigned to Milestone
tilda (Ubuntu)
Medium
Unassigned

Bug Description

After leaving Tilda config "tilda -C", i get message """"(tilda:9793): Gtk-CRITICAL **: gtk_main_quit: assertion 'main_loops != Null Failed."""""
Besides this error my problem is MAINLY that while entering text in Tilda i see the letter i write clearly but while entering the next, the first "blurs out" to unreadable.

Revision history for this message
Áron Sisak (asisak) wrote :

Thanks for reporting this bug.

1. Please try to obtain a backtrace <http://wiki.ubuntu.com/DebuggingProgramCrash> and attach the file to the bug report. This will greatly help us in tracking down your problem.
2. Try to switch on double buffering, that might help on the latter issue.

Changed in tilda:
assignee: nobody → asisak
importance: Undecided → Medium
status: Unconfirmed → Needs Info
Revision history for this message
Áron Sisak (asisak) wrote :

 We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and don't hesitate to submit bug reports in the future.

Changed in tilda:
assignee: asisak → nobody
status: Needs Info → Rejected
Revision history for this message
figgles (ggles-fi) wrote :

I am having the identical problem. I performed a backtrace, as referenced above and attached.

figgles (ggles-fi)
Changed in tilda:
status: Rejected → Confirmed
Revision history for this message
figgles (ggles-fi) wrote :

Reviewing my notes, I am not being clear. I have not experienced the "blurs out" issue with the fonts but the crash prevents tilda from loading.

Revision history for this message
Áron Sisak (asisak) wrote :

Thanks for your bug. Please confirm that this still occurs when you remove your configuration files. If so, please try to obtain a backtrace with dbgsym libraries (http://wiki.ubuntu.com/DebuggingProgramCrash should help). Thanks in advance.

Changed in tilda:
assignee: nobody → asisak
status: Confirmed → Incomplete
Revision history for this message
Mantas Zimnickas (sirex) wrote :

I also got identical error, when there is no ~/.tilda/ config directory, I get this error:

(tilda:6879): Gtk-CRITICAL **: gtk_window_resize: assertion `height > 0' failed

if ~/.tilda/ config direcoty is already created and I add -C flag, got this error:

(tilda:6933): Gtk-CRITICAL **: gtk_window_resize: assertion `height > 0' failed

Currently I'm using: Ubuntu 7.04, tilda 0.09.4

Revision history for this message
Mantas Zimnickas (sirex) wrote :

Also attached backtrace.

Revision history for this message
Áron Sisak (asisak) wrote :

Thanks for your response. Which version of Tilda do you use.

Revision history for this message
Áron Sisak (asisak) wrote :

Sorry, I mean, which package version, e.g. 0.09.4-4

Revision history for this message
Mantas Zimnickas (sirex) wrote : Re: [Bug 111571] Re: Tilda:9793 GTK Error

command `dpkg -l` shows fallowing information:

    tilda 0.09.4-0ubuntu2

On 2007-08-24 07:25, Áron Sisak wrote:
> Sorry, I mean, which package version, e.g. 0.09.4-4
>
> --
> Tilda:9793 GTK Error
> https://bugs.launchpad.net/bugs/111571
> You received this bug notification because you are a direct subscriber
> of the bug.

--
Mantas aka sirex
http://sirex.raguvele.lt/
Ubuntu - Linux for human beings

"If a trainstation is where the train stops, what's a workstation...?" -- Anon.

Revision history for this message
Áron Sisak (asisak) wrote :

Okay. You get this warning messages but is Tilda working? The backtrace shows it is not a real problem to run the application. Please correct me if I would be wrong.

Revision history for this message
Mantas Zimnickas (sirex) wrote :

OK, this is step by step, what I do and what I get:

% rm -rf .tilda
% tilda

after this, tilda configuration window appears. I do not change any thing, and
just press „OK“. After that tilda window appears just for a second, and then
disappears. Then I got these error messages:

    (tilda:12217): Gtk-CRITICAL **: gtk_main_quit: assertion `main_loops != NULL' failed'

    (tilda:12217): Gtk-CRITICAL **: gtk_window_resize: assertion `height > 0' failed'

Trying to run tilda again:

% tilda

and any thing happened.. Tilda window will not appeared.

% tilda -C

    (tilda:12282): Gtk-CRITICAL **: gtk_main_quit: assertion `main_loops != NULL' failed'

% tilda
% ps -e | grep -i tilda

no process running...

% rm -rf .tilda
% tilda

    (tilda:12466): Gtk-CRITICAL **: gtk_main_quit: assertion `main_loops != NULL' failed'

% tilda
%

And another thing, I tried to do every thing like written in:

    https://wiki.ubuntu.com/DebuggingProgramCrash

But what I got:

% sudo apt-get install tilda-dbgsym

The following packages have unmet dependencies:
  tilda-dbgsym: Depends: tilda (= 0.09.4-4) but 0.09.4-0ubuntu2 is to be installed

So that is why backtrace shows nothing..

Also I attached another backtrace, when tilda is launched with removed
configuration directory.

On 2007-08-24 08:09, Áron Sisak wrote:
> Okay. You get this warning messages but is Tilda working? The backtrace
> shows it is not a real problem to run the application. Please correct me
> if I would be wrong.
>
> --
> Tilda:9793 GTK Error
> https://bugs.launchpad.net/bugs/111571
> You received this bug notification because you are a direct subscriber
> of the bug.

--
Mantas aka sirex
http://sirex.raguvele.lt/
Ubuntu - Linux for human beings

"We should forget about small efficiencies, say about 97% of the time: premature optimization is the root of all evil." (Code Complete, Page 594)

Revision history for this message
Áron Sisak (asisak) wrote :

Did you replace feisty by gutsy if you are running feisty?
It would also be useful to test this issue on gutsy (with 0.09.4-4)

Revision history for this message
Mantas Zimnickas (sirex) wrote :

No, I'm not replaced feisty by gutsy. I'm using only feisty repositories.

Also I tried to install .deb package (version 0.09.4-4) from gutsy repository,
but gdebi said me, that there is a dependency problem with libc6. So I decided
to not broke dependencies.

At this time, I can't test it on gutsy.

On 2007-08-24 09:22, Áron Sisak wrote:
> Did you replace feisty by gutsy if you are running feisty?
> It would also be useful to test this issue on gutsy (with 0.09.4-4)
>
> --
> Tilda:9793 GTK Error
> https://bugs.launchpad.net/bugs/111571
> You received this bug notification because you are a direct subscriber
> of the bug.

--
Mantas aka sirex
http://sirex.raguvele.lt/
Ubuntu - Linux for human beings

"Programming is like sex: one mistake and you have to support it for the rest of your life." -- Michael Sinz.

Revision history for this message
Áron Sisak (asisak) wrote :

Sorry I wanted to ask if you use the feisty dbgsym instead of the gutsy one?

Revision history for this message
Mantas Zimnickas (sirex) wrote :
Download full text (4.7 KiB)

Sorry, it's my fault. It seams, that accidentally I added gutsy
http://people.ubuntu.com/~ubuntu-archive/ddebs repositories. That's why I got
dependencies errors. Now all fixed. Also I made backtraces again. I made it with
config directory and without it. Hope that now it all done well and information
will be helpful.

On 2007-08-24 09:48, Áron Sisak wrote:
> Sorry I wanted to ask if you use the feisty dbgsym instead of the gutsy
> one?
>
> --
> Tilda:9793 GTK Error
> https://bugs.launchpad.net/bugs/111571
> You received this bug notification because you are a direct subscriber
> of the bug.

--
Mantas aka sirex
http://sirex.raguvele.lt/
Ubuntu - Linux for human beings

"The real danger is not that computers will begin to think like men, but that men will begin to think like computers." -- Sydney J. Harris.

"The real danger is not that computers will begin to think like men, but that men will begin to think like computers." -- Sydney J. Harris.

GNU gdb 6.6-debian
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB. Type "show warranty" for details.
This GDB was configured as "i486-linux-gnu"...
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(gdb) handle SIG33 pass nostop noprint
Signal Stop Print Pass to program Description
SIG33 No No Yes Real-time event 33
(gdb) set pagination 0
(gdb) run
Starting program: /usr/bin/tilda
[Thread debugging using libthread_db enabled]
[New Thread -1219803456 (LWP 16352)]
/home/sirex/.themes/Dark Grey '72/gtk-2.0/gtkrc:180: Unable to locate image file in pixmap_path: "Arrows/arrow-up.png"
/home/sirex/.themes/Dark Grey '72/gtk-2.0/gtkrc:184: Overlay image options specified without filename
/home/sirex/.themes/Dark Grey '72/gtk-2.0/gtkrc:330: Unable to locate image file in pixmap_path: "Combo/combo-arrow-insens.png"
/home/sirex/.themes/Dark Grey '72/gtk-2.0/gtkrc:332: Overlay image options specified without filename
[New Thread -1221194864 (LWP 16359)]
[New Thread -1229608048 (LWP 16362)]

Program exited normally.
(gdb) backtrace full
No stack.
(gdb) ~info registers
The program has no registers now.
(gdb) thread apply all backtrace
(gdb) quit

GNU gdb 6.6-debian
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB. Type "show warranty" for details.
This GDB was configured as "i486-linux-gnu"...
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(gdb) handle SIG33 pass nostop noprint
Signal Stop Print Pass to program Description
SIG33 No No Yes Real-time event 33
(gdb) set pagination 0
(gdb) run
Starting program: /usr/bin/tilda
[Thread debugging using libthread_db enabled]
[New Thread -1220426048 (LWP 16237)]
/home/sirex/.themes/Dark Grey '72/gtk-2.0/gtkrc...

Read more...

Revision history for this message
Bartek Szopka (bartoszopka) wrote :

I get similar error on gutsy with tilda-0.09.4-4.

When I run it (even with clean configuration) I get all those errors:
(tilda:3502): Gdk-CRITICAL **: gdk_window_set_geometry_hints: assertion `GDK_IS_WINDOW (window)' failed

(tilda:3502): Gdk-CRITICAL **: gdk_window_move: assertion `GDK_IS_WINDOW (window)' failed

But tilda seems to be running. Window appears and everything works until I hide tilda with hot-key.
When I try to get it back i shows blank white window (with no terminal).

I need to quit tilda and start it back to get it working again.

Revision history for this message
Bartek Szopka (bartoszopka) wrote :

here is also strace log, maybe this one will help

Revision history for this message
Patrice KARATCHENTZEFF (patrice-karatchentzeff) wrote :

I get the same problem. Gutsy on x86

Revision history for this message
Patrice KARATCHENTZEFF (patrice-karatchentzeff) wrote :

and now the strace log file (more verbose).

FYI, I did the same thing as Mantas Zimnickas wrote on 2007-08-24...

Revision history for this message
Bartek Szopka (bartoszopka) wrote :

I also found that the problem appears only in "Animated pooldown" (I can't check now how this feature is called exactly) is switched OFF!

So with Animated Pooldown ON tilda works fine. It shows this GTK errors on console but it works (you can hide it and show again).
And with Animated Pooldown OFF tilda works fine after start but after hiding and showing it back again tilda window gets blank.

Hope it helps to track the bug.

Revision history for this message
Bartek Szopka (bartoszopka) wrote :

BTW, on hardy alpha with tilda 0.9.5pre problem is no more :)

Revision history for this message
Marishka (marina-chaban) wrote : Tilda Error

Tilda works fine after start but after hiding and showing it back again tilda window gets blank.

Revision history for this message
bernhard (bernhardredl) wrote : Workaround

http://phorolinux.com/how-to-install-tilda-095-on-ubuntu-710-gutsy-gibbon.html

here is a workaround for gutsy

i tried it on my system and it worked. ( keep in mind that make install installs to /usr/local/bin and not to /usr/bin where the binary from the packages lies

sadly i'm not experienced that much that i create a fixed dep file

Revision history for this message
Dan (orblivion) wrote :

It seems that some of you who had this problem in 0.94 had better luck with 0.95. Well as of Intrepid, Tilda is on version 0.96.

Those of you that were having this problem, could you update us as to whether it's now fixed for you?

Revision history for this message
Patrice KARATCHENTZEFF (patrice-karatchentzeff) wrote : Re: [Bug 111571] Re: Tilda:9793 GTK Error

2009/2/21 Dan <email address hidden>:

Hi,

> It seems that some of you who had this problem in 0.94 had better luck
> with 0.95. Well as of Intrepid, Tilda is on version 0.96.
>
> Those of you that were having this problem, could you update us as to
> whether it's now fixed for you?
>
> --
> Tilda:9793 GTK Error
> https://bugs.launchpad.net/bugs/111571
> You received this bug notification because you are a direct subscriber
> of the bug.

I just installed and tried on intrepid (AMD64): still seg fault :

Here is the log file:

% tilda
Unable to open lock directory: /home/pk/.tilda/locks
Unable to open lock directory: /home/pk/.tilda/locks

(tilda:20780): Gtk-WARNING **: GtkSpinButton: setting an adjustment
with non-zero page size is deprecated

(tilda:20780): Gtk-WARNING **: GtkSpinButton: setting an adjustment
with non-zero page size is deprecated

(tilda:20780): Gtk-WARNING **: GtkSpinButton: setting an adjustment
with non-zero page size is deprecated

(tilda:20780): Gtk-WARNING **: GtkSpinButton: setting an adjustment
with non-zero page size is deprecated

(tilda:20780): Gtk-WARNING **: GtkSpinButton: setting an adjustment
with non-zero page size is deprecated

(tilda:20780): Gtk-WARNING **: GtkSpinButton: setting an adjustment
with non-zero page size is deprecated

(tilda:20780): Gtk-WARNING **: GtkSpinButton: setting an adjustment
with non-zero page size is deprecated

(tilda:20780): Gtk-WARNING **: GtkSpinButton: setting an adjustment
with non-zero page size is deprecated

(tilda:20780): Gtk-WARNING **: GtkSpinButton: setting an adjustment
with non-zero page size is deprecated

(tilda:20780): Gtk-WARNING **: GtkSpinButton: setting an adjustment
with non-zero page size is deprecated

(tilda:20780): Gtk-WARNING **: GtkSpinButton: setting an adjustment
with non-zero page size is deprecated

(tilda:20780): Gtk-WARNING **: GtkSpinButton: setting an adjustment
with non-zero page size is deprecated

(tilda:20780): Gtk-WARNING **: GtkSpinButton: setting an adjustment
with non-zero page size is deprecated

(tilda:20780): Gtk-WARNING **: GtkSpinButton: setting an adjustment
with non-zero page size is deprecated

(tilda:20780): Gtk-WARNING **: GtkSpinButton: setting an adjustment
with non-zero page size is deprecated

(tilda:20780): Gtk-CRITICAL **: gtk_file_chooser_select_filename:
assertion `filename != NULL' failed

(tilda:20780): Gdk-CRITICAL **: gdk_x11_window_set_user_time:
assertion `GDK_IS_WINDOW (window)' failed

(tilda:20780): Gtk-CRITICAL **: gtk_container_foreach: assertion
`GTK_IS_CONTAINER (container)' failed
[1] 20780 segmentation fault tilda

Hope it can help you,

Thanks,

PK

--
      |\ _,,,---,,_ Patrice KARATCHENTZEFF
ZZZzz /,`.-'`' -. ;-;;,_ mailto:<email address hidden>
     |,4- ) )-,_. ,\ ( `'-' http://p.karatchentzeff.free.fr
    '---''(_/--' `-'\_)

Revision history for this message
Mantas Zimnickas (sirex) wrote :
Download full text (5.1 KiB)

Now I'm using Tilda on Archlinux with E17 window manager. And Tilda is
working...

Don't know if it really helped, bet when Tilda is always crashed at start up, in
configuration I added „Run a custom command instead of the shell“: „zsh“.

After this Tilda started to work. But that was long time ago.

And now, when I run Tilda from terminal I get similar warnings:

    » tilda

    (tilda:7435): Gdk-CRITICAL **: gdk_x11_window_set_user_time: assertion `GDK_IS_WINDOW (window)' failed

    (tilda:7435): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

    (tilda:7435): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

    [ ... ]

    (tilda:7435): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

    (tilda:7435): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

    (tilda:7435): Gtk-CRITICAL **: gtk_file_chooser_select_filename: assertion `filename != NULL' failed

    (tilda:7435): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

    (tilda:7435): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

    [ ... ]

    (tilda:7435): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

    (tilda:7435): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

    (tilda:7435): Gtk-CRITICAL **: gtk_file_chooser_select_filename: assertion `filename != NULL' failed

    (tilda:7435): Gtk-CRITICAL **: gtk_main_quit: assertion `main_loops != NULL' failed

It would be great if Tlida's startup will be clean.

Also I user Clearlooks GTK2 theme.

On 2009-02-21 23:16, Patrice KARATCHENTZEFF wrote:
> 2009/2/21 Dan <email address hidden>:
> Hi,

>> It seems that some of you who had this problem in 0.94 had better luck
>> with 0.95. Well as of Intrepid, Tilda is on version 0.96.
>>
>> Those of you that were having this problem, could you update us as to
>> whether it's now fixed for you?
>>
>> --
>> Tilda:9793 GTK Error
>> https://bugs.launchpad.net/bugs/111571
>> You received this bug notification because you are a direct subscriber
>> of the bug.
> I just installed and tried on intrepid (AMD64): still seg fault :
> Here is the log file:
> % tilda
> Unable to open lock directory: /home/pk/.tilda/locks
> Unable to open lock directory: /home/pk/.tilda/locks
> (tilda:20780): Gtk-WARNING **: GtkSpinButton: setting an adjustment
> with non-zero page size is deprecated
> (tilda:20780): Gtk-WARNING **: GtkSpinButton: setting an adjustment
> with non-zero page size is deprecated
> (tilda:20780): Gtk-WARNING **: GtkSpinButton: setting an adjustment
> with non-zero page size is deprecated
> (tilda:20780): Gtk-WARNING **: GtkSpinButton: setting an adjustment
> with non-zero page size is deprecated
> (tilda:20780): Gtk-WARNING **: GtkSpinButton: setting an adjustment
> with non-zero page size is deprecated
> (tilda:20780): Gtk-WARNING **: GtkSpinButton: setting an adjustment
> with non-zero page size is deprecated
> (tilda:20780):...

Read more...

Revision history for this message
Dimitrios Symeonidis (azimout) wrote :

patrice, have you tried removing the ~/.tilda directory?

Changed in tilda (Ubuntu):
assignee: Áron Sisak (asisak) → nobody
Revision history for this message
Patrice KARATCHENTZEFF (patrice-karatchentzeff) wrote :

2009/10/13 Dimitrios Symeonidis <email address hidden>:
> patrice, have you tried removing the ~/.tilda directory?

Yes : I tried today on mu both system (Edgy amd64 and i386) : in the
better case, tilda is running but does not print anything from
keyboard.

PK

--
      |\ _,,,---,,_ Patrice KARATCHENTZEFF
ZZZzz /,`.-'`' -. ;-;;,_ mailto:<email address hidden>
     |,4- ) )-,_. ,\ ( `'-' http://p.karatchentzeff.free.fr
    '---''(_/--' `-'\_)

Revision history for this message
Dimitrios Symeonidis (azimout) wrote :

You're running Ubuntu Edgy (6.10)?

Revision history for this message
Patrice KARATCHENTZEFF (patrice-karatchentzeff) wrote :

2009/10/14 Dimitrios Symeonidis <email address hidden>:
> You're running Ubuntu Edgy (6.10)?

No : sorry : jaunty of course.

PK

--
      |\ _,,,---,,_ Patrice KARATCHENTZEFF
ZZZzz /,`.-'`' -. ;-;;,_ mailto:<email address hidden>
     |,4- ) )-,_. ,\ ( `'-' http://p.karatchentzeff.free.fr
    '---''(_/--' `-'\_)

Changed in tilda (Ubuntu):
status: Incomplete → New
Revision history for this message
Thomas Hotz (thotz-deactivatedaccount) wrote :

Can you reproduce this error with a supported Ubuntu version? Thank you!

Changed in tilda (Ubuntu):
status: New → Incomplete
Revision history for this message
Patrice KARATCHENTZEFF (patrice-karatchentzeff) wrote :

Sorry I did not use Ubuntu yet: I prefer Linux Mint.

PK

2012/11/8 Thomas Hotz <email address hidden>:
> Can you reproduce this error with a supported Ubuntu version? Thank you!
>
> ** Changed in: tilda (Ubuntu)
> Status: New => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/111571
>
> Title:
> Tilda:9793 GTK Error
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/tilda/+bug/111571/+subscriptions

--
      |\ _,,,---,,_ Patrice KARATCHENTZEFF
ZZZzz /,`.-'`' -. ;-;;,_ mailto:<email address hidden>
     |,4- ) )-,_. ,\ ( `'-' http://p.karatchentzeff.free.fr
    '---''(_/--' `-'\_)

Changed in tilda (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers