Ubuntu

Comment 5 for bug 972840

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package enigmail - 2:1.4-0ubuntu0.10.04.1

---------------
enigmail (2:1.4-0ubuntu0.10.04.1) lucid-proposed; urgency=low

  * New upstream release v1.4 (LP: #972840)
  * Make sure we remove the .bzr folder from the tarball when we build it
    - update debian/rules
  * Build with Latest Thunderbird SDK
    - update debian/rules
  * Add a proper get-orig-source target which pulls the build system from
    lp:~mozillateam/mozilla-build-system/beta, now that we don't have the old
    build-system.tar.gz from xulrunner
  * Build with --disable-elf-hack - it's broken on oneiric, and is a no-op
    on Ubuntu anyway
    - update debian/rules
  * Drop the nspr build-dep and don't build with --with-system-nspr.
    Thunderbird provides this already, and avoids needing to bump nspr
    on older releases just to build enigmail
    - update debian/rules
    - update debian/control
  * Add build/unix/elfhack/Makefile to debian/clean. It doesn't get cleaned
    by the build system, and there is a copy in the tree already which
    breaks the build
    - update debian/clean
  * Build with --disable-webm and --disable-libjpeg-turbo so we don't need to
    build-depend on yasm. I really do need to clean all of this useless
    junk out of the configure script
    - update debian/rules
  * Remove build/pgo/profileserver.py from debian/clean. The new build
    system has a target depending on this
    - update debian/clean
  * Drop debian/patches/autoconf.diff, just generate this at build time
  * libipc seems to be renamed to libipc-pipe. Fix genxpi and chrome.manifest
    to fix this
    - add debian/patches/ipc-pipe_rename.diff
    - update debian/patches/series
  * The makefiles in extensions/enigmail/ipc have an incorrect DEPTH
    attribute. Fix this so that they can find the rest of the build system
    - add debian/patches/makefile_depth.diff
    - update debian/patches/series
  * Drop debian/patches/makefile-in-empty-xpcom-fix.diff - fixed in the
    current version
  * Bump thunderbird-dev dependency to >= 5.0~b1
    - update debian/control
  * Run autoconf2.13 at build time
    - update debian/rules
    - update debian/control
  * Add useless mesa-common-dev build-dep, just to satisfy the build system.
    We should just patch this out entirely really, but that's for another upload
    - update debian/control
 -- Chris Coulson <email address hidden> Tue, 17 Apr 2012 03:05:21 -0500