Ubuntu

Thunderbird 11 stable release migration

Reported by Micah Gersten on 2012-04-03
64
This bug affects 12 people
Affects Status Importance Assigned to Milestone
enigmail (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Micah Gersten
Natty
Undecided
Micah Gersten
lightning-extension (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned
Natty
Undecided
Micah Gersten
thunderbird (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Micah Gersten
Natty
Undecided
Micah Gersten

Bug Description

This is the tracking but for the Thunderbird stable release migration.

hardy/karmic -> lucid upgrades tracked in Bug #980367

Micah Gersten (micahg) on 2012-04-03
Changed in thunderbird (Ubuntu):
status: New → Invalid
Changed in thunderbird (Ubuntu Lucid):
status: New → In Progress
Changed in thunderbird (Ubuntu Natty):
status: New → In Progress
Changed in thunderbird (Ubuntu Lucid):
assignee: nobody → Micah Gersten (micahg)
Changed in thunderbird (Ubuntu Natty):
assignee: nobody → Micah Gersten (micahg)
Micah Gersten (micahg) on 2012-04-12
Changed in enigmail (Ubuntu Lucid):
status: New → In Progress
Changed in enigmail (Ubuntu Natty):
status: New → In Progress
Changed in enigmail (Ubuntu Lucid):
assignee: nobody → Micah Gersten (micahg)
Changed in enigmail (Ubuntu Natty):
assignee: nobody → Micah Gersten (micahg)
Changed in lightning-extension (Ubuntu Natty):
status: New → In Progress
Changed in lightning-extension (Ubuntu):
status: New → Invalid
Changed in lightning-extension (Ubuntu Lucid):
status: New → Invalid
Changed in enigmail (Ubuntu):
status: New → Invalid
Changed in lightning-extension (Ubuntu Natty):
assignee: nobody → Micah Gersten (micahg)
Micah Gersten (micahg) on 2012-04-12
description: updated
Micah Gersten (micahg) wrote :

The following packages are now in natty-proposed for extended testing:
thunderbird 11.0.1
enigmail 1.4
lightning-extension 1.3

The following packages are now in lucid-proposed for extended testing:
thunderbird 11.0.1
enigmail 1.4

Please see the following document on how to enable the proposed repository if you'd like to help test:
https://wiki.ubuntu.com/Testing/EnableProposed

These packages should migrate to the updates repository early next week with Thunderbird 12 as a security update following later.

Changed in enigmail (Ubuntu Lucid):
status: In Progress → Fix Committed
Changed in enigmail (Ubuntu Natty):
status: In Progress → Fix Committed
Changed in lightning-extension (Ubuntu Natty):
status: In Progress → Fix Committed
Changed in thunderbird (Ubuntu Lucid):
status: In Progress → Fix Committed
Changed in thunderbird (Ubuntu Natty):
status: In Progress → Fix Committed

Thank you for providing us this upgrade. One question though: it seems that v11 is not ESR; does that mean you will have to plan a new upgrade every 6 weeks or could we expect each version to be supported a bit longer than the "rapid release" cycle ?

Micah Gersten (micahg) wrote :

Yes, Thunderbird will follow the same cycle as Firefox to reduce the maintenance burden, build patches can be shared. We will be upgrading every 6 weeks. Most of the reasons for choosing Firefox rapid release apply to Thunderbird as well.

Micah Gersten (micahg) wrote :

Tested lucid i386 and amd64, no apparent regressions over Thunderbird 3.1.x, this update only goes to lucid-updates, Thunderbird 12 will be the next update in lucid-security

tags: added: security-verification verification-done-lucid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package enigmail - 2:1.4-0ubuntu0.10.04.1

---------------
enigmail (2:1.4-0ubuntu0.10.04.1) lucid-proposed; urgency=low

  * New upstream release v1.4 (LP: #972840)
  * Make sure we remove the .bzr folder from the tarball when we build it
    - update debian/rules
  * Build with Latest Thunderbird SDK
    - update debian/rules
  * Add a proper get-orig-source target which pulls the build system from
    lp:~mozillateam/mozilla-build-system/beta, now that we don't have the old
    build-system.tar.gz from xulrunner
  * Build with --disable-elf-hack - it's broken on oneiric, and is a no-op
    on Ubuntu anyway
    - update debian/rules
  * Drop the nspr build-dep and don't build with --with-system-nspr.
    Thunderbird provides this already, and avoids needing to bump nspr
    on older releases just to build enigmail
    - update debian/rules
    - update debian/control
  * Add build/unix/elfhack/Makefile to debian/clean. It doesn't get cleaned
    by the build system, and there is a copy in the tree already which
    breaks the build
    - update debian/clean
  * Build with --disable-webm and --disable-libjpeg-turbo so we don't need to
    build-depend on yasm. I really do need to clean all of this useless
    junk out of the configure script
    - update debian/rules
  * Remove build/pgo/profileserver.py from debian/clean. The new build
    system has a target depending on this
    - update debian/clean
  * Drop debian/patches/autoconf.diff, just generate this at build time
  * libipc seems to be renamed to libipc-pipe. Fix genxpi and chrome.manifest
    to fix this
    - add debian/patches/ipc-pipe_rename.diff
    - update debian/patches/series
  * The makefiles in extensions/enigmail/ipc have an incorrect DEPTH
    attribute. Fix this so that they can find the rest of the build system
    - add debian/patches/makefile_depth.diff
    - update debian/patches/series
  * Drop debian/patches/makefile-in-empty-xpcom-fix.diff - fixed in the
    current version
  * Bump thunderbird-dev dependency to >= 5.0~b1
    - update debian/control
  * Run autoconf2.13 at build time
    - update debian/rules
    - update debian/control
  * Add useless mesa-common-dev build-dep, just to satisfy the build system.
    We should just patch this out entirely really, but that's for another upload
    - update debian/control
 -- Chris Coulson <email address hidden> Tue, 17 Apr 2012 03:05:21 -0500

Changed in enigmail (Ubuntu Lucid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (13.6 KiB)

This bug was fixed in the package thunderbird - 11.0.1+build1-0ubuntu0.10.04.1

---------------
thunderbird (11.0.1+build1-0ubuntu0.10.04.1) lucid-proposed; urgency=low

  * New upstream stable release (THUNDERBIRD_11_0_1_BUILD1) (LP: #972840)

  [ Chris Coulson <email address hidden> ]
  * Ensure we include locales in the tarball if they are in shipped-locales
    but not in all-locales
    - update debian/build/create-tarball.py
  * Always set the update channel - not setting it at build-time on release
    builds breaks the extensions.checkCompatibility pref. The only things
    using it at runtime are nsBlocklistService, Test Pilot (beta + aurora)
    and the about dialog (where the channel is hidden anyway)
    - update debian/rules
    - update debian/thunderbird.install.in
  * Fix LP: #898883 - IPC xpcshell tests hang the buildd's. Give all
    xpcshell tests an X display, as plugin-container won't work without one
    - update debian/build/testsuite.mk
  * Turn on all IPC xpcshell tests again (only applicable when the testsuite
    is enabled in the future)
    - update debian/build/testsute.mk
  * Drop the default-apps xml file
    - remove debian/thunderbird.xml
    - update debian/thunderbird-gnome-support.install.in
    - update debian/rules
  * Fix LP: #918763 - Revert the temporary investigation patch for
    bmo: #621446, as it breaks GCC4.4
    - add debian/patches/revert-bmo621446-investigation.patch
    - update debian/patches/series
  * Fix LP: #915895 - Just set autoDisableScopes to 0. Other distributions
    are already doing this, and we already made this feature pretty much
    useless by allowing extensions in the application directory, so that our
    language packs aren't disabled by default
    - update debian/vendor.js
  * Fix LP: #926495 - Add patch based on one from bmo: #691898 to enable
    building on ppc again
    - add debian/patches/fix-build-failure-without-yarr-jit.patch
    - update debian/patches/series
  * Fix LP: #926495 - Disable the SPS profiler on unsupported architectures
    - add debian/patches/no-sps-profiler-on-unsupported-archs.patch
    - update debian/patches/series
  * Disable more hanging IPC xpcshell tests
    - update debian/build/testsuite.mk
  * Update after landing of bmo: #701875 - Rename omni.jar to omni.ja
    - update debian/thunderbird.install.in
  * Update shipped locales (addition of Asturian and Serbian)
    - refresh debian/config/locales.all
    - refresh debian/config/locales.shipped
    - refresh debian/control
  * Backport changes to allow per-release/par-arch patches
    - add debian/build/enable-dist-patches.pl
    - update debian/rules
  * Don't unconditionally overwrite SourcePackage when reporting bugs with
    the nightly apport hook
    - update debian/apport/source_thunderbird.py.in
  * Set "Channel = Unavailable" if channel-prefs.js doesn't contain a
    channel name
    - update debian/apport/source_thunderbird.py.in
  * Ensure that create-tarball can handle there not being a locale blacklist
    - update debian/build/create-tarball.py
  * Use makedirs to create the local cache directory
    - update debian/build-create-tarball.py
  * Drop xpidl from $LI...

Changed in thunderbird (Ubuntu Lucid):
status: Fix Committed → Fix Released
Micah Gersten (micahg) wrote :

Tested natty i386 and amd64, no apparent regressions over Thunderbird 3.1.x, this update only goes to natty-updates, Thunderbird 12 will be the next update in natty-security

tags: added: verification-done-natty
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package enigmail - 2:1.4-0ubuntu0.11.04.1

---------------
enigmail (2:1.4-0ubuntu0.11.04.1) natty-proposed; urgency=low

  * New upstream release v1.4 (LP: #972840)

  * Make sure we remove the .bzr folder from the tarball when we build it
    - update debian/rules
  * Actually add the get-orig-source target..
  * Build with Latest Thunderbird SDK
    - update debian/rules
  * Add a proper get-orig-source target which pulls the build system from
    lp:~mozillateam/mozilla-build-system/beta, now that we don't have the old
    build-system.tar.gz from xulrunner
  * Drop build_system_dont_link_libxul.diff - this isn't needed in current
    Thunderbird versions, as it ships a libxul.so
  * Drop the nspr build-dep and don't build with --with-system-nspr.
    Thunderbird provides this already, and avoids needing to bump nspr
    on older releases just to build enigmail
    - update debian/rules
    - update debian/control
  * Add build/unix/elfhack/Makefile to debian/clean. It doesn't get cleaned
    by the build system, and there is a copy in the tree already which
    breaks the build
    - update debian/clean
  * Build with --disable-webm and --disable-libjpeg-turbo so we don't need to
    build-depend on yasm. I really do need to clean all of this useless
    junk out of the configure script
    - update debian/rules
  * Remove build/pgo/profileserver.py from debian/clean. The new build
    system has a target depending on this
    - update debian/clean
  * Drop debian/patches/autoconf.diff, just generate this at build time
  * Refresh debian/patches/build_system_dont_link_libxul.diff
  * libipc seems to be renamed to libipc-pipe. Fix genxpi and chrome.manifest
    to fix this
    - add debian/patches/ipc-pipe_rename.diff
    - update debian/patches/series
  * The makefiles in extensions/enigmail/ipc have an incorrect DEPTH
    attribute. Fix this so that they can find the rest of the build system
    - add debian/patches/makefile_depth.diff
    - update debian/patches/series
  * Drop debian/patches/makefile-in-empty-xpcom-fix.diff - fixed in the
    current version
  * Don't register a class ID multiple times, as this breaks enigmail entirely
    - add debian/patches/dont_register_cids_multiple_times.diff
    - update debian/patches/series
  * Run autoconf2.13 at build time
    - update debian/rules
    - update debian/control
  * Add useless mesa-common-dev build-dep, just to satisfy the build system.
    We should just patch this out entirely really, but that's for another upload
    - update debian/control
 -- Chris Coulson <email address hidden> Tue, 17 Apr 2012 01:05:56 -0500

Changed in enigmail (Ubuntu Natty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightning-extension - 1.3+build1-0ubuntu0.11.04.1

---------------
lightning-extension (1.3+build1-0ubuntu0.11.04.1) natty-proposed; urgency=low

  * New upstream stable release (CALENDAR_1_3_BUILD1) (LP: #972840)
  * Add mozilla/mfbt to tarball
  * Refresh debian/patches/01_no_sunbird.patch
  * Add some additional mailnews makefiles to the tarball, to make the build
    system not sad anymore
  * Add the new python IDL parser to the tarball
    - update debian/rules
  * Pull from comm-beta
    - update debian/rules
  * Add db/mork/Makefile.in to the tarball
    - update debian/rules
  * Pass --mozilla-rev to client.py when creating the tarball
    - update debian/rules
  * Include the files containing the mail/suite version numbers in the tarball,
    as they're used to populate the version requirements in the install.rdf
    - update debian/rules
  * Strip everything we don't need out of the tarball (Firefox, Thunderbird,
    Seamonkey), leaving just the calendar and build system. This gets the
    tarball down from 85MB to 6MB, which will make those carrier pigeons
    who carry the bits from my house to the archive much, much happier
    - update debian/rules
    - remove debian/remove-binonly.sh
  * Add a get-orig-source target
  * Build with --disable-tests
    - update debian/rules
  * Fix LP: #809757 - FTBFS on armel. Build with --disable-elf-hack, as it's
    basically a noop on Ubuntu anyway
    - update debian/rules
  * Bump thunderbird-dev build-dep to 5.0~b1
    - update debian/control
  * Build with --disable-webm and --disable-libjpeg-turbo, to avoid needing
    a build-depends on yasm
    - update debian/rules
  * Add useless build-dep on mesa-common-dev, it's mandatory to be able to
    configure lightning, even though it doesn't need it
    - update debian/control
  * Look for any version of the Thunderbird SDK
    - update debian/rules
  * Don't build with --with-system-nspr and --with-system-nss - thunderbird
    doesn't use these, so we just get everything from the SDK
    - update debian/rules
  * Build with --enable-chrome-format=jar. The calendar build.mk should
    probably specify a default here
    - update debian/rules
  * Build with --enable-libxul to force JS_SHARED_LIBRARY=0 and stop some
    makefile targets depending on a shared libmozjs
    - update debian/rules
 -- Chris Coulson <email address hidden> Tue, 17 Apr 2012 02:48:27 -0500

Changed in lightning-extension (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions