[needs-packaging] [upgrade] Thunderbird 11.0 : critical freeze in Imap folder switching

Bug #971578 reported by Xavier Guillot on 2012-04-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
thunderbird (Ubuntu)
Undecided
Unassigned

Bug Description

Hello,

On Ubuntu Precise beta 2, with default mail client Thunderbird 11 and an imap account, I get regular crashes : it happens when I select with the mouse another mail folder than the one I'm reading.

It occurs only sometimes, not every time I change folder, but the crash always happens when I select a folder, no other action makes it freeze. Window becomes gray, and I get an error message to "force quit" Thunderbird.

Then Thunderbird closes and I can restart it. I get no crash log report suggestion, perhaps there is a file that I can look. ALso no specific explanation if I run Thunderbird with the terminal and reproduces the crash.

It's a known and fixed bug by Mozilla :

https://bugzilla.mozilla.org/show_bug.cgi?id=733731
https://getsatisfaction.com/mozilla_messaging/topics/problems_with_mozilla_11_0

Problem has been solved with a 11.0.1 version of Thunderbird.

For the moment it is not in Precise repositories, perhaps it's in building. If not, it is very important to upgrade it : 12.04 is a LTS version and Thunderbird is the default mail program !

Thanks in advance.

Changed in thunderbird (Ubuntu):
status: New → Confirmed
Chris Coulson (chrisccoulson) wrote :

There really is no need to report bugs like this at all for either Thunderbird or Firefox

Xavier Guillot (valeryan-24) wrote :

Why ? I've seen nowhere a duplicate and, in case the 11.0.1 mozilla update was missed, it was important to report it, no ? We are in beta 2 stage, all critical bugs should be filled.

Or is there a specific way for Firefox and Thunderbird ?

Chris Coulson (chrisccoulson) wrote :

No, I'm well aware of new releases and don't need people to report bugs to remind me to do them. I haven't done it yet because it doesn't justify an upload on its own and I've got other things I need to do with it as well. There are already other bugs on Launchpad describing the actual bug, so there was no need to create this one at all

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunderbird - 11.0.1+build1-0ubuntu1

---------------
thunderbird (11.0.1+build1-0ubuntu1) precise; urgency=low

  * New upstream stable release (THUNDERBIRD_11_0_1_BUILD1)
    - Fixes LP: #962631, LP: #971578

  * Update globalmenu-extension to 3.1
    - Reduce our memory footprint a bit, which wasn't really a lot anyway
    - Avoid the use of the component manager for accessing commonly used
      services, where "commonly used" means "accessed when building every
      menu item". This should save some CPU cycles when building or
      refreshing menus
    - Try to recycle menuitems when they are removed from a menu by
      adding contiguous blocks of removed items to a "free list" which
      is emptied asynchronously, and reusing the items in this list when
      new items are added in place of the removed items. This means that
      menus which fully refresh on opening no longer alter the menu
      structure, but instead just update properties on existing nodes.
      This has a few benefits:
      + With no layout changes, unity-panel-service doesn't request
        the entire menu structure, which significantly reduces dbus traffic
        and makes it much faster to refresh the menu contents
      + The size of the menu doesn't change when it is refreshed, which
        eliminates the flicker that used to occur when opening some menus
      + The HUD can refresh our menus now without triggering layout updates
        (assuming that menu layout really hasn't changed)
    - Remove all use of the global observer service for sending our own
      internal notifications around
    - Get rid of a static initializer
    - Don't support older than Thunderbird 11
    - Fix some GError leaks
    - Hide the internal menu when creating a native menu, rather than
      waiting for confirmation that the native menu is registered
      successfully. We don't try to create a native menu if we don't
      find a menu service to register the menu with anyway
    - Keep menu contents updated whilst the menu is open, rather than
      just whilst it is opening
 -- Chris Coulson <email address hidden> Mon, 02 Apr 2012 17:52:31 +0100

Changed in thunderbird (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers