Thunderbird 11 imap connections hang

Bug #962631 reported by Blair Zajac on 2012-03-22
42
This bug affects 9 people
Affects Status Importance Assigned to Milestone
thunderbird (Ubuntu)
Undecided
Unassigned
Oneiric
Medium
Micah Gersten

Bug Description

Link to upstream release notes: http://www.mozilla.org/en-US/thunderbird/11.0.1/releasenotes/

After upgrading to Thunderbird 11 I experience frequent hangs of Thunderbird. I'm using IMAP. Here is an strace and stacktrace:

$ strace -p 3046
Process 3046 attached - interrupt to quit
futex(0x7f00ba56d0e8, FUTEX_WAIT_PRIVATE, 2, NULL

$ gdb -p 3046

#0 0x00007f00bb3f0be4 in __lll_lock_wait ()
   from /lib/x86_64-linux-gnu/libpthread.so.0
#1 0x00007f00bb3ec21b in _L_lock_1031 ()
   from /lib/x86_64-linux-gnu/libpthread.so.0
#2 0x00007f00bb3ec19c in pthread_mutex_lock ()
   from /lib/x86_64-linux-gnu/libpthread.so.0
#3 0x00007f00b60e45a9 in PR_Lock (lock=0x7f00ba56d0e8)
    at /build/buildd/thunderbird-11.0+build1/build-tree/mozilla/mozilla/nsprpub/pr/src/pthreads/ptsynch.c:206
#4 0x00007f00b60e4bc5 in PR_EnterMonitor (mon=0x7f00ba56d0e0)
    at /build/buildd/thunderbird-11.0+build1/build-tree/mozilla/mozilla/nsprpub/pr/src/pthreads/ptsynch.c:561
#5 0x00007f00b60d53c1 in PR_CEnterMonitor (address=<optimized out>)
    at /build/buildd/thunderbird-11.0+build1/build-tree/mozilla/mozilla/nsprpub/pr/src/threads/prcmon.c:380
#6 0x00007f00b9218f96 in nsImapProtocol::PseudoInterruptMsgLoad (
    this=0x7f008b806800, aImapFolder=0x7f009a3a6038, aMsgWindow=0x0,
    interrupted=0x7fff61c43e30)
    at /build/buildd/thunderbird-11.0+build1/build-tree/mozilla/mailnews/imap/src/nsImapProtocol.cpp:1280
#7 0x00007f00b91f2dd9 in nsImapIncomingServer::PseudoInterruptMsgLoad (
    this=0x7f00aac560c0, aImapFolder=0x7f009a3a6038, aMsgWindow=0x0,
    interrupted=0x7fff61c43e30)
    at /build/buildd/thunderbird-11.0+build1/build-tree/mozilla/mailnews/imap/src/nsImapIncomingServer.cpp:2245
#8 0x00007f00b9210fb8 in nsImapMailFolder::DeleteMessages (
    this=0x7f009a3a6000, messages=0x7f009c2ae860, msgWindow=0x0,
    deleteStorage=true, isMove=false, listener=0x0, allowUndo=false)
    at /build/buildd/thunderbird-11.0+build1/build-tree/mozilla/mailnews/imap/src/nsImapMailFolder.cpp:2279
#9 0x00007f00b91c8406 in nsMsgComposeSendListener::RemoveCurrentDraftMessage (
    this=0x7f00888e6240, compObj=0x7f0089213250, calledByCopy=false)
    at /build/buildd/thunderbird-11.0+build1/build-tree/mozilla/mailnews/compose/src/nsMsgCompose.cpp:3798
#10 0x00007f00b91d1487 in nsMsgComposeSendListener::OnStopSending (
    this=0x7f00888e6240,
    aMsgID=0x7f008bb8c550 "<email address hidden>", aStatus=0,
    aMsg=0x0, returnFile=0x0)
    at /build/buildd/thunderbird-11.0+build1/build-tree/mozilla/mailnews/compose/src/nsMsgCompose.cpp:3623
#11 0x00007f00b91a3cb0 in nsMsgComposeAndSend::NotifyListenerOnStopSending (
    this=<optimized out>, aMsgID=<optimized out>, aStatus=<optimized out>,
    aMsg=<optimized out>, returnFile=<optimized out>)
    at /build/buildd/thunderbird-11.0+build1/build-tree/mozilla/mailnews/compose/src/nsMsgSend.cpp:3991
#12 0x00007f00b91ab492 in nsMsgComposeAndSend::DoDeliveryExitProcessing (
    this=0x7f009a806e20, aUri=<optimized out>, aExitCode=0,
    aCheckForMail=<optimized out>)
    at /build/buildd/thunderbird-11.0+build1/build-tree/mozilla/mailnews/compose/src/nsMsgSend.cpp:3856
#13 0x00007f00b91ab4c1 in nsMsgComposeAndSend::DeliverAsMailExit (
    this=<optimized out>, aUrl=<optimized out>, aExitCode=<optimized out>)
    at /build/buildd/thunderbird-11.0+build1/build-tree/mozilla/mailnews/compose/src/nsMsgSend.cpp:3876
#14 0x00007f00b91a45db in SendDeliveryCallback (aExitCode=0,
    aUrl=<optimized out>, this=<optimized out>,
    inIsNewsDelivery=<optimized out>)
    at /build/buildd/thunderbird-11.0+build1/build-tree/mozilla/mailnews/compose/src/nsMsgSend.cpp:3437
#15 nsMsgComposeAndSend::SendDeliveryCallback (this=<optimized out>,
    aUrl=<optimized out>, inIsNewsDelivery=<optimized out>,
    aExitCode=<optimized out>)
    at /build/buildd/thunderbird-11.0+build1/build-tree/mozilla/mailnews/compose/src/nsMsgSend.cpp:3397
#16 0x00007f00b91a4238 in MsgDeliveryListener::OnStopRunningUrl (
    this=0x7f0096aa3c40, url=0x7f00896f7be8, aExitCode=0)
    at /build/buildd/thunderbird-11.0+build1/build-tree/mozilla/mailnews/compose/src/nsMsgSend.cpp:277
#17 0x00007f00b9100cba in SetUrlState (aExitCode=0,
    aRunningUrl=<optimized out>, this=0x7f00896f7be8)
    at /build/buildd/thunderbird-11.0+build1/build-tree/mozilla/mailnews/base/util/nsMsgMailNewsUrl.cpp:135
#18 nsMsgMailNewsUrl::SetUrlState (this=0x7f00896f7be8,
    aRunningUrl=<optimized out>, aExitCode=0)
    at /build/buildd/thunderbird-11.0+build1/build-tree/mozilla/mailnews/base/util/nsMsgMailNewsUrl.cpp:109
#19 0x00007f00b91a3b3d in nsSmtpProtocol::ProcessProtocolState (
    this=0x7f008bbe6000, url=<optimized out>, inputStream=0x7f008b15d010,
    sourceOffset=<optimized out>, length=48)
    at /build/buildd/thunderbird-11.0+build1/build-tree/mozilla/mailnews/compose/src/nsSmtpProtocol.cpp:1949
#20 0x00007f00b90fbecf in nsMsgProtocol::OnDataAvailable (this=0x7f008bbe6000,
    request=<optimized out>, ctxt=<optimized out>, inStr=0x7f008b15d010,
    sourceOffset=621, count=<optimized out>)
    at /build/buildd/thunderbird-11.0+build1/build-tree/mozilla/mailnews/base/util/nsMsgProtocol.cpp:389
#21 0x00007f00b87eda63 in nsInputStreamPump::OnStateTransfer (
    this=0x7f009c234860)
    at /build/buildd/thunderbird-11.0+build1/build-tree/mozilla/mozilla/netwerk/base/src/nsInputStreamPump.cpp:512
#22 0x00007f00b87edbcf in nsInputStreamPump::OnInputStreamReady (
    this=0x7f009c234860, stream=<optimized out>)
    at /build/buildd/thunderbird-11.0+build1/build-tree/mozilla/mozilla/netwerk/base/src/nsInputStreamPump.cpp:402
#23 0x00007f00b9398b74 in nsInputStreamReadyEvent::Run (this=<optimized out>)
    at /build/buildd/thunderbird-11.0+build1/build-tree/mozilla/mozilla/xpcom/io/nsStreamUtils.cpp:114
#24 0x00007f00b93a713f in nsThread::ProcessNextEvent (this=0x7f00ba550f50,
    mayWait=false, result=0x7fff61c4445f)
    at /build/buildd/thunderbird-11.0+build1/build-tree/mozilla/mozilla/xpcom/threads/nsThread.cpp:660
#25 0x00007f00b937bebd in NS_ProcessNextEvent_P (thread=<optimized out>,
    mayWait=false)
    at /build/buildd/thunderbird-11.0+build1/build-tree/mozilla/mozilla/obj-x86_64-linux-gnu/mozilla/xpcom/build/nsThreadUtils.cpp:245
#26 0x00007f00b9319d2e in mozilla::ipc::MessagePump::Run (this=0x7f00ad016d40,
    aDelegate=0x7f00ba5d0760)
    at /build/buildd/thunderbird-11.0+build1/build-tree/mozilla/mozilla/ipc/glue/MessagePump.cpp:110
#27 0x00007f00b93c53b1 in RunHandler (this=0x7f00ba5d0760)
    at /build/buildd/thunderbird-11.0+build1/build-tree/mozilla/mozilla/ipc/chromium/src/base/message_loop.cc:201
#28 MessageLoop::Run (this=0x7f00ba5d0760)
    at /build/buildd/thunderbird-11.0+build1/build-tree/mozilla/mozilla/ipc/chromium/src/base/message_loop.cc:175
#29 0x00007f00b9056f76 in nsBaseAppShell::Run (this=0x7f00aad81a90)
    at /build/buildd/thunderbird-11.0+build1/build-tree/mozilla/mozilla/widget/src/xpwidgets/nsBaseAppShell.cpp:189
#30 0x00007f00b8f2a960 in nsAppStartup::Run (this=0x7f00aac6b3d0)
    at /build/buildd/thunderbird-11.0+build1/build-tree/mozilla/mozilla/toolkit/components/startup/nsAppStartup.cpp:220
#31 0x00007f00b87d1168 in XRE_main (argc=<optimized out>,
    argv=<optimized out>, aAppData=<optimized out>)
    at /build/buildd/thunderbird-11.0+build1/build-tree/mozilla/mozilla/toolkit/xre/nsAppRunner.cpp:3519
#32 0x0000000000401c97 in do_main (argv=0x7fff61c45f68, argc=1,
    exePath=0x7fff61c44e58 "/usr/lib/thunderbird-11.0/libxpcom.so")
    at /build/buildd/thunderbird-11.0+build1/build-tree/mozilla/mail/app/nsMailApp.cpp:143
#33 main (argc=1, argv=0x7fff61c45f68)
    at /build/buildd/thunderbird-11.0+build1/build-tree/mozilla/mail/app/nsMailApp.cpp:226

ProblemType: BugDistroRelease: Ubuntu 11.10
Package: thunderbird 11.0+build1-0ubuntu0.11.10.1
ProcVersionSignature: Ubuntu 3.0.0-16.29-generic 3.0.20
Uname: Linux 3.0.0-16-generic x86_64
AddonCompatCheckDisabled: False
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: I82801AAICH [Intel 82801AA-ICH], device 0: Intel ICH [Intel 82801AA-ICH]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: blair 1675 F.... pulseaudio
BuildID: 20120310043956
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'I82801AAICH'/'Intel 82801AA-ICH with STAC9700,83,84 at irq 21'
   Mixer name : 'SigmaTel STAC9700,83,84'
   Components : 'AC97a:83847600'
   Controls : 34
   Simple ctrls : 24
Channel: release
Date: Thu Mar 22 15:46:03 2012
ExecutablePath: /usr/lib/thunderbird-11.0/thunderbird-bin
ForcedLayersAccel: False
IfupdownConfig:
 auto lo
 iface lo inet loopback
IncompatibleExtensions:
 Messaging Menu and Unity Launcher integration - <email address hidden>, Version=0.8.3, minVersion=3.3a1pre, maxVersion=11.0a1, Location=app-global, Type=extension, Active=Yes
 EDS Contact Integration - <email address hidden>, Version=0.3.9, minVersion=7.0, maxVersion=11.0a1, Location=app-global, Type=extension, Active=Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64+mac (20111012)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.

 tun0 no wireless extensions.
Plugins:
 Gnome Shell Integration - Lib=libgnome-shell-browser-plugin.so, Location=/usr/lib/mozilla/plugins
 VLC Multimedia Plugin (compatible Totem 3.0.1) - Lib=libtotem-cone-plugin.so, Location=/usr/lib/mozilla/plugins
 QuickTime Plug-in 7.6.6 - Lib=libtotem-narrowspace-plugin.so, Location=/usr/lib/mozilla/plugins
 Windows Media Player Plug-in 10 (compatible; Totem) - Lib=libtotem-gmp-plugin.so, Location=/usr/lib/mozilla/plugins
 DivX® Web Player - Lib=libtotem-mully-plugin.so, Location=/usr/lib/mozilla/plugins
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Profiles: Profile0 (Default) - LastVersion=11.0/20120310043956 (Running)
RfKill:

RunningIncompatibleAddons: TrueSourcePackage: thunderbird
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/01/2006
dmi.bios.vendor: innotek GmbH
dmi.bios.version: VirtualBox
dmi.modalias: dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:
dmi.product.name: VirtualBox
dmi.product.version: 1.2
dmi.sys.vendor: innotek GmbH

Blair Zajac (blair) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunderbird (Ubuntu):
status: New → Confirmed
che--- (hcguersoy) wrote :

Hi,

I observe the same, accessing my mailbox via IMAP (Davmail), so I assume it's not Exchange specific.

che--- (hcguersoy) wrote :
che--- (hcguersoy) wrote :

My strace & gdb:

$ sudo strace -p 7475
Process 7475 attached - interrupt to quit
futex(0x7f9b18b6d1b8, FUTEX_WAIT_PRIVATE, 2, NULL

....
$ sudo gdb -p 7475
0x00007f9b199a6be4 in __lll_lock_wait ()
   from /lib/x86_64-linux-gnu/libpthread.so.0

che--- (hcguersoy) wrote :

And an update here:

https://bugzilla.mozilla.org/show_bug.cgi?id=733731

Seems to be fixed in TB12 but may do it into TB11.01.

Micah Gersten (micahg) wrote :

Could someone please test thunderbird 11.0.1 from ppa:ubuntu-mozilla-security/ppa? I believe this will fix the issue.

Pushkin (kovshovik-alexandr) wrote :

I've tested it - it works fine. The problem with IMAP folder switching went away. Please release the bugfix as an official Ubuntu update...

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunderbird - 11.0.1+build1-0ubuntu1

---------------
thunderbird (11.0.1+build1-0ubuntu1) precise; urgency=low

  * New upstream stable release (THUNDERBIRD_11_0_1_BUILD1)
    - Fixes LP: #962631, LP: #971578

  * Update globalmenu-extension to 3.1
    - Reduce our memory footprint a bit, which wasn't really a lot anyway
    - Avoid the use of the component manager for accessing commonly used
      services, where "commonly used" means "accessed when building every
      menu item". This should save some CPU cycles when building or
      refreshing menus
    - Try to recycle menuitems when they are removed from a menu by
      adding contiguous blocks of removed items to a "free list" which
      is emptied asynchronously, and reusing the items in this list when
      new items are added in place of the removed items. This means that
      menus which fully refresh on opening no longer alter the menu
      structure, but instead just update properties on existing nodes.
      This has a few benefits:
      + With no layout changes, unity-panel-service doesn't request
        the entire menu structure, which significantly reduces dbus traffic
        and makes it much faster to refresh the menu contents
      + The size of the menu doesn't change when it is refreshed, which
        eliminates the flicker that used to occur when opening some menus
      + The HUD can refresh our menus now without triggering layout updates
        (assuming that menu layout really hasn't changed)
    - Remove all use of the global observer service for sending our own
      internal notifications around
    - Get rid of a static initializer
    - Don't support older than Thunderbird 11
    - Fix some GError leaks
    - Hide the internal menu when creating a native menu, rather than
      waiting for confirmation that the native menu is registered
      successfully. We don't try to create a native menu if we don't
      find a menu service to register the menu with anyway
    - Keep menu contents updated whilst the menu is open, rather than
      just whilst it is opening
 -- Chris Coulson <email address hidden> Mon, 02 Apr 2012 17:52:31 +0100

Changed in thunderbird (Ubuntu):
status: Confirmed → Fix Released
Micah Gersten (micahg) on 2012-04-02
Changed in thunderbird (Ubuntu Oneiric):
assignee: nobody → Micah Gersten (micahg)
importance: Undecided → Medium
status: New → Confirmed
tags: added: regression-update
removed: release-channel
Micah Gersten (micahg) wrote :

Updated packages are in oneiric-security now (11.0.1+build1-0ubuntu0.11.10.1)

Changed in thunderbird (Ubuntu Oneiric):
status: Confirmed → Fix Released
description: updated
summary: - Thunderbird 11 hangs against Exchange 2007
+ Thunderbird 11 imap connections hang
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.