Lack of support for default browser in the KDE environment when opening HTTP links

Bug #884135 reported by Pho3nix on 2011-10-31
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
thunderbird (Ubuntu)
Wishlist
Unassigned

Bug Description

[Note: the original description is under the five dashes, below. What follows is a reformatted bug description that follows the format described at <https://wiki.ubuntu.com/MozillaTeam/NormalizedBugFormat>.]

Summary: Lack of support for default browser in the KDE environment when opening HTTP links

Steps to reproduce:
  1. Make sure that you are working in the KDE environment and that at least one browser is installed into the system. (I don't know if the bug can be reproduced if both the KDE and GNOME environments are installed, but it definitely is reproducible if only the KDE system is present).
  2. Open Thunderbird. If you are starting with a fresh profile, ignore the request to set up a new account by closing the window.
  3. Open the Preferences dialog (Edit->Preferences), switch to the Attachments tab and make sure that no application is listed for HTTP links. Close the dialog.
  4. Open an e-mail message containing an HTTP link (go to File->Open->Saved Message and choose a saved e-mail message or, if a message containing a link is present in the Inbox, use that as well). For the testers' convenience, I have attached one to this report (see [1]). If you are prompted to create a new account (as no one exists), skip it.
  5. Click the link.

Expected Result:
 The "Choose application" window appears, presenting a list of installed browsers or offering to open the link with the default browser.

Actual Result:
 The "Choose application" window appears, offering only the choice to select an application's binary file (see attached screenshot, [2]). No installed browsers are listed nor is the default browser offered as a choice.

References:
 1. https://bugs.launchpad.net/ubuntu/+source/thunderbird/+bug/884135/+attachment/2585570/+files/LinkTest.eml / E-mail message containing a link
 2. https://bugs.launchpad.net/ubuntu/+source/thunderbird/+bug/884135/+attachment/2585580/+files/ChooseAppScreenshot.png / Screenshot showing the actual result

This kind of support is already offered by Thunderbird in GNOME (through the thunderbird-gnome-support package).

I have reproduced the issue on a clean Thunderbird profile, with the English Language Pack and the Addon Compatibility Reporter, Lightning and Enigmail extensions installed.
-----
When I click on the links the website does not open, but there is a window, where I can choose the browser. But there a no browsers shown at all, so I cannot really chose one. I installed firefox and rekonq is already installed. But it does not work anyway or at least shows the browsers to choose.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: thunderbird 7.0.1+build1+nobinonly-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
AddonCompatCheckDisabled: False
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu3
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: philipp 1576 F.... pulseaudio
BuildID: 20110929181644
CRDA: Error: [Errno 2] Datei oder Verzeichnis nicht gefunden
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfe6dc000 irq 50'
   Mixer name : 'Analog Devices AD1984A'
   Components : 'HDA:11d4194a,1028027f,00100400'
   Controls : 34
   Simple ctrls : 20
Channel: release
CurrentDmesg:
 [ 15.887138] init: plymouth-stop pre-start process (1090) terminated with status 1
 [ 16.320861] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx/Tx
 [ 16.320996] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
 [ 24.236494] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,commit=0
 [ 26.808009] eth0: no IPv6 routers present
Date: Mon Oct 31 10:45:40 2011
ForcedLayersAccel: False
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Kubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
IpRoute:
 default via 134.91.37.1 dev eth0 proto static
 134.91.37.0/24 dev eth0 proto kernel scope link src 134.91.37.167 metric 1
 169.254.0.0/16 dev eth0 scope link metric 1000
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
Plugins:
 Shockwave Flash - Lib=libflashplayer.so, Location=/usr/lib/flashplugin-installer
 Skype Buttons for Kopete - Lib=skypebuttons.so, Location=/usr/lib/mozilla/plugins
ProcEnviron:
 LANGUAGE=
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
Profiles: Profile0 (Default) - LastVersion=7.0.1/20110929181644 (Running)
RfKill:

RunningIncompatibleAddons: False
SourcePackage: thunderbird
UpgradeStatus: No upgrade log present (probably fresh install)
UserJS:
 network.protocol-handler.app.ftp - /usr/bin/firefox
 network.protocol-handler.app.https - /usr/bin/firefox
 network.protocol-handler.app.http - /usr/bin/firefox
WifiSyslog:

dmi.bios.date: 04/29/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A03
dmi.board.name: 0M858N
dmi.board.vendor: Dell Inc.
dmi.board.version: A01
dmi.chassis.type: 6
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA03:bd04/29/2009:svnDellInc.:pnOptiPlex760:pvr:rvnDellInc.:rn0M858N:rvrA01:cvnDellInc.:ct6:cvr:
dmi.product.name: OptiPlex 760
dmi.sys.vendor: Dell Inc.

Pho3nix (philipp89) wrote :
Alessandro Menti (elgaton) wrote :

Hi, thanks for reporting.

In the window where you can choose the browser, have you tried clicking on the "Choose" button and then choosing the executable file for your browser (like "/usr/bin/firefox" if you want the link to be opened with Firefox)?

Changed in thunderbird (Ubuntu):
status: New → Incomplete
Pho3nix (philipp89) wrote :

Yeah, that worked.

Should be somewhat clearer where to find the programs... Isn't it possible to implement this list (probably not as it is the one of KDE?!)

Alessandro Menti (elgaton) wrote :

I have searched the Launchpad bug tracker, seems that the list has already been implemented in GNOME (package thunderbird-gnome-support) but not in KDE.

I have changed the title and description of this bug report so that it matches the format used by the Ubuntu Mozilla team, as well as confirming the bug (I have reproduced it myself and am attaching a test case below).

Thanks for your input!

Changed in thunderbird (Ubuntu):
status: Incomplete → Confirmed
Alessandro Menti (elgaton) wrote :

Simple e-mail containing a link. May be used in the test case contained in the bug description.

Alessandro Menti (elgaton) wrote :

Screenshot of the "Choose Application" window. No browsers are listed even though two of them (rekonq and Firefox) are installed.

description: updated
summary: - thunderbird does not open any links
+ Lack of support for default browser in the KDE environment when opening
+ HTTP links
Dave Gilbert (ubuntu-treblig) wrote :

Wishlist suggested by Elgaton; seems reasonable.

Changed in thunderbird (Ubuntu):
importance: Undecided → Wishlist
Changed in thunderbird (Ubuntu):
status: Confirmed → Triaged
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers