Messaging menu support not working

Bug #863003 reported by Jono Bacon on 2011-09-30
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
thunderbird (Ubuntu)
Low
Unassigned

Bug Description

While Thunderbird has an entry in the Messaging Menu with Compose New Message and Contacts sub-items, the number of messages is not shown there as was shown with Evolution.

I also seem to a 'Messaging Menu and Unity Launcher Integration' add-in at v0.7.3 which is disabled because it is incompatible with TB 7.0.1.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: thunderbird 7.0.1+build1+nobinonly-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
AddonCompatCheckDisabled: False
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu2
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: jono 10210 F.... pulseaudio
 /dev/snd/controlC0: jono 10210 F.... pulseaudio
 /dev/snd/pcmC0D0p: jono 10210 F...m pulseaudio
BuildID: 20110929181644
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfc020000 irq 47'
   Mixer name : 'Conexant CX20561 (Hermosa)'
   Components : 'HDA:14f15051,17aa211c,00100000'
   Controls : 17
   Simple ctrls : 9
Card1.Amixer.info:
 Card hw:1 'Headset'/'Logitech Logitech USB Headset at usb-0000:00:1a.0-1, full speed'
   Mixer name : 'USB Mixer'
   Components : 'USB046d:0a0b'
   Controls : 6
   Simple ctrls : 2
Card2.Amixer.info:
 Card hw:2 'U0x46d0x825'/'USB Device 0x46d:0x825 at usb-0000:00:1d.7-1.4.4, high speed'
   Mixer name : 'USB Mixer'
   Components : 'USB046d:0825'
   Controls : 2
   Simple ctrls : 1
Card2.Amixer.values:
 Simple mixer control 'Mic',0
   Capabilities: cvolume cvolume-joined cswitch cswitch-joined penum
   Capture channels: Mono
   Limits: Capture 0 - 6144
   Mono: Capture 2843 [46%] [17.10dB] [off]
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw 7VHT16WW-1.06'
   Mixer name : 'ThinkPad EC 7VHT16WW-1.06'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Channel: release
Date: Thu Sep 29 22:30:44 2011
ForcedLayersAccel: False
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202)
IpRoute:
 default via 192.168.1.254 dev wlan0 proto static
 169.254.0.0/16 dev wlan0 scope link metric 1000
 192.168.1.0/24 dev wlan0 proto kernel scope link src 192.168.1.68 metric 2
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Profiles: Profile0 (Default) - LastVersion=7.0.1/20110929181644 (Running)
RunningIncompatibleAddons: False
SourcePackage: thunderbird
UpgradeStatus: Upgraded to oneiric on 2011-07-13 (78 days ago)
dmi.bios.date: 11/26/2009
dmi.bios.vendor: LENOVO
dmi.bios.version: 7UET81WW (3.11 )
dmi.board.name: 7417CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr7UET81WW(3.11):bd11/26/2009:svnLENOVO:pn7417CTO:pvrThinkPadT400:rvnLENOVO:rn7417CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 7417CTO
dmi.product.version: ThinkPad T400
dmi.sys.vendor: LENOVO

Jono Bacon (jonobacon) wrote :
Chris Coulson (chrisccoulson) wrote :

Hi Jono,

It isn't working because you have an old version of the extension installed in your profile. Please use the addon manager to uninstall it, and then it should work again

Changed in thunderbird (Ubuntu):
status: New → Invalid
Jono Bacon (jonobacon) wrote :

I uninstalled it in the 'Messaging Menu and Unity Launcher Integration' add-in at v0.7.3 and restarted TB and even rebooted and I still don't see the number of unread messages shown in the Messaging Menu.

I also don't see unread messages on the TB Launcher icon.

Changed in thunderbird (Ubuntu):
status: Invalid → Confirmed
Mike Conley (mconley) wrote :

Jono:

Now that you've uninstalled the add-on, do you see a similarly named add-on in the add-on manager? If so, what is the version?

-Mike

Jono Bacon (jonobacon) wrote :

I have:

  Messaging Menu and Unity Launcher Integration 0.8
  Unity Launcher Integration 0.4

It is still not working for me.

Chris: "Please use the addon manager to uninstall it, and then it should work again"

How do I do this as there is no Remove button on the Add-on tab in TB for 'Messaging Menu and Unity Launcher Integration v0.8', only a Disable. I also have the 'Global Menu Bar Integration v2.0.1' installed, but there is no 'Unity Launcher Integration' add-on available to me. Do I need this and if so, how do I get it?

BTW I have no unread counts on the TB icon on the launcher at the moment, and on the Messaging menu, I have no TB item only one that says 'Mail' and it does not work.

Update: after re-enabling 'Messaging Menu and Unity Launcher Integration v0.8' and after downloading updates from the repos earlier, this integration is now working, so no worries any more.

Changed in thunderbird (Ubuntu):
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers