Can not open Ubuntu One address book: "book backend is opening"

Bug #841566 reported by Séverin Lemaignan on 2011-09-05
86
This bug affects 18 people
Affects Status Importance Assigned to Milestone
thunderbird (Ubuntu)
Undecided
Unassigned

Bug Description

Thunderbird displayed the following message whenever I interact with my email for something like 5 minutes:

There was a problem opening the address book "Ubuntu One" - the message returned was: Cannot open book: Cannot process, book backend is opening"

I guess that after the 5 min, the "backend" eventually opened...

This bug is similar but probably different from #825280

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: thunderbird 7.0~b1+build1+nobinonly-0ubuntu4
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic i686
AddonCompatCheckDisabled: False
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: skadge 1582 F.... pulseaudio
 /dev/snd/controlC0: skadge 1582 F.... pulseaudio
BuildID: 20110828151035
CRDA: Error: [Errno 2] Aucun fichier ou dossier de ce type
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfe1f8000 irq 47'
   Mixer name : 'Realtek ALC882'
   Components : 'HDA:10ec0882,1043060d,00100101 HDA:14f12bfa,10431126,00090000'
   Controls : 33
   Simple ctrls : 20
Card1.Amixer.info:
 Card hw:1 'SAA7134'/'saa7133[0] at 0xfd5ff800 irq 19'
   Mixer name : 'SAA7134 Mixer'
   Components : ''
   Controls : 6
   Simple ctrls : 3
Channel: default
Date: Mon Sep 5 07:58:32 2011
ExecutablePath: /usr/lib/thunderbird-7.0/thunderbird-bin
ForcedLayersAccel: False
IfupdownConfig:
 auto lo
 iface lo inet loopback
IncompatibleExtensions: German Dictionary - <email address hidden>, Version=2.0.2, minVersion=1.9a8pre, maxVersion=2.0.*, Location=app-profile, Type=extension, Active=Yes
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
IpRoute:
 default via 192.168.0.1 dev wlan0 proto static
 169.254.0.0/16 dev wlan0 scope link metric 1000
 192.168.0.0/24 dev wlan0 proto kernel scope link src 192.168.0.11
ProcEnviron:
 LANGUAGE=fr:en
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 LC_MESSAGES=fr_FR.UTF-8
 SHELL=/bin/bash
Profiles: Profile0 (Default) - LastVersion=7.0/20110828151035 (Running)
RunningIncompatibleAddons: True
SourcePackage: thunderbird
UpgradeStatus: Upgraded to oneiric on 2011-09-02 (2 days ago)
dmi.bios.date: 07/27/2006
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 300
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: A7J
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr300:bd07/27/2006:svnASUSTeKComputerInc.:pnA7J:pvr1.0:rvnASUSTeKComputerInc.:rnA7J:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr:
dmi.product.name: A7J
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.

Séverin Lemaignan (skadge) wrote :
Changed in thunderbird (Ubuntu):
status: New → Confirmed
Ian Nicholson (imnichol) wrote :

I've experienced this bug whenever I open thunderbird as well.

Ian Nicholson (imnichol) wrote :

Also, I am not able to access my U1 contact list from thunderbird. The Ubuntu1 program indicates that my files have finished syncing.

Rodrigo Moya (rodrigo-moya) wrote :

This might be caused by evo-couchdb not being able to contact desktopcouch, which can be because of a few reasons. So to help us determine what's the problem, could you please quit thunderbird, and then, on a terminal, run the following:

$ killall -9 e-addressbook-factory
$ export COUCHDB_DEBUG_MESSAGES=1
$ /usr/lib/evolution/e-addressbook-factory

then run thunderbird again, and when you see those error messages again, please copy all the output in the terminal and paste it here.

vlc (vlc) wrote :

The same happens here for a Google address book, included by extension "Google Contacts". If I restart e-addressbook-factory with debug information enabled as described above, the message does not occur and I only get the following output:

e-data-server-Message: adding type `EBookBackendFileFactory'
e-data-server-Message: adding type `EBookBackendVCFFactory'
e-data-server-Message: adding type `EBookBackendWebdavFactory'
e-data-server-Message: adding type `EBookBackendLDAPFactory'
e-data-server-Message: adding type `EBookBackendGoogleFactory'
Server is up and running...

vlc (vlc) wrote :

Update to what I wrote a few minutes ago:

(1) The address book content is actually displayed, no matter if the error message was displayed or not.

(2) If I restart e-addressbook-factory without COUCHDB_DEBUG_MESSAGES set, the problem also disappears, i.e.

$ killall -9 e-addressbook-factory
$ /usr/lib/evolution/e-addressbook-factory

Si Dedman (si-dedman) wrote :

same for me with opening address book "Contacts"

To post a comment you must log in.