package thunderbird-locale-si (not installed) failed to install/upgrade: trying to overwrite '/usr/lib/thunderbird-addons/extensions/.xpi', which is also in package thunderbird-locale-pt 1:5.0+build1+nobinonly-0ubuntu4

Bug #807805 reported by abinstudy on 2011-07-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
thunderbird (Ubuntu)
High
Chris Coulson
Oneiric
High
Chris Coulson

Bug Description

thunderbird

ProblemType: Package
DistroRelease: Ubuntu 11.10
Package: thunderbird-locale-si (not installed)
ProcVersionSignature: Ubuntu 3.0-3.4-generic 3.0.0-rc5
Uname: Linux 3.0-3-generic i686
Architecture: i386
Date: Thu Jul 7 10:13:18 2011
ErrorMessage: trying to overwrite '/usr/lib/thunderbird-addons/extensions/.xpi', which is also in package thunderbird-locale-pt 1:5.0+build1+nobinonly-0ubuntu4
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110618)
SourcePackage: thunderbird
Title: package thunderbird-locale-si (not installed) failed to install/upgrade: trying to overwrite '/usr/lib/thunderbird-addons/extensions/.xpi', which is also in package thunderbird-locale-pt 1:5.0+build1+nobinonly-0ubuntu4
UpgradeStatus: Upgraded to oneiric on 2011-07-09 (0 days ago)

abinstudy (abinstudy) wrote :
Changed in thunderbird (Ubuntu Oneiric):
milestone: none → oneiric-alpha-3
importance: Undecided → High
status: New → Triaged
assignee: nobody → Chris Coulson (chrisccoulson)
Changed in thunderbird (Ubuntu Oneiric):
status: Triaged → Fix Committed
Chris Coulson (chrisccoulson) wrote :

Note, this will be fixed in the next beta upload. I also added a check to make sure that this kind of thing will fail the build in future, rather than shipping broken binaries

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunderbird - 6.0~b1+build1+nobinonly-0ubuntu1

---------------
thunderbird (6.0~b1+build1+nobinonly-0ubuntu1) oneiric; urgency=low

  * New upstream release from the beta channel (THUNDERBIRD_6_0b1_BUILD1)

  * Switch to beta
    - update debian/rules
    - update debian/mozclient/thunderbird.conf
  * Update messagingmenu-extension to r58
    - Fixes a bug which causes an exception to be thrown in the default
      install, preventing it from working correctly
  * Drop the profile migrator, as it doesn't really make any sense with the new
    release cycle. Instead, just copy the thunderbird profile (if it exists) to
    thunderbird-trunk (if it doesn't exist)
    - remove debian/migrator/xulapp-profilemigrator
    - update debian/thunderbird.sh.in
    - update debian/thunderbird.install.in
    - update debian/rules
    - update debian/control.in
  * Drop patches fixed upstream:
    - remove debian/patches/fix-nsGIOService.patch
    - remove debian/patches/add-uri-handler-methods-to-nsIGIOService.patch
    - remove debian/patches/default-uri-handler-check-use-gio.patch
    - remove debian/patches/powerpc-build-fix.patch
    - remove debian/patches/update-assembler-excl-arch-list.patch
    - remove debian/patches/default-mailer-check-use-gio.patch
    - remove debian/patches/stack-overflow-fix.patch
    - update debian/patches/series
  * xpt_link and xpt_dump have been replaced by xpt.py
    - update debian/thunderbird-dev.install.in
    - update debian/thunderbird-dev.links.in
  * Refresh patches
    - update debian/patches/stack-overflow-fix.patch
  * Fix LP: #807805 - invalid language packs created because get-xpi-id.py
    exits with "xml.parsers.expat.ExpatError: XML or text declaration not at
    start of entity" exception when the install.rdf starts with empty lines
    - update debian/get-xpi-id.py
  * Backport patch from aurora to de-RDF the addressbook. Required to support
    the eds contacts integration
    - add debian/patches/addressbook-de-rdf.patch
    - update debian/patches/series
  * Apply patch from b.m.o to fix issues with reentering ctypes function
    callbacks, needed for the eds integration
    - add debian/patches/ctypes-callback-reentry-fix.patch
    - update debian/patches/series
  * Backport patch from aurora to make the addressbook more extendable.
    Required for the eds contacts integration
    - add debian/patches/addressbook-extensibility.patch
    - update debian/patches/series
  * Refresh shipped locales for the current beta
    - refresh debian/locales.shipped and debian/locales.unavail
    - refresh debian/control
 -- Chris Coulson <email address hidden> Wed, 20 Jul 2011 11:13:49 +0100

Changed in thunderbird (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers