Thunderbird with Firetray/MinimizeToTray - Global menu disappears

Bug #775080 reported by Connor Imes on 2011-05-01
62
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Global menubar extension
Low
Unassigned
thunderbird (Ubuntu)
Low
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: thunderbird

Running thunderbird with the Firetray plugin. Clicking the close button in thunderbird does not kill thunderbird but sends it to the background, but Unity thinks the app is closed (the little arrow(s) don't show anymore).
When opening again from Unity, it recognized the app as running, but the menus (File, Edit, etc) fail to show in the top bar when the mouse is brought up there. The only way to get it back is to kill thunderbird and restart it.

Disabling the firetray plugin, which doesn't work with Unity anyway, fixes this problem. However, it would be great to have a tray icon by the session menu.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: thunderbird 3.1.9+nobinonly-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sun May 1 14:44:42 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: thunderbird
UpgradeStatus: No upgrade log present (probably fresh install)

Connor Imes (ckimes) wrote :
Chris Coulson (chrisccoulson) wrote :

Thanks. Any idea what FireTray does? Does it use GTK directly to just unmap the top-level window? If the window is unregistered/registered via nsIAppShellService, then we should recreate the menu there (we are listening for new windows already). However, if it is just using the GTK API directly to unmap the underlying top-level GtkWindow, then I guess we'd need to add a hack to workaround that.

Connor Imes (ckimes) wrote :

Hi Chris, thanks for the quick response. This could be related to bug 769327 as well where the Thunderbird window fails to reappear at all.

I just checked out the FireTray read-only source from Google code - http://code.google.com/p/firetray/
I don't see any mention of nsIAppShellService. It's been quite awhile since I've done any work in C/C++ and I'm not familiar with the GTK APIs. However, it does look like it might be getting the window directly using "gdk_window_get_toplevel(GdkWindow *window)". I also see a function "get_gtkwindow_from_gdkwindow(GdkWindow *win)" but it doesn't look like it's being used.

HTH.

Changed in unity (Ubuntu):
status: New → Invalid
Changed in globalmenu-extension:
milestone: none → 2.0
status: New → Triaged
importance: Undecided → Low
assignee: nobody → Chris Coulson (chrisccoulson)
Changed in thunderbird (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Conscious User (conscioususer) wrote :

The bug is not exclusive to FireTray, I'm also having it with the "MinimizeToTray Revived" extension:

https://tn123.org/mintrayr/

Aurélien Gâteau (agateau) wrote :

Assuming this is the same problem as https://bugs.launchpad.net/appmenu-qt/+bug/775278 , this bug happens because when the window goes to the tray, bamf says it has closed => after 5 seconds indicator-appmenu forgets about the association between the window and its menubar => no menubar after restoring the window.

The solution I applied in appmenu-qt is to register the window again when the window is brought back.

Vasco Alves (vascofalves) wrote :

Why does this have low priority? It really is an horrible bug that can affect really one's workflow..

summary: - Thunderbird with Firetray - menu in Unity top bar disappears
+ Thunderbird with Firetray/MinimizeToTray - Global menu disappears
Chris Coulson (chrisccoulson) wrote :

It is low priority because it doesn't break an important piece of functionality in anything we ship. Yes, it makes a third party addon not work correctly but we've only had 2 bug reports for this in 1 year, so it's not affecting many people at all.

I'm willing to accept a patch to fix it, but it's not something I'm going to be spending any time on just yet.

Hendrik Knackstedt (hennekn) wrote :

Is somebody able to adapt the patch from agateu?

Chris Coulson (chrisccoulson) wrote :

I don't see a patch?

Hendrik Knackstedt (hennekn) wrote :

He said he wrote one for appmenu-qt in comment #5.

Chris Coulson (chrisccoulson) wrote :

Well, appmenu-qt != globalmenu-extension. They are 2 completely different pieces of code and there isn't much chance of them being adapted ;)

Is anyone interested in working on this? I'd be happy to give some guidance to anyone who wanted to work on it

Dave Vree (hdave) wrote :

I can confirm this with the "MinimizeToTray Revived" add-on as well. One workaround I found for this is to use HUD to access menu items. Tap "Alt" once and then enter a few characters...it works well.

Changed in globalmenu-extension:
assignee: Chris Coulson (chrisccoulson) → nobody
Vasco Alves (vascofalves) wrote :

Getting told to fix it myself if I don't like a bug. I must have accidentally reported this bug to Fedora...

Seriously though, how much money would you need to fix this? I'm sure all the people here can set up a kickstarter thing..

Chris Coulson (chrisccoulson) wrote :
Changed in globalmenu-extension:
milestone: 2.0 → none
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunderbird - 14.0~b3+build1-0ubuntu1

---------------
thunderbird (14.0~b3+build1-0ubuntu1) quantal; urgency=low

  * New upstream release from the beta channel (THUNDERBIRD_14_0b3_BUILD1)

  * Update globalmenu-extension to 3.3 prerelease r369
    - Fix LP: #1010580 - update the window event timestamp when handling
      menu events
    - Fix LP: #775080 - Thunderbird with Firetray/MinimizeToTray -
      Global menu disappears
    - Fix LP: #813775 - Hitting an assertion in dbusmenu
  * Update eds extension to 0.3.10 for new evolution-data-server ABI
    (thanks to Tim Gardner)
  * Update eds dependencies for quantal (LP: #1015723)
 -- Chris Coulson <email address hidden> Wed, 20 Jun 2012 18:21:30 +0100

Changed in thunderbird (Ubuntu):
status: Triaged → Fix Released
Changed in globalmenu-extension:
status: Fix Committed → Fix Released
Vasco Alves (vascofalves) wrote :

Can we not have this backported to Precise?

Greg A (etulfetulf) wrote :

The fix apparently landed in Precise today (thunderbird 15.0+build1-0ubuntu0.12.04.1)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers