no option for thunderbird as default email client

Bug #719919 reported by Mauricio Pretto on 2011-02-16
112
This bug affects 20 people
Affects Status Importance Assigned to Milestone
thunderbird (Ubuntu)
Medium
Chris Coulson
Natty
Medium
Chris Coulson

Bug Description

Binary package hint: gnome-control-center

on preffered applications there is no thunderbird for default email client on natty

affects: gnome-control-center (Ubuntu) → thunderbird (Ubuntu)
Changed in thunderbird (Ubuntu):
importance: Undecided → Low
affects: thunderbird (Ubuntu) → ubuntu
affects: Ubuntu Natty → thunderbird (Ubuntu Natty)
Changed in thunderbird (Ubuntu Natty):
assignee: nobody → Chris Coulson (chrisccoulson)
importance: Low → Medium
status: New → Triaged
Changed in thunderbird (Ubuntu Natty):
milestone: none → ubuntu-11.04-beta-1
Jeremy Bicha (jbicha) wrote :

Chris, I posted a fix for this. Could you take a look at my branch and merge it if it's ready?

Chris Coulson (chrisccoulson) wrote :

Thanks. Yes, it looks fine, although it's only really a partial fix. This won't really work properly unless we:

1) Backport gio support to tbird 3.1
2) Ship my patches from https://bugzilla.mozilla.org/show_bug.cgi?id=611953

Chris Coulson (chrisccoulson) wrote :

Ooh, I just noticed you proposed the merge in to lp:ubuntu/thunderbird. Could you please propose it in to lp:thunderbird/3.1 instead? (that's our packaging vcs)

Jeremy Bicha (jbicha) wrote :

Ok, I proposed the merge in the other merge.

igi (igor-cali) on 2011-04-02
summary: - no option for thunderbird as default email
+ no option for thunderbird as default email client
Changed in thunderbird (Ubuntu Natty):
milestone: ubuntu-11.04-beta-1 → ubuntu-11.04-beta-2
Changed in thunderbird (Ubuntu Natty):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunderbird - 3.1.9+nobinonly-0ubuntu2

---------------
thunderbird (3.1.9+nobinonly-0ubuntu2) natty; urgency=low

  * Update globalmenu-extension code to 0.7
    - Fixes LP: #749440 - Interaction with CuteButtons extension makes
      Thunderbird abort with icons in menus. Work around this by ignoring
      icons greater than 100x100 to avoid DoS'ing unity and dbus-daemon with
      lots of icon data
    - Fixes LP: #734837 - Some menu items are not displayed. Some menuitems
      inherit a label from their command content node rather than having a
      label attribute on the menuitem content node. Make sure we use the
      right label in this case
    - Make the Alt key show the menubar in the panel
    - Drop the hacks we had to workaround the lack of menu closed signals from
      Unity. We no longer synthesize our own menu closed events, but use the
      proper event from dbusmenu.
    - In addition to this, we split the work done during menu opening in to
      2 phases - the first phase triggered off "about-to-show" and the second
      phase triggered off "opened". In the future, we should be able to delay
      the menu opening with the about-to-show handler, which is where we
      do all the work to update the menu

  * Fix LP: #719919 - no option for Thunderbird as default mail client
    - update debian/thunderbird.desktop
  * Disable the default mail client check. This seemed to always be the
    intent, but the wrong preference was being set. We correctly set
    mail.shell.checkDefaultClient to false now. This check doesn't work in
    Natty and isn't going to work unless I get time to backport gio support
    to 3.1
    - update debian/thunderbird.js
 -- Chris Coulson <email address hidden> Thu, 07 Apr 2011 00:08:36 +0100

Changed in thunderbird (Ubuntu Natty):
status: Fix Committed → Fix Released
Mauricio Pretto (pretto) wrote :

Fixed :)

km (km-mathcs) wrote :

I just upgraded from 10.10 to the released version of 11.04. The make thunderbird default popop at thunderbird startup is ineffective and the gnome preferred applications menu only lists evolution. The thunderbird version is

         3.1.10+build1+nobinonly-0ubuntu0.10.10.1

This seems to be later than the one that was declared fixed. Is this a regression?

igi (igor-cali) wrote :

@km: check if package thunderbird-globalmenu is installed; if not install it and confirm is you still have the bug.

Dmitry Murat (dmitry-murat) wrote :

@igi: I have the same issue at natty with thunderbird 3.1.10+build1+nobinonly-0ubuntu0.11.04.1 and thunderbird-globalmenu installed.

@igi: I don't know if it is the the same bug, but I have both thunderbird and thunderbird-globalmenu 3.1.10+build1+nobinonly-0ubuntu0.11.04.1 installed and I can select Thunderbird in Preferred Applications but Natty won't honour my selection. If I exit and restart Preferred Applications, Thunderbird stays selected, but mailing from Libre Office, Draftsight or Firefox starts Evolution.

I'm using Classic Desktop.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.