Thunderbird Crashes When Pasting Text from Openoffice Writer

Bug #574491 reported by Jason Sollom on 2010-05-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
thunderbird (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: thunderbird

Ubuntu version: 9.10 (Karmic Koala)
Package: Thunderbird
Thunderbird version: 2.0.0.24
--------------------------------------------------------------------------------------------
$ apt-cache policy thunderbird
thunderbird:
  Installed: 2.0.0.24+build1+nobinonly-0ubuntu0.9.10.2
  Candidate: 2.0.0.24+build1+nobinonly-0ubuntu0.9.10.2
  Version table:
 *** 2.0.0.24+build1+nobinonly-0ubuntu0.9.10.2 0
        500 http://us.archive.ubuntu.com karmic-updates/main Packages
        500 http://security.ubuntu.com karmic-security/main Packages
        100 /var/lib/dpkg/status
     2.0.0.23+build1+nobinonly-0ubuntu1 0
        500 http://us.archive.ubuntu.com karmic/main Packages
--------------------------------------------------------------------------------------------

What I expected to happen:
I am trying to paste text from Openoffice Writer into a Thunderbird e-mail. I expected to be able to paste the text successfully via one of two methods.
1. Using the ctrl-v short-cut.
2. Highlighting the text in Openoffice Writer and pasting via a middle mouse button click in the Thunderbird e-mail.

What happened instead:
I am trying to paste text from Openoffice Writer into a Thunderbird e-mail. I have tried using both the short-cut Ctrl-V to do the paste as well as simply highlighting the text in OpenOffice and pasting with the middle mouse button. Either attempt causes Thunderbird to hang. After attempting to paste, I can no longer type anything in the e-mail, and the main Thunderbird client is also unresponsive. This hang persists until I close Thunderbird. When I try to close it, I see the customary pop-up box option asking if I want to wait it out or kill it outright. I have tried waiting some more, but that does not solve the problem. Invariably, I end up killing Thunderbird and starting again.

There are no other symptoms. There is no output stating what the problem is.

Unfortunately, this problem is not consistently reproducible. Sometimes, I can successfully paste (via either method) into Thunderbird, but often times I cannot.

This is a high priority problem as being able to paste text into Thunderbird e-mails is very important to its ease of use.

Additional Info:
Openoffice Writer version: 3.1.1

vida (kiki-h) wrote :

I experience a crash of Thunderbird 2.0.0.24 when pasting text (trough middle button or context menu) using Ubuntu 9.04.
I do not know if it is related or not.

I also tried it in safe-mode, but I do get the same effect:
$ /usr/bin/thunderbird -safe-mode
/usr/lib/thunderbird/run-mozilla.sh: line 131: 2408 Segmentation fault "$prog" ${1+"$@"}

It can also happen when copying from and pasting in the same email. I do not need OpenOffice Writer.

$ apt-cache policy thunderbird
thunderbird:
  Installed: 2.0.0.24+build1+nobinonly-0ubuntu0.9.04.1
  Candidate: 2.0.0.24+build1+nobinonly-0ubuntu0.9.04.1
  Version table:
 *** 2.0.0.24+build1+nobinonly-0ubuntu0.9.04.1 0
        500 http://de.archive.ubuntu.com jaunty-updates/main Packages
        500 http://security.ubuntu.com jaunty-security/main Packages
        100 /var/lib/dpkg/status
     2.0.0.21+nobinonly-0ubuntu1.9.04.1 0
        500 http://de.archive.ubuntu.com jaunty/main Packages

vida (kiki-h) wrote :

Several upgrades later with Thunderbird 3.0.10 and Ubuntu 10.04.1 I do not experience this error any more.

gf (gf-interlinks) wrote :

Hello Jason,
Thank you for submitting this bug and reporting a problem with Thunderbird.

You made this bug report in 2010 and there have been several versions of Ubuntu and Thunderbird since then.

Could you confirm that this is no longer a problem and that we can close the ticket?
Or, if it is still a problem, could you run the following (only once):
apport-collect 574491

and upload the updated logs and and any other logs that are relevant for this particular issue.

Thank you again for helping make Ubuntu and Thunderbird better.

G

Changed in thunderbird (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for thunderbird (Ubuntu) because there has been no activity for 60 days.]

Changed in thunderbird (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers