Need per-folder column widths

Bug #56465 reported by Helen King on 2006-08-15
8
Affects Status Importance Assigned to Milestone
Mozilla Thunderbird
Invalid
Wishlist
thunderbird (Ubuntu)
Wishlist
Unassigned

Bug Description

Column display and width is defined across all folders, can not specify one for one folder and another for another. Particularly non-user friendly when looking at requirements from the Sent items vs the Inbox.

In , Mcow (mcow) wrote :

Confirming this because I want this feature too. Specifically, I only want a
Junk column for mail Inbox, Junk and Trash folders; I only want a Read and Flag
column for Inbox and News; and I want 'Sender' and 'Recipient' used for most
Local Folders, but not for Inbox or Sent, etc.

Specific to the original report: There are, in effect, two column
configurations: one for the Sent, Drafts and Templates folders and one for
everything else. However, the differences only apply to the Sender/Recipient
columns: If 'Sender' is shown in Inbox, 'Recipient' will be shown in Sent, and
vice versa. Also, the column widths can vary between the two configurations.

Compare this to bug 234554, which asks for different column configurations only
between Mail and News. I think that solution is insufficient.

Netscape Communicator 4.xx had entries in prefs.js for each folder, box, and
group settings by using CSV to record col and their widths.

FWIW, Mnenhy's FolderStorage does this: <http://mnenhy.mozdev.org/folderstore.html>

In , Mcow (mcow) wrote :

*** Bug 279281 has been marked as a duplicate of this bug. ***

(In reply to comment #3)
> FWIW, Mnenhy's FolderStorage does this:
> <http://mnenhy.mozdev.org/folderstore.html>
>
Nice to know.

I believe this should be a function of the base application as Mike stated in comment #1. The use of an extension for this is a short term work around in my view.

Column display and width is defined across all folders, can not specify one for one folder and another for another. Particularly non-user friendly when looking at requirements from the Sent items vs the Inbox.

Carthik Sharma (carthik) wrote :

Thanks for the bug report.

Changed in mozilla-thunderbird:
importance: Untriaged → Wishlist
status: Unconfirmed → Confirmed
Changed in thunderbird:
status: Unknown → Confirmed

Assigned to Mozilla Team

Changed in mozilla-thunderbird:
assignee: nobody → mozilla-bugs

*** Bug 413970 has been marked as a duplicate of this bug. ***

nominating wanted-thunderbird3
see rationale comment 1

*** Bug 449365 has been marked as a duplicate of this bug. ***

Micah Gersten (micahg) wrote :

Moved to thunderbird package for TB2+

Changed in thunderbird (Ubuntu):
assignee: Mozilla Bugs (mozilla-bugs) → nobody

Bug 474701 provides groundwork for this functionality in its "folder display layer" patch.

*** Bug 401353 has been marked as a duplicate of this bug. ***

for what i see, one can now select different columns on every folder, at least for imap accounts, on

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.2pre) Gecko/20090727 Shredder/3.0b4pre ID:20090727034746

Right you are, Raoul. This is fixed on trunk, so WORKSFORME.

(In reply to comment #13)
> Right you are, Raoul. This is fixed on trunk, so WORKSFORME.

Shouldn't this RFE be closed as Fixed and annotated with the Bug that landed the new feature.

Also, for the record, the new feature works for News though it is not as flexible as NC4, which provided per-group col setting.

Changed in thunderbird:
status: Confirmed → Invalid
Micah Gersten (micahg) wrote :

This was marked invalid upstream as it already exists in Thunderbird 3. We now will await Thunderbird 3.

Changed in thunderbird (Ubuntu):
status: Confirmed → Triaged
Micah Gersten (micahg) on 2009-12-14
Changed in thunderbird:
milestone: none → 3.0
Launchpad Janitor (janitor) wrote :
Download full text (6.7 KiB)

This bug was fixed in the package thunderbird - 3.0+nobinonly-0ubuntu1

---------------
thunderbird (3.0+nobinonly-0ubuntu1) lucid; urgency=low

  * New Upstream Release 3.0 (THUNDERBIRD_3_0_RELEASE)
    - LP: #50902 - Thunderbird displays useless dialog
    - LP: #52667 - Thunderbird doesn't support RFC-2369
    - LP: #49033 - Doesn't recognize upper case extension (.JPG)
    - LP: #56465 - Per folder column widths
    - LP: #68456 - CTRL-Shift-K bound to 2 functions
    - LP: #79337 - Typo in Server Information for Add Account Wizard
    - LP: #1084 - No scroll on full headers list
    - LP: #62071 - Middle click on scrollbar pastes instead of jumping
    - LP: #119358 - Weak default authentication mode
    - LP: #120672 - No option to empty junk folder with right click
    - LP: #96566 - movemail doesn't work with default privs
    - LP: #122529 - Non-Thunderbird IMAP folders not visible to Thunderbird
    - LP: #241276 - Not able to paste image into thunderbird compose window
    - LP: #244635 - scrollboxes scroll to offset 0 when resized
    - LP: #259387 - "Edit Message as New" broken for eml messages
    - LP: #120281 - Editing a message from the drafts folder leaves line breaks
    - LP: #115484 - Dialogue boxes too large for 1024x768 resolution
    - LP: #320034 - Mail with self referencing headers breaks threading
    - LP: #160794 - shortcuts different in windows and linux
    - LP: #280987 - thunderbird keeps asking a password when working off-line
    - LP: #369150 - Thunderbird splits email addresses with non-ascii characters
                    and a comma in From: field
    - LP: #135066 - Thunderbird doesn't use Ubuntu icon theme
    - LP: #297301 - after authentication error the password is forgotten
    - LP: #487541 - thunderbird-bin crashed with SIGSEGV (AFS filesystem)
    - LP: #485224 - Thunderbird saves double attachment file name endings on
                    FAT32 and NTFS
    - LP: #482496 - When using SCIM ANTHY, autosaving fails, and then get asked
                    about sending in UTF-8

  [ Fabien Tassin <email address hidden> ]
  * Add build-depends on autoconf2.13, autotolls-dev, mozilla-devscripts
    libglib2.0-dev (>= 2.12), libstartup-notification0-dev, libbz2-dev,
    libpixman-1-dev, libdbus-1-dev (>= 1.0.0), libdbus-glib-1-dev (>= 0.60),
    libhal-dev (>= 0.5.8), libasound2-dev, libreadline5-dev | libreadline-dev,
    libkrb5-dev
  * Update build-depends minimums for libx11-dev (>= 2:1.0),
    libgtk2.0-dev (>= 2.12), zlib1g-dev (>= 1:1.2.3), libpng12-dev (>= 1.2.0),
    libjpeg62-dev (>= 6b), libcairo2-dev (>= 0.5.8), libgnome2-dev (>= 2.16),
    libgnomevfs2-dev (>= 1:2.16), libgnomeui-dev (>= 2.16),
    libnss3-dev (>= 3.12.0~1.9b3)
  * Bump standards version to 3.8.0
  * Replace ${Source-Version} by ${binary:Version} in control file
    - update debian/control
  * Bump requirement for system nspr to >= 4.8 since Mozilla bug 492464 landed
  * Bump requirement for system nss to >= 3.12.3 since Mozilla bug 485052 landed
  * Use in-source hunspell when hunspell 1.2 is not available
  * Add conditionnal support for --with-libxul-sdk controlled by
    $(USE_SYSTEM_XUL)
    - update debian/rules
  * Add p...

Read more...

Changed in thunderbird (Ubuntu):
status: Triaged → Fix Released
Changed in thunderbird:
importance: Unknown → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.