ensure that x-www-browser is used if no http handler is found through gnome integration

Bug #543064 reported by Alexander Sack on 2010-03-20
40
This bug affects 5 people
Affects Status Importance Assigned to Milestone
thunderbird (Ubuntu)
Medium
Chris Coulson

Bug Description

Binary package hint: thunderbird

left over from bug 526290

in greates tbird 2.0 package we had global config for http protocol handler set to x-www-browser ... and i think
we also had a patch that protocol handler is used if the gnome integration didnt give any result.

In that way we had a safety net that would bring up some browser even if user setup is otherwise messed up
or if the user uses a desktop environment without gconf.

Alexander Sack (asac) wrote :

regression over tbird 2

Changed in thunderbird (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Chris Coulson (chrisccoulson)
Changed in thunderbird (Ubuntu Lucid):
milestone: none → ubuntu-10.04-beta-2
Martin Pitt (pitti) on 2010-03-26
Changed in thunderbird (Ubuntu Lucid):
importance: High → Medium
Jonathan Davies (jpds) on 2010-03-31
tags: added: regression-potential
Steve Langasek (vorlon) on 2010-04-09
Changed in thunderbird (Ubuntu Lucid):
milestone: ubuntu-10.04-beta-2 → ubuntu-10.04
Xavier Claessens (zdra) wrote :

I have that issue too. When thunderbird is asking for an app to open http/https I gave /usr/bin/xdg-open and now it works nicelly, following GNOME config.

This is an important issue IMO.

Steve Langasek (vorlon) wrote :

Per Chris, this is mitigated by having the gnome components shipped in the main package now and should be deferred to maverick.

Changed in thunderbird (Ubuntu Lucid):
status: Triaged → Won't Fix
Martin Pitt (pitti) on 2010-04-27
Changed in thunderbird (Ubuntu Lucid):
milestone: ubuntu-10.04 → none
Albert Zeyer (albertzeyer) wrote :

Can someone give me some useful workaround for now? I really want to have links working.

C de-Avillez (hggdh2) on 2010-08-26
tags: added: lucid regression-release
removed: regression-potential
Changed in thunderbird (Ubuntu):
milestone: ubuntu-10.04 → ubuntu-10.10
Simon Oosthoek (simon-margo) wrote :

Like Albert Zeyer says, please document the process/workaround that mitigates this for *ubuntu 10.04 in this bug.

I'm referring to Steve's comment:
> Per Chris, this is mitigated by having the gnome components shipped
> in the main package now and should be deferred to maverick.

tnx

Simon

Changed in thunderbird (Ubuntu):
milestone: ubuntu-10.10 → maverick-updates
Changed in thunderbird (Ubuntu Maverick):
milestone: none → maverick-updates
Adolfo Jayme (fitojb) on 2013-07-06
no longer affects: thunderbird (Ubuntu Lucid)
no longer affects: thunderbird (Ubuntu Maverick)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers