[lucid] thunderbird on lucid 64 bit doesn't work: Segmentation fault (core dumped)

Bug #532128 reported by matyi on 2010-03-04
46
This bug affects 8 people
Affects Status Importance Assigned to Milestone
thunderbird (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: thunderbird

[lucid] thunderbird 3 from repo on lucid 64 bit alpha 3 doesn't work: Segmentation fault (core dumped)

Do you have enigmail installed?

On 03/04/2010 01:35 PM, matyi wrote:
> Public bug reported:
>
> Binary package hint: thunderbird
>
> [lucid] thunderbird 3 from repo on lucid 64 bit alpha 3 doesn't work:
> Segmentation fault (core dumped)
>
>
>

matyi (nszm) wrote :

:$ I don't know, and I cannot see it now, because I came home. I can tell it to you on Sunday.

matyi (nszm) wrote :

No, I don't have Enigmail. Thunderbird removes it automatically, when I install it from the repository.

Micah Gersten (micahg) wrote :

Did apport catch the crash?

Changed in thunderbird (Ubuntu):
status: New → Incomplete

I have the same problem. Thunderbird crashes on startup. However, this only happens with one account. When I login with a different account, it runs without problems.

I tried to remove the configuration files (i.e. the .thunderbird directory) for the failing account without success. I also tried to copy the configuration for the other account. I can't figure out what makes the difference between the accounts.

btw: Although it says "core dumped", I can't find any dump on the disk. Apport also doesn't catch the crash.

I've found a difference between the account that works and the one that doesn't. The account where Thunderbird crashes is an LDAP account. There are no local entries in /etc/passwd. Instead, the account is managed via nss_ldap.

If I add the account to /etc/passwd with the same information as in LDAP, then it works.

With Karmic and Thunderbird 2 it did work without the entry in /etc/passwd.

jens7677 (jpeters7677) wrote :

Confirmed, same problem here, Thunderbird 3 segfaults if you use an ldap account.

Same problem here, not just on 64-bits but also on 32-bits Lucid. User accounts are in ldap, and after executing

'getent passwd demo >> /etc/passwd'

as root, the account demo can start thunderbird again.

Fabián Rodríguez (magicfab) wrote :

Thank you for reporting this bug. In order to get any developer attention I'd suggest trying to reproduce this using the latest Lucid desktop live CD and installing Thunderbird on it. Once installed, please try to reproduce the crash and document the steps here. Then please mark the bug again as "New".

zoolook (nbensa) wrote :

Workaroung: install nscd

Indeed, installing nscd works.
Fabian, I can reproduce this bug with a fresh installed lucid installation. However, it's a lot harder to reproduce with a live cd, since the live cd isn't set up to use ldap accounts. It would come down to installing and configuring an ldap server for user accounts on the live cd, and getting the live cd to authenticate against that. We can provide you with any strace or whatever other logs you would like to have.

Micah Gersten (micahg) wrote :

Is this a dupe of Bug #507089?

zoolook (nbensa) wrote :

I'd say yes. It's a dupe.

Thanks.

Micah Gersten (micahg) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 507089, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

matyi (nszm) wrote :

Hi

Today i found it out. In my profile folder was an old add-on, called fire-tray, which is not compatible with TB 3. I started TB like this: thunderbird --safe-mode, removed the addon, and now, everything working.

Matyi

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers