Thunderbird 3 hyperlinks broken

Bug #526290 reported by Hew on 2010-02-23
94
This bug affects 20 people
Affects Status Importance Assigned to Milestone
thunderbird (Ubuntu)
Low
Alexander Sack
Lucid
Low
Alexander Sack

Bug Description

Binary package hint: thunderbird

I have just upgraded to Thunderbird 3.0.1+nobinonly-0ubuntu1 on Lucid. Any hyperlink I click in an email pops up the "Launch Application" dialog. No default choices are present. My web browser in Preferred Applications is still set to Firefox, which was working with Thunderbird 2 right before the upgrade.

I have the same problem in this version 3.0.1

Hew (hew) on 2010-02-27
Changed in thunderbird (Ubuntu):
status: New → Confirmed
summary: - Thunderbird 3 hyperlinks broken with upgrade
+ Thunderbird 3 hyperlinks broken
summary: - Thunderbird 3 hyperlinks broken
+ Thunderbird 3 hyperlinks broken (3.0.1)
Jean-Louis Dupond (dupondje) wrote :

Its still broken in newest version (3.0.3+nobinonly-0ubuntu1)

summary: - Thunderbird 3 hyperlinks broken (3.0.1)
+ Thunderbird 3 hyperlinks broken
Alexander Sack (asac) wrote :

is thunderbird-gnome-support package installed?

i think we should do something similar to what we do in firefox where we ship the gnome components in the main package, but manually strip the gnome-depends and move them to the empty thunderbird-gnome-support package. in that way kubuntu users wont get polluted by just installing thunderbird, while gnome users that dont install -gnome-support still get gnome integration.

setting to low as i think the -gnome-support package is just not installed

Changed in thunderbird (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)
importance: Undecided → Low
status: Confirmed → Triaged
Alexander Sack (asac) wrote :

bzr commit -m '* fix LP: #526290 - Thunderbird 3 hyperlinks broken; installing
  the thunderbird-gnome-support package does not trigger component
  re-registration. This caused users that install thunderbird-gnome-support
  after first run without gnome integration until they upgrade/reinstall
  thunderbird main package. We fix this by adding a postinst.in/prerm.in
  for the -gnome-support package that touches $PKGLIBDIR/.autoreg to trigger
  component reregistration on next start.
  - add debian/thunderbird-gnome-support.postinst.in
  - add debian/thunderbird-gnome-support.prerm.in
  - update debian/rules' --fixes 'lp:526290'
Committing to: bzr+ssh://bazaar.launchpad.net/~mozillateam/thunderbird/thunderbird.head/
modified debian/changelog
modified debian/rules
added debian/thunderbird-gnome-support.postinst.in
added debian/thunderbird-gnome-support.prerm.in
Committed revision 143.

Changed in thunderbird (Ubuntu):
status: Triaged → Fix Committed
Alexander Sack (asac) wrote :

the depends/component shuffleing trick mentioned in #4 should be tracked in a separate bug.

Changed in thunderbird (Ubuntu):
assignee: Chris Coulson (chrisccoulson) → Alexander Sack (asac)
Alexander Sack (asac) wrote :

filed bug 543060 for the component shuffling mentioned above.

Alexander Sack (asac) wrote :

filed bug 543064 about us not using x-www-browser as a safety net.

emarkay (mrk) wrote :

From
http://ubuntuforums.org/showthread.php?p=9006611:

"Thunderbird-gnome-support" wasn't installed.
(Now I know to do this in the future on any reinstall of Thunderbird - All new installs need to have this added.)
But installing it does nothing, until you again reinstall Thunderbird3. (Luckily doing so did not overwrite or remove existing configurations). Now it works as before/intended.

On Mon, Mar 22, 2010 at 01:35:39AM -0000, emarkay wrote:
> >From
> http://ubuntuforums.org/showthread.php?p=9006611:
>
> "Thunderbird-gnome-support" wasn't installed.
> (Now I know to do this in the future on any reinstall of Thunderbird - All new installs need to have this added.)
> But installing it does nothing, until you again reinstall Thunderbird3. (Luckily doing so did not overwrite or remove existing configurations). Now it works as before/intended.

that "needs reinstall first" is fixed in .head. next upload will fix it.

 - Alexander

John Vivirito (gnomefreak) wrote :

emarkay:
By setting *-gnome-support as installed by default when installing Thunderbird is not some that is useful for KDE users

Changed in thunderbird (Ubuntu Lucid):
milestone: none → ubuntu-10.04-beta-2
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunderbird - 3.0.3+nobinonly-0ubuntu2

---------------
thunderbird (3.0.3+nobinonly-0ubuntu2) lucid; urgency=low

  * fix LP: #526290 - Thunderbird 3 hyperlinks broken; installing
    the thunderbird-gnome-support package does not trigger component
    re-registration. This caused users that install thunderbird-gnome-support
    after first run without gnome integration until they upgrade/reinstall
    thunderbird main package. We fix this by adding a postinst.in/prerm.in
    for the -gnome-support package that touches $PKGLIBDIR/.autoreg to trigger
    component reregistration on next start.
    - add debian/thunderbird-gnome-support.postinst.in
    - add debian/thunderbird-gnome-support.prerm.in
    - update debian/rules
  * fix LP: #527138 - enigmail is uninstallable in lucid, needs update to 1.0 - blocked
    by missing tbird sdk; add missing SDK and headers to thunderbird-dev package;
    this allows extensions with native components like enigmail and traybiff to build.
    To fix this we add INSTALL_SDK=1 to DEB_MAKE_EXTRA_ARGS in rules and add the
    appropriate paths to a fresh thunderbird-dev.install package.
    - update debian/rules
    - add debian/thunderbird-dev.install
  * fix SDK packaging for system-nspr/nss; we install links for nspr-config and
    /usr/include/nspr (and nss-config and /usr/include/nss) to the tbird sdk if
    system nspr/nss is used
    - update debian/rules
  * fix build failures on hardy-jaunty; DEB_MAKE_EXTRA_ARGS doesnt exist in the
    cdbs versions available there; using DEB_MAKE_ENVVARS is supposed to work
    everywhere; hence we use that to set INSTALL_SDK
    - update debian/rules
  * the sdk binaries (xpt_* and xpidl) seems to get not installed for applications
    != xulrunner; we work around by patching toolkits packager.mk to install them
    into "installdir"
    - add debian/patches/fix_install_sdk_bin.patch
    - update debian/patches/series
  * mailnews does not install enough mime headers for enigmail when using
    INSTALL_SDK=1; we add nsStreamConverter.h, mimecryp.h and mimemoz2.h to
    EXPORT.
    - add debian/patches/fix_sdk_install_mimecrypt.patch
    - update debian/patches/series
  * install xpidl and xpt_link/xpt_dump to pkglibdir of thunderbird-dev package
    - update debian/thunderbird-dev.install
 -- Alexander Sack <email address hidden> Mon, 22 Mar 2010 23:51:02 +0100

Changed in thunderbird (Ubuntu Lucid):
status: Fix Committed → Fix Released

Well, I've just installed exactly that version and I'm getting exactly the same error, so I don't know what's going on here.

Alexander Sack (asac) wrote :

On Wed, Mar 31, 2010 at 07:55:03PM -0000, Christopher Neville-Smith wrote:
> Well, I've just installed exactly that version and I'm getting exactly
> the same error, so I don't know what's going on here.

you need to install thunderbird-gnome-support ...

 - Alexander

Rolf Leggewie (r0lf) wrote :

how about bumping thunderbird-gnome-support from suggests to recommends? I think many people will run into this issue.

Alexander Sack (asac) wrote :

On Wed, Apr 07, 2010 at 10:05:21AM -0000, Rolf Leggewie wrote:
> how about bumping thunderbird-gnome-support from suggests to recommends?
> I think many people will run into this issue.

read the bug log ;) ... that was discussed above iirc.

 - Alexander

It would be nice if something in ubuntu-desktop depended on thunderbird-gnome-support, it _seems_ like it won't be included in a default OS install to me, though I might be wrong about this.

Alexander Sack (asac) wrote :

On Wed, Apr 07, 2010 at 11:58:47AM -0000, Michael Hudson wrote:
> It would be nice if something in ubuntu-desktop depended on thunderbird-
> gnome-support, it _seems_ like it won't be included in a default OS
> install to me, though I might be wrong about this.

thunderbird wont be included by default at all ... which makes this tricky.

I tried to lobby for going with tbird by default instead of evo, but noone
listened ;)

anyway, the real fix is adding a fallback to the thunderbird.js that uses xdg-open

 - Alexander

ullix (ullix) wrote :

Installing thunderbird-gnome-support did help in the way that firefox is now proposed when clicking on a http: or https: link, but why tb even asking, when I have set my preferences in the 'preferred applications'?

Now tb is offering the right programs for viewing pdf, gif, tiff, but it has no idea about png files. all it does is to offer me to save it (or cancel).

I have other problems with tb, it has become too smart and too eager to do prefetch and store everything, so now on my netbook, with a slow SSD, I am bogged down by all the writing of tb to the hard disk. The tb 2.x was much easier to use. Maybe it is time to take a look at alternatives.

axx (axx) wrote :

I can say installing thunderbird-gnome-support fixed this issue for me.

http and https links now open on their own in Firefox, which is set as me default browser in Preferred Applications (with "Open link in new tab" as an option).

Alexander Sack (asac) wrote :

On Wed, Apr 07, 2010 at 05:25:28PM -0000, ullix wrote:
> Installing thunderbird-gnome-support did help in the way that firefox is
> now proposed when clicking on a http: or https: link, but why tb even
> asking, when I have set my preferences in the 'preferred applications'?

maybe you tweaked the application tab or something which causes this now?

 - Alexander

frizzle21 (frederik-nnaji) wrote :

is this fixed already?

my system is Ubuntu Lucid Beta

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.9) Gecko/20100415 Thunderbird/3.0.4 ("About")

is there a patch i should test already?

Alexander Sack (asac) wrote :

On Tue, Apr 20, 2010 at 06:55:14PM -0000, frederik.nnaji wrote:
> is this fixed already?
>
> my system is Ubuntu Lucid Beta
>
> Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.9) Gecko/20100415
> Thunderbird/3.0.4 ("About")
>
> is there a patch i should test already?

read the bug log man ;) ... install thunderbird-gnome-support. done.

 - Alexander

frizzle21 (frederik-nnaji) wrote :

thanks for the patch alex!
i was referring to whether this was fixed in the distribution updates yet...

where does this katastrophe originate? upstream mozilla dev?
cause i find it hard to believe that a desktop application in 2010 seriously
has problems opening links in a browser.
we have xdg-utils for that sort of thing, so that platform doesnt matter any
more. is thunderbird aware of xdg-open?
i'll just wait and watch..
thanks again..

On Wed, Apr 21, 2010 at 12:29, Alexander Sack <email address hidden> wrote:

> On Tue, Apr 20, 2010 at 06:55:14PM -0000, frederik.nnaji wrote:
> > is this fixed already?
> >
> > my system is Ubuntu Lucid Beta
> >
> > Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.9) Gecko/20100415
> > Thunderbird/3.0.4 ("About")
> >
> > is there a patch i should test already?
>
> read the bug log man ;) ... install thunderbird-gnome-support. done.
>
> - Alexander
>

Hervé Guétin (herve-guetin) wrote :

Guys,

Tried everything suggested here and there : install thunderbird-gnome-support, setting preferred apps in Ubuntu's system preferences, adding

user_pref("network.protocol-handler.app.http", "/usr/bin/firefox");
user_pref("network.protocol-handler.app.https", "/usr/bin/firefox");
user_pref("network.protocol-handler.app.ftp", "/usr/bin/firefox");

to my profile's prefs.js

No success at all.

No luck in left-clicking on a link in a mail nor in right-clicking > Open link in browser.

Shall I bang my head harder on the wall ? :)

Thanks for your appreciated help.

FF : Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.9) Gecko/20100401 Ubuntu/9.10 (karmic) Firefox/3.5.9

TB3 w/ lightning : Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.5) Gecko/20091204 Lightning/1.0b2pre Thunderbird/3.0

neuromancer (neuromancer) wrote :

I had this problem on Karmic Koala with TB 3.0.1 installed from Mozilla's binary.
Upgrading to 3.0.4 (always installing Mozilla's binary downloaded from mozilla.org) has fixed, in my case, the problem.
In another machine I have Lucid Linx with TB 3.04 installed from official repository and all work ok, also without Thunderbird gnome support.

@ neuromancer: Here's kudos for the trendy name!

-- Gesendet von meinem Palm Pre

------------------------------
neuromancer <email address hidden> schrieb am 24.05.2010 01:50:

I had this problem on Karmic Koala with TB 3.0.1 installed from Mozilla's
binary.
Upgrading to 3.0.4 (always installing Mozilla's binary downloaded from
mozilla.org) has fixed, in my case, the problem.
In another machine I have Lucid Linx with TB 3.04 installed from official
repository and all work ok, also without Thunderbird gnome support.

--
Thunderbird 3 hyperlinks broken
https://bugs.launchpad.net/bugs/526290
You received this bug notification because you are a direct subscriber
of the bug.

Status in “thunderbird” package in Ubuntu: Fix Released
Status in “thunderbird” source package in Lucid: Fix Released

Bug description:
Binary package hint: thunderbird

I have just upgraded to Thunderbird 3.0.1+nobinonly-0ubuntu1 on Lucid. Any
hyperlink I click in an email pops up the "Launch Application" dialog. No
default choices are present. My web browser in Preferred Applications is
still set to Firefox, which was working with Thunderbird 2 right before the
upgrade.

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/ubuntu/+source/thunderbird/+bug/526290/+subscribe

Hervé Guétin (herve-guetin) wrote :

Ok - great.
I upgraded to TB 3.0.4. (via TB's menu Help > Check for updates)
Hyperlinks work.
Lightning not.
So I reinstalled the lightning add-on from https://addons.mozilla.org/en-US/thunderbird/addon/2313/
And now everything is back on track.
Thanks again for helping.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments