Printing multiple messages to file, gets overwritten

Bug #509665 reported by Orin77 on 2010-01-19
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Mozilla Thunderbird
Unknown
Unknown
thunderbird (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: thunderbird

When printing multiple messages (in one go) to a file, only the last message ends up in the file. Apparently the file gets overwritten for each message.

I expected the file to contain all messages.

To reproduce:
1. Select multiple messages.
2. File -> Print... , select Print To File. Printer "PostScript/default". Enter filename and click Print.
3. View generated PostScript file (in Evince, for example) to see it only contains the last message.

This on Ubuntu 9.10, Thunderbird version 2.0.0.23 (20090817).

ProblemType: Bug
Architecture: i386
Date: Tue Jan 19 15:36:58 2010
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
NonfreeKernelModules: nvidia
Package: mozilla-thunderbird (not installed)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-17.54-genUser Name
SourcePackage: thunderbird
Uname: Linux 2.6.31-17-generic i686
---
AddonCompatCheckDisabled: False
ApportVersion: 2.20.7-0ubuntu3.9
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: eric 2196 F.... pulseaudio
BuildID: 20180522092515
Channel: Unavailable
CurrentDesktop: ubuntu:GNOME
DistroRelease: Ubuntu 17.10
Extensions: extensions.sqlite corrupt or missing
ForcedLayersAccel: False
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
IncompatibleExtensions: Unavailable (corrupt or non-existant compatibility.ini or extensions.sqlite)
InstallationDate: Installed on 2017-06-04 (391 days ago)
InstallationMedia: Ubuntu 17.04 "Zesty Zapus" - Release amd64 (20170412)
IpRoute:
 default via 192.168.178.1 dev wlp14s0 proto static metric 600
 169.254.0.0/16 dev wlp14s0 scope link metric 1000
 192.168.178.0/24 dev wlp14s0 proto kernel scope link src 192.168.178.27 metric 600
Locales: extensions.sqlite corrupt or missing
Package: thunderbird 1:52.8.0+build1-0ubuntu0.17.10.1
PackageArchitecture: amd64
PrefSources: prefs.js
ProcVersionSignature: Ubuntu 4.13.0-45.50-generic 4.13.16
Profiles: Profile0 (Default) - LastVersion=52.8.0/20180522092515 (In use)
RunningIncompatibleAddons: False
Tags: artful wayland-session
Themes: extensions.sqlite corrupt or missing
Uname: Linux 4.13.0-45-generic x86_64
UpgradeStatus: Upgraded to artful on 2018-01-06 (175 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 11/13/2012
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: V2.13
dmi.board.asset.tag: Type2 - Board Asset Tag
dmi.board.name: VA70_HC
dmi.board.vendor: Acer
dmi.board.version: Type2 - Board Version
dmi.chassis.type: 10
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnInsydeCorp.:bvrV2.13:bd11/13/2012:svnAcer:pnAspireV3-771:pvrV2.13:rvnAcer:rnVA70_HC:rvrType2-BoardVersion:cvnChassisManufacturer:ct10:cvrChassisVersion:
dmi.product.family: Type1Family
dmi.product.name: Aspire V3-771
dmi.product.version: V2.13
dmi.sys.vendor: Acer

Orin77 (eppie) wrote :
gf (gf-interlinks) wrote :

Hello Orin,
Thank you for submitting this bug and reporting a problem with Thunderbird.

You made this bug report in 2010 and there have been several versions of Ubuntu and Thunderbird since then.

Could you confirm that this is no longer a problem and that we can close the ticket?
Or, if it is still a problem, could you run the following (only once):
apport-collect 509665

and upload the updated logs and and any other logs that are relevant for this particular issue.

Thank you again for helping make Ubuntu and Thunderbird better.

G

Changed in thunderbird (Ubuntu):
status: New → Incomplete
Orin77 (eppie) wrote : AlsaInfo.txt

apport information

tags: added: apport-collected artful wayland-session
description: updated
Orin77 (eppie) wrote : CRDA.txt

apport information

apport information

apport information

Orin77 (eppie) wrote : IpAddr.txt

apport information

Orin77 (eppie) wrote : IwConfig.txt

apport information

Orin77 (eppie) wrote : Lspci.txt

apport information

apport information

Orin77 (eppie) wrote : Prefs.txt

apport information

apport information

apport information

Orin77 (eppie) wrote : PulseList.txt

apport information

Orin77 (eppie) wrote : RfKill.txt

apport information

apport information

Orin77 (eppie) wrote :

Hello gf,

Thank you for taking care of this bug report. The bug is still valid: printing multiple messages to a file results in only the last message being printed in the file.

I've added the apport-collect information as requested.

To reproduce the bug, please refer to the 3 simple steps in the initial bug report.

Thank you for your time and effort to make things better.

Orin

gf (gf-interlinks) wrote :

Hi Orin,
Thanks for the update. I have changed the status back to New. Next step: I will try to recreate the bug on my computer over the next few days.
Take care
G

Changed in thunderbird (Ubuntu):
status: Incomplete → New
gf (gf-interlinks) wrote :

Hi Orin,
I have Thunderbird 52.9.1 (64-bit) and I am on Ubuntu 18.04.

I tried the steps above but they are slightly different.

To reproduce:
1. Select multiple messages
2. Click on menu in the top right of the window
3. Click Print...
4. Select Print To File
5. Select Postscript or PDF (no difference)
6. Enter filename
7. Click the green "Print" button at top right of window

I have a different result than you do.
I selected three emails. The first gets printed to the file. The second and third get printed on the regular printer. No difference if Postscript or PDF is selected (both produce same result).

What version of Ubuntu and Thunderbird are you using?
Thanks
G

gf (gf-interlinks) wrote :

Searched for dups – no dups found on either ubuntu-bugs or mozilla bugzilla.

G

Orin77 (eppie) wrote :

Hi gf,

I'm using Thunderbird 52.9.1 (64-bit), on Ubuntu 17.10 (64-bit).

As I don't have a printer, I can't confirm your findings about the other messages being printed to the printer. I did install a (dummy) printer(-driver), to see if the messages would end up in the queue. They did not appear there, but that might be because there is no actual printer attached.

My exact reproduction scenario:

In an open Thunderbird:

1) Select a message by single-click;
2) Select second message by Control-click;
3) Select third message by Control-click;
4) Click on "hamburger menu", in upper-right corner to open menu;
5) Choose "Print..." from menu;
6) Choose "Print to File", select Output format PDF, leave filename at default "~/mozilla.pdf";
7) Click green button "Print" in upper right corner;
8) A popup flashes a few times, indicating the messages being printed.

Check file "~/mozilla.pdf" with a PDF viewer (I used Evince)

The file only contains the LAST message from the selection.

I also tried a variation, after selecting three messages, Control-click the first one twice (which deselects it, and then re-selects it). After that, continue with step 4 above. This also prints only the LAST message to the file. So it seems the selection is printed in order, not "last selected first", or some such.

regards,
Orin

gf (gf-interlinks) wrote :

Thanks for the clarification, Orin. I will try your steps and get back to you.
:)
G

gf (gf-interlinks) wrote :

Hi Orin,
I have tested this in several versions of Thunderbird:
52.9.1 (64-bit)
57.0b2 (64-bit)
60.0 (64-bit)
I get the same result as you do.
I will report to Mozilla on this.
Thanks for detailing the steps.
:)
G

gf (gf-interlinks) wrote :

One more thing, Orin.
Would you say that this one is a feature/enhancement request? I need to specify that when I create a bug report on the Mozilla bug site.
:)
G

Changed in thunderbird (Ubuntu):
status: New → Confirmed
Orin77 (eppie) wrote :

Hi GF,

I don't feel this is a feature request or an enhancement. To me, it really is more of a bug or defect. The current behavior of the print-to-PDF functionality is unexpected for the user as it deviates from printing-to-printer and has no beneficial side effect. (i.e. there is no scenario, that I can see, that would benefit from current behavior over the, well, 'correct' behavior).

I suspect fixing this issue might not be all that difficult, I can imagine that the code does something like this:

FOR EACH SELECTED MESSAGE
  OPEN PRINTING DEVICE OR FILE
  PRINT MESSAGE
  CLOSE PRINTING DEVICE OR FILE
END

This works well for actual printers, and would explain the current behavior with printing to PDF. It might be fixed by rewriting it too something like this:

OPEN PRINTING DEVICE OR FILE
FOR EACH SELECTED MESSAGE
  PRINT MESSAGE
END
CLOSE PRINTING DEVICE OR FILE

Mind, this is a very high level description, and without looking at the actual code it remains to be seen if this is the root cause. However, I do think it is something like this.

Thanks again for your willingness to help with fixing this issue!

Regards,
Orin

gf (gf-interlinks) wrote :

Hi Orin,
Thanks for the update. Yes, you are right. I see your point that the current behaviour would not be desirable by anyone; therefore, it is a bug. I hope it is as easy to change as you described.

I have created an "upstream" bug report at the Thunderbird/Mozilla bug report site called Bugzilla. And I have linked that bug report to this one.

Here is the link to the other report:
https://bugzilla.mozilla.org/show_bug.cgi?id=1484558

Please feel free to monitor that bug's progress and/or make comments there on that website.

Now that this bug report is confirmed, hopefully they will action it soon. Though, I must advise that it will likely be classified as a low priority ticket. It may take a long time for them to action it, as the programmers themselves are also volunteers. Thank you for your patience. I will keep an eye on this ticket to watch for progress.

Hope you are well.

G

C de-Avillez (hggdh2) wrote :

Importance set to low following gf2's request on #ubuntu-bugs.

Changed in thunderbird (Ubuntu):
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.