Thunderbird 3 Shows only English dictionary in Spell menu

Bug #509248 reported by Nikolaus Rath on 2010-01-18
46
This bug affects 8 people
Affects Status Importance Assigned to Milestone
thunderbird (Ubuntu)
Medium
Micah Gersten
Lucid
Medium
Micah Gersten

Bug Description

Binary package hint: thunderbird

The currrent thunderbird-3.0 build shows only "English" in the spell menu when composing messages, even if other hunspell or myspell dictionaries are installed.

Confirmed by micahg on #ubuntu-mozillateam:

(12:28:21 PM) Nikratio: Is it a known bug that thunderbird-3.0 shows only the English dictionary in the Spell menu, even if other hunspell or myspell languages are installed?
(12:29:49 PM) ***micahg can see the issue
(12:30:04 PM) micahg: Nikratio: please file a bug and tag ppa
(12:30:13 PM) micahg: in thunderbird package

Tags: ppa Edit Tag help
Nikolaus Rath (nikratio) on 2010-01-18
Changed in thunderbird (Ubuntu):
status: New → Confirmed
Micah Gersten (micahg) on 2010-01-18
summary: - [PPA] Shows only English dictionary in Spell menu
+ [PPA] Thunderbird 3 Shows only English dictionary in Spell menu
Changed in thunderbird (Ubuntu):
assignee: nobody → Micah Gersten (micahg)
importance: Undecided → Medium
status: Confirmed → Triaged

This also affects me. I have the thunderbird-locale-en-gb and myspell-en-gb packages installed. Thunderbird shows the language pack correctly installed under 'Tools > Add-ons > Languages'. However, I am only able to select the United States English dictionary when composing email.

Current package versions (Lucid):
thunderbird: 3.0.4+nobinonly-0ubuntu1
thunderbird-locale-en-gb: 1:3.0-0ubuntu2
myspell-en-gb: 1:3.2.0-2ubuntu2

This problem is caused by Thunderbird not correctly linking the myspell dictionaries into '/usr/lib/thunderbird-3.0.4/dictionaries/'. I believe there are two possible solutions to this problem:

1) Link Thunderbird's dictionaries directory to the myspell dictionaries directory. This is the solution currently used by Firefox:
  '/usr/lib/thunderbird-3.0.4/dictionaries -> ../../share/myspell/dicts'
  c.f. '/usr/lib/firefox-3.6.3/dictionaries -> ../../share/myspell/dicts'.

2) Link the individual dictionaries at the thunderbird-locale level. This would probably entail making the locale package dependant on the appropriate myspell dictionary pack, e.g.:
  thunderbird-locale-en-gb:
    Depends: myspell-en-gb

  '/usr/lib/thunderbird-3.0.4/dictionaries/en-GB.dic -> ../../../share/myspell/dicts/en-GB.dic'
  '/usr/lib/thunderbird-3.0.4/dictionaries/en-GB.aff -> ../../../share/myspell/dicts/en-GB.aff'.

Toltech (robert-toltech) wrote :

Tested the above suggestion and it worked, I would suggest making this link

Xavier Claessens (zdra) wrote :

I confirm that the solution works:

sudo ln -s /usr/share/myspell/dicts/ /usr/lib/thunderbird-3.0.4/dictionaries

then restart thunderbird and all dictionaries are now listed.

Micah Gersten (micahg) on 2010-04-20
summary: - [PPA] Thunderbird 3 Shows only English dictionary in Spell menu
+ Thunderbird 3 Shows only English dictionary in Spell menu
Changed in thunderbird (Ubuntu Lucid):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunderbird - 3.0.4+nobinonly-0ubuntu4

---------------
thunderbird (3.0.4+nobinonly-0ubuntu4) lucid; urgency=low

  [ Micah Gersten <email address hidden> ]
  * fix LP: #509248 - Thunderbird 3 Shows only English dictionary in Spell
    menu; Don't install Thunderbird dictionaries; Link Thunderbird dictionaries
    folder to system dictionaries; Create symlink in postinst if dictionaries
    dir is empty
    - update debian/thunderbird.postinst.in
    - update debian/thunderbird.install
    - update debian/rules

  [ Chris Coulson <email address hidden> ]
  * Fix LP: #543060 - gnome integration should work even without -gnome-support.
    Move the gnome components to the main thunderbird package whilst using
    thunderbird-gnome-support to pull in the gnome dependencies:
    - update debian/rules
    - remove debian/thunderbird-gnome-support.postinst.in
    - remove debian/thunderbird-gnome-support.prerm.in
    - add replaces/breaks to thunderbird on previous versions of
      thunderbird-gnome-supportm to ensure the upgrade works
 -- Chris Coulson <email address hidden> Tue, 20 Apr 2010 16:18:24 +0100

Changed in thunderbird (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers